You are not logged in.

#1 2012-06-17 09:14:06

Lockheed
Member
Registered: 2010-03-16
Posts: 1,461

error -110 whilst initialising SD card

When I enter my 8GB Class 6 Samsung MicroSD card into the cardreader (mmc), 4 times out of 5 it does not mount. dmesg gives this:

error -110 whilst initialising SD card

I am not sure, but it appears to be timeout issue (the system does not wait long enough?).

The behaviour of the card in the mobile phone:
The same card mounts perfectly fine each and every time on Android 2.4 and/or ClockWordMod bootloader, but on Android 4 and/or 4ext bootloader it exhibits the same issues as on Arch.

Last edited by Lockheed (2012-06-17 09:16:08)


Laptop: ThinkPad T420s, i7/i5, 16GB RAM, 1080p IPS mod, Arch | HTPC/Server/fw: Zotac AQ01, A4-5000 Kabini, 8GB, Arch/lxd NethServer

Offline

#2 2012-06-25 10:51:53

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: error -110 whilst initialising SD card

Same problem here on a XPS M1330. Since the last two kernel updates my Samsung 16GB class6 SD card won't get mounted. Dmesg gives me the same error message.

I think this is a kernel driver problem, as others have this error too:
https://bbs.archlinux.org/viewtopic.php … 8#p1118218


sorry for my bad english smile

Offline

#3 2012-06-30 22:10:38

Lockheed
Member
Registered: 2010-03-16
Posts: 1,461

Re: error -110 whilst initialising SD card

Try removing and reinserting the card several times. Mine usually mounts once in ever 7 times.


Laptop: ThinkPad T420s, i7/i5, 16GB RAM, 1080p IPS mod, Arch | HTPC/Server/fw: Zotac AQ01, A4-5000 Kabini, 8GB, Arch/lxd NethServer

Offline

#4 2012-07-03 21:58:23

iggy
Member
From: Germany, L.E. - Leipzig
Registered: 2004-10-17
Posts: 367

Re: error -110 whilst initialising SD card

This is not really a fix for the problem. No one else having this error?


sorry for my bad english smile

Offline

#5 2015-02-14 19:30:33

friendofarch
Member
Registered: 2013-12-30
Posts: 53

Re: error -110 whilst initialising SD card

Did you find a solution back than? I have the same problem for the first time today!

Offline

#6 2015-02-14 19:43:51

Lockheed
Member
Registered: 2010-03-16
Posts: 1,461

Re: error -110 whilst initialising SD card

The problem is that some cards are just too slow to initialise, and kernel gives up on waiting for them.
For mobile phone,  there is no solution other than using older kernel (in some GingerBread ROM) or changing the SD card.
For computer, just change the card. I don't think it's worth the trouble trying to solve it in other ways.

Last edited by Lockheed (2015-02-14 19:46:08)


Laptop: ThinkPad T420s, i7/i5, 16GB RAM, 1080p IPS mod, Arch | HTPC/Server/fw: Zotac AQ01, A4-5000 Kabini, 8GB, Arch/lxd NethServer

Offline

Board footer

Powered by FluxBB