You are not logged in.

#1 2012-06-23 17:28:49

cjpembo
Member
Registered: 2008-08-06
Posts: 105

[CLOSED] Gnome 3 hangs after login

Gnome 3 has been hanging approx half the time I boot up.

I login via gdm.  dbus is loaded first.  I get my gnome wallpaper loaded - mouse cursor and keyboard both work - but the gnome desktop is non-responsive.  I cannot access menu items in the upper-left corner and the icons in the upper-right corner status area show that the network and possibly audio have not yet loaded.  I use dhcp via eth0.  I've tried both /etc/rc.d/network and /etc/rc.d/networkmanager - both give the same result - about 50% failure.  I'm not saying I don't get my ip address set: just that gnome is hung and not responding.  I can switch to a terminal and use the network.

When it boots fine, it is absolutely stable and fast.

Let me know which log files would be most useful and I'll post them.

And I will create a new user and try loging-in with that account to rule out a simple config error.  This account is about 8 months old - and worked flawlessly up until about a month ago.

Thanks

Last edited by cjpembo (2012-06-27 04:58:19)

Offline

#2 2012-06-24 20:25:07

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 392

Re: [CLOSED] Gnome 3 hangs after login

cjpembo wrote:

Gnome 3 has been hanging approx half the time I boot up.

I login via gdm.  dbus is loaded first.  I get my gnome wallpaper loaded - mouse cursor and keyboard both work - but the gnome desktop is non-responsive.  I cannot access menu items in the upper-left corner and the icons in the upper-right corner status area show that the network and possibly audio have not yet loaded.  I use dhcp via eth0.  I've tried both /etc/rc.d/network and /etc/rc.d/networkmanager - both give the same result - about 50% failure.  I'm not saying I don't get my ip address set: just that gnome is hung and not responding.  I can switch to a terminal and use the network.

When it boots fine, it is absolutely stable and fast.

Let me know which log files would be most useful and I'll post them.

And I will create a new user and try loging-in with that account to rule out a simple config error.  This account is about 8 months old - and worked flawlessly up until about a month ago.

Thanks

Please post your daemons from /etc/rc.conf and which video card you have and which drivers.


Registered Linux user #436067

Offline

#3 2012-06-25 05:21:47

cjpembo
Member
Registered: 2008-08-06
Posts: 105

Re: [CLOSED] Gnome 3 hangs after login

Dual nVidia GeForce GTX 560
nVidia-ck driver version 302.17
Linux version 3.4.3-1-ck (x86_64)

DAEMONS=(syslog-ng dbus networkmanager gdm cupsd crond)

Offline

#4 2012-06-25 05:28:57

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: [CLOSED] Gnome 3 hangs after login

Try putting gdm at the end of your DAEMONS array, after crond.

Offline

#5 2012-06-25 07:30:32

nowahn
Member
From: elsewhere
Registered: 2008-12-05
Posts: 75

Re: [CLOSED] Gnome 3 hangs after login

Hi,

Quite the same bug here (gnome3, network tray icon showing the network is not configured, but it is when I switch to ttys).
But there are some differences:

  • only something like 5% failure.

  • not starting gdm from the daemons array in rc.conf (starting Xorg from inittab instead)

  • Not the same hardware:

    • Intel integrated graphic card.

    • default linux kernel (3.4.4-1)

    • system installed 4 month ago, don't know whether the bug was present from the beginning.

I noticed that doing killall Xorg in a tty (as root) restart Xorg and it has always been working for me after that (except that it starts in tty8 instead of tty7).

Did you try top in a tty to see if something is hanging ? (I thought of it just after the last time it bugged, and I had no opportunity to try it since then.)

Last edited by nowahn (2012-06-25 07:32:07)


take time to daydream, inspiration comes ...

Offline

#6 2012-06-25 21:19:32

cjpembo
Member
Registered: 2008-08-06
Posts: 105

Re: [CLOSED] Gnome 3 hangs after login

I have not changed anything yet... but the last 6 boots have been flawless.  I'm either on a roll of good luck or something got updated.  If I can get it to fail again, I'll start poking around more.  Several weeks of gnome misbehaving; I ask the question and it starts behaving again.  The gnome knows it's being watched - so it is behaving.  Tricksy little hobbits !

Offline

#7 2012-06-27 04:57:45

cjpembo
Member
Registered: 2008-08-06
Posts: 105

Re: [CLOSED] Gnome 3 hangs after login

The issue seems to have vanished.  No problems at all in the past dozen+ boots.  Closed....

Offline

#8 2012-06-27 07:45:23

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,281

Re: [CLOSED] Gnome 3 hangs after login

cjpembo, please do not use the term "CLOSED" for a solved thread. This is reserved for threads set made read only by the mods.
See the Forum Etiquette
Pleases change the CLOSED mark into SOLVED as soon as possible.


To know or not to know ...
... the questions remain forever.

Offline

Board footer

Powered by FluxBB