You are not logged in.

#1 2012-06-30 05:00:35

Registered: 2010-11-04
Posts: 11

Kernel panic while/after system upgrade

Hello all,

I'm not sure whether this issue is restricted to the [testing] repository. However, since it only occurs on system upgrading, I suppose it is.

Now, the problem is: I start a complete system upgrade (pacman -Syu), everything starts going well but, in the middle of the installation process, I get a kernel panic.
This happens every time I try to run the system upgrade, on my two laptops (both with [testing] activated). In addition, one of them started getting these kernel panics while booting, after I tried upgrading a few times. This was when I tried to run the upgrade on the other laptop. Obviously, I stopped trying after the first failure ;D

Some specific information:

renato@renato  ~ 
$ uname -a
Linux renato 3.3.6-1-ARCH #1 SMP PREEMPT Sun May 13 10:52:32 CEST 2012 x86_64 GNU/Linux

The kernel panic, with some previous log during boot on the other laptop ([...] is omitted information):

:: Triggering uevents...done.
:: performing fsck on '/dev/disk/by-uuid/9a[...]1b1'
/dev/sda3: clean, 26[...]/76[...] files, 25[...]/30[...] blocks
:: mounting '/dev/disk/by-uuid/9a[...]1b1' on real root
switch_root: failed to execute /bin/systemd: Input/output error
[      1.785077] Kernel panic - not syncing: Attempted to kill init!
[      1.785207] Pid: 1, comm: switch_root Not tainted 3.3.4-2 ARCH #1
[      1.785353] Call Trace:
[      1.785488]   [<ffffffff81456185>] panic+0xba/0x1c6
[      1.785630]   [<ffffffff81053e63>] do_exit+0x873/0x900
[      1.785775]   [<ffffffff8105423f>] do_group_exit+0x3f/0xa0
[      1.785920]   [<ffffffff810542b7>] sys_exit_group+0x17/0x20
[      1.786067]   [<ffffffff8145fe69>] system_call_fastpath+0x16/0x1b

I have read a similar error in another thread, and it seems that deleting ./usr/lib/locale/locale-archive and reinstalling pacman and libarchive this problem could be solved. But I don't have a LiveCD to do that now on the other laptop, and it's strange that I can't upgrade on any of them, anyway.

Suggestions? smile


EDIT: I've been able to spot the point where the crash occurs during the system upgrade. It downloads all the files, checks them, and then:
(1) upgrades linux-api-headers
(2) starts upgrading glibc
        - enters "generating locales"

Then the same crash.

EDIT 2: I tried to boot a Live CD on the other laptop to reinstall glibc. However, I am not able to install anything, pacman gives me a load of errors.
I can't be sure if this is related to the issue, but here is what I tried to do:

- Boot from Live CD
- Mount my root and /var partitions on /mnt
- Find the glibc package to install on /mnt/var/cache/pacman/pkg/
- Install with pacman -U <package> -r /mnt/

Then I get:

looking for inter-conflicts...
error: could not open file /mnt/var/lib/pacman/local/glibc-2.15-12/desc: No such file or directory (this one repeats many, many times)
Proceed with installation? [Y/n] checking package integrity...
checking for file conflicts...
error: could not open file /mnt/var/lib/pacman/local/glibc-2.15-12/desc: No such file or directory (again, appears many times)
glibc: /mnt/etc/gai.conf exists in filesystem

Then loads of "exists in filesystem" errors, for exaple:

(many files on /mnt/usr/include, /mnt/usr/lib, etc.)

I also tried reinstalling another package, libarchive. In addition to the first line of error (about the "desc" file), I also get:

(1/1) upgrading libarchive
call to execv failed (Exec format error)
error: command failed to execute correctly

Would it be safe to try forcing the glibc installation?

Last edited by Renato_Ferreira (2012-06-30 14:40:56)


#2 2012-07-02 17:42:30

Registered: 2009-12-21
Posts: 8

Re: Kernel panic while/after system upgrade

Renato_Ferreira wrote:

Would it be safe to try forcing the glibc installation?

I had this exact same thing happen to my laptop. I believe it should be safe to force the glibc installation; I did it, and it does not seem to have caused any trouble.


Board footer

Powered by FluxBB