You are not logged in.

#1 2012-07-13 19:42:10

C6M6
Member
Registered: 2012-07-13
Posts: 36

[SOLVED]hda-intel spurius response, and other hda-intel related errors

from the errors log file, i've got a lots of this messages plus some other errors.... it don't seem to be dangerous apart from flooding the error.log file, is there a solution to this problem?

my aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and also the /proc/asound/card0/codec response:

Codec: IDT 92HD81B1X5

shortened errors.log

[   42.350936] hda-intel: spurious response 0x0:0x0, last cmd=0x370100
[   42.350940] hda-intel: spurious response 0x0:0x0, last cmd=0x370100
[   42.350942] hda-intel: spurious response 0x0:0x0, last cmd=0x370100
......
[   42.351265] hda-intel: spurious response 0x0:0x0, last cmd=0x370100
[   42.351267] hda-intel: spurious response 0x0:0x0, last cmd=0x370100
[   42.351268] hda-intel: spurious response 0x0:0x0, last cmd=0x370100
[   42.448961] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[   44.354111] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x003f0700
[   45.355751] hda-intel: No response from codec, disabling MSI: last cmd=0x003f0700
[   46.800055] hda-intel: spurious response 0x1002aa01:0x0, last cmd=0x170503
[   46.800063] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.800067] hda-intel: spurious response 0x100200:0x0, last cmd=0x170503
[   46.800072] hda-intel: spurious response 0x10001:0x0, last cmd=0x170503
[   46.800076] hda-intel: spurious response 0x1:0x0, last cmd=0x170503
[   46.800079] hda-intel: spurious response 0x20002:0x0, last cmd=0x170503
[   46.800084] hda-intel: spurious response 0x201:0x0, last cmd=0x170503
[   46.800087] hda-intel: spurious response 0x400381:0x0, last cmd=0x170503
[   46.800091] hda-intel: spurious response 0x18560010:0x0, last cmd=0x170503
[   46.800096] hda-intel: spurious response 0x40:0x0, last cmd=0x170503
[   46.800099] hda-intel: spurious response 0xaa0100:0x0, last cmd=0x170503
[   46.800103] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.800107] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.800111] hda-intel: spurious response 0x20002:0x0, last cmd=0x170503
[   46.800115] hda-intel: spurious response 0x201:0x0, last cmd=0x170503
[   46.800119] hda-intel: spurious response 0x20070:0x0, last cmd=0x170503
[   46.800123] hda-intel: spurious response 0x1:0x0, last cmd=0x170503
[   46.800127] hda-intel: spurious response 0x400381:0x0, last cmd=0x170503
[   46.800131] hda-intel: spurious response 0x94:0x0, last cmd=0x170503
[   46.800135] hda-intel: spurious response 0x18560010:0x0, last cmd=0x170503
[   46.800139] hda-intel: spurious response 0x1:0x0, last cmd=0x170503
[   46.800142] hda-intel: spurious response 0x2:0x0, last cmd=0x170503
[   46.800146] hda-intel: spurious response 0x9:0x0, last cmd=0x170503
[   46.800150] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.800154] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.800158] hda-intel: spurious response 0x94:0x0, last cmd=0x170503
[   46.800162] hda-intel: spurious response 0x7fffffff:0x0, last cmd=0x170503
[   46.800166] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.800170] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.800174] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
.......
[   46.801062] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.801066] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   46.801069] hda-intel: spurious response 0x0:0x0, last cmd=0x170503
[   47.801538] hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x00170500
[   48.813711] hda-codec: out of range cmd 0:0:3:707:ffffffff
[   48.814462] hda-codec: out of range cmd 0:0:3:707:ffffffbf

Thanks in advance to anyone who can help

Last edited by C6M6 (2012-07-17 22:51:55)

Offline

#2 2012-07-13 21:26:19

brebs
Member
Registered: 2007-04-03
Posts: 3,401

Re: [SOLVED]hda-intel spurius response, and other hda-intel related errors

I think you should post that to the ALSA bugzilla, so they can either fix it or silence the messages.

Offline

#3 2012-07-17 16:11:50

C6M6
Member
Registered: 2012-07-13
Posts: 36

Re: [SOLVED]hda-intel spurius response, and other hda-intel related errors

after some test the issue is related to the second graphic card, if the pc start with the second card turned off (i've disabled it at boot from rc.local) those errors appears, otherwise they don't
i've tried to disable the audio card at boot with "radeon.audio=0" in the kernel line but it doesn't function, blacklisting only the hdmi codec doesn't function either..., is there any other way to disable the hdmi audio card?

Offline

#4 2012-07-17 16:38:58

brebs
Member
Registered: 2007-04-03
Posts: 3,401

Re: [SOLVED]hda-intel spurius response, and other hda-intel related errors

Can probably use probe_mask - google it.

Offline

#5 2012-07-17 22:50:51

C6M6
Member
Registered: 2012-07-13
Posts: 36

Re: [SOLVED]hda-intel spurius response, and other hda-intel related errors

after some test with probe_mask, i've found out that it wasn't exactly what i was searching for, so i've started tryng some other snd_hda_intel parameters, in particular probe_only was the one i've been searching, it probe the card but don't initialize the codec, so those erros don't appear if the sound card is switched-off at boot time (i've also removed the module snd_hda_codec_hdmi, before switching off the discrete card, but i don't think it's a necessary step to stop those warning/errors).
after i've created a sound.conf in the modprobe.d directory with

options snd_hda_intel probe_only=0,1

hopefully it may be useful to someone else

thanks brebs for the help

Last edited by C6M6 (2012-07-17 23:04:07)

Offline

#6 2014-08-25 13:05:17

xub14.04
Member
Registered: 2014-08-25
Posts: 1

Re: [SOLVED]hda-intel spurius response, and other hda-intel related errors

your solution worked for me too and helped a lot, thanks

Offline

Board footer

Powered by FluxBB