You are not logged in.

#1 2005-08-12 18:33:10

tuxman
Member
From: Ensenada Mexico
Registered: 2005-08-12
Posts: 51

gaim doesnt work with msn

hi,
I have installed the latest gaim in arch but it i cant login into msn messenger, it gives a plugin error message while yahoo works fine.
I use gaim in debian with the same configuration and login no problem.
Is that a package or plugin problem?


thanks

tuxman

Offline

#2 2005-08-12 18:54:05

Arn0
Member
From: the Netherlands
Registered: 2005-03-13
Posts: 49

Re: gaim doesnt work with msn

I'm using Gaim as well and don't have any problem with MSN. Have you tryd reinstalling it


Whenever you are asked if you can do a job, tell 'em, 'Certainly I can!' Then get busy and find out how to do it.

Offline

#3 2005-08-12 19:43:46

max_sipos
Member
From: Ithaca, NY
Registered: 2004-10-31
Posts: 106
Website

Re: gaim doesnt work with msn

I also use gaim with MSN and it works properply for me.

What plugin is it complaining about?

Did you try disabling plugins in Preferences?

Offline

#4 2005-08-12 22:25:07

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: gaim doesnt work with msn

get the latest update.
MSN play mardy b*stards and keep changing the code/protocol just to p*ss off opensource community.

Offline

#5 2005-08-12 23:16:27

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,436
Website

Re: gaim doesnt work with msn

how childish they are

Offline

#6 2005-08-16 17:46:25

tuxman
Member
From: Ensenada Mexico
Registered: 2005-08-12
Posts: 51

Re: gaim doesnt work with msn

I did reinstall gaim twice and now get the message " unable to log in" and the user has been disconnectd.
of course my username and password are correct and Im not getting the same problem in gain neither under debian nor windows.


thanks

tuxman

Offline

#7 2005-08-16 17:54:21

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: gaim doesnt work with msn

did you update your local  pacman list by using pacman -Ssy gaim

the y to ensure you get the latest releases.

or - check which version of gaim you are using, and compare to the latest from the gaim homesite..

i had the exact same probs ( " unable to log in" and the user has been disconnected)
and it was down to the version number.
maybe make sure you uninstall fully including any config files - then grab the most recent Gaim.

my sys
===============
[root@localhost ~]# pacman -Q gaim   
gaim 1.3.0-2

[root@localhost ~]# pacman -Ssy gaim
:: Synchronizing package databases..
current/gaim 1.5.0-1
    A GTK+-based messaging client
extra/gaim-encryption 2.38-1
    A Gaim plugin providing transparent RSA encryption using NSS
================
even im out of date !


hth

Offline

#8 2005-08-17 15:14:13

Meshuggin
Member
From: /home/meshuggin
Registered: 2005-03-23
Posts: 137

Re: gaim doesnt work with msn

I have ...

(meshuggin:~$) pacman -Q gaim
gaim 1.5.0-1

... And no problems at all (default configuration)


Arch GNU/Linux 0.7.1 (Noodle)
Linux 2.6.14-archck1

Offline

#9 2005-08-20 03:14:11

tuxman
Member
From: Ensenada Mexico
Registered: 2005-08-12
Posts: 51

Re: gaim doesnt work with msn

weird,
I removed gaim
# pacman -R --nosave gaim
reinstalled gaim 1.5.0-1
same problem, still can't login into msn
i was even wondering if it couldnt be a firewall issue when i setup adsl (firewall level 1)
cos gaim never gave me any problem before


thanks

tuxman

Offline

#10 2005-08-20 03:18:00

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: gaim doesnt work with msn

have you tried removing your ~/.gaim folder?
That should erase all settings.

Offline

#11 2005-08-20 09:40:46

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: gaim doesnt work with msn

try run gaim from a terminal like so,

gaim --debug

might give you better feedback on the msn rejection.

Offline

#12 2005-08-23 02:32:50

tuxman
Member
From: Ensenada Mexico
Registered: 2005-08-12
Posts: 51

Re: gaim doesnt work with msn

I tried the #gaim --debug code and this is the result
at some point it seems to complain about some missing file.
might that be the problem?

[root@tuxman ~]# gaim --debug
sound: Initializing sound output drivers.
plugins: registering plugin-load signal
plugins: registering plugin-unload signal
plugins: probing /usr/lib/gaim/libnovell.la
plugins: probing /usr/lib/gaim/libnovell.so
plugins: probing /usr/lib/gaim/gaim-remote.la
plugins: probing /usr/lib/gaim/gaim-remote.so
plugins: probing /usr/lib/gaim/libirc.la
plugins: probing /usr/lib/gaim/libirc.so
plugins: probing /usr/lib/gaim/libmsn.la
plugins: probing /usr/lib/gaim/libmsn.so
plugins: probing /usr/lib/gaim/timestamp.la
plugins: probing /usr/lib/gaim/timestamp.so
plugins: probing /usr/lib/gaim/libzephyr.la
plugins: probing /usr/lib/gaim/libzephyr.so
plugins: probing /usr/lib/gaim/statenotify.la
plugins: probing /usr/lib/gaim/statenotify.so
plugins: probing /usr/lib/gaim/libyahoo.la
plugins: probing /usr/lib/gaim/libyahoo.so
plugins: probing /usr/lib/gaim/ssl-gnutls.la
plugins: probing /usr/lib/gaim/ssl-gnutls.so
plugins: probing /usr/lib/gaim/notify.la
plugins: probing /usr/lib/gaim/notify.so
plugins: probing /usr/lib/gaim/gestures.la
plugins: probing /usr/lib/gaim/gestures.so
plugins: probing /usr/lib/gaim/ssl-nss.la
plugins: probing /usr/lib/gaim/ssl-nss.so
plugins: probing /usr/lib/gaim/libjabber.la
plugins: probing /usr/lib/gaim/libjabber.so
plugins: probing /usr/lib/gaim/iconaway.la
plugins: probing /usr/lib/gaim/iconaway.so
plugins: probing /usr/lib/gaim/history.la
plugins: probing /usr/lib/gaim/history.so
plugins: probing /usr/lib/gaim/spellchk.la
plugins: probing /usr/lib/gaim/spellchk.so
plugins: probing /usr/lib/gaim/tcl.la
plugins: probing /usr/lib/gaim/tcl.so
plugins: probing /usr/lib/gaim/ssl.la
plugins: probing /usr/lib/gaim/ssl.so
plugins: probing /usr/lib/gaim/relnot.la
plugins: probing /usr/lib/gaim/relnot.so
plugins: probing /usr/lib/gaim/liboscar.la
plugins: probing /usr/lib/gaim/liboscar.so
plugins: probing /usr/lib/gaim/extplacement.la
plugins: probing /usr/lib/gaim/extplacement.so
plugins: probing /usr/lib/gaim/idle.la
plugins: probing /usr/lib/gaim/idle.so
plugins: probing /usr/lib/gaim/perl.la
plugins: probing /usr/lib/gaim/perl.so
plugins: probing /usr/lib/gaim/libgg.la
plugins: probing /usr/lib/gaim/libgg.so
plugins: probing /usr/lib/gaim/libnapster.la
plugins: probing /usr/lib/gaim/libnapster.so
plugins: probing /usr/lib/gaim/ticker.la
plugins: probing /usr/lib/gaim/ticker.so
plugins: probing /usr/lib/gaim/docklet.la
plugins: probing /usr/lib/gaim/docklet.so
plugins: probing /usr/lib/gaim/autorecon.la
plugins: probing /usr/lib/gaim/autorecon.so
plugins: probing /root/.gaim/smileys
plugins: probing /root/.gaim/accounts.xml
plugins: registering plugin-load signal
plugins: registering plugin-unload signal
plugins: registering plugin-load signal
plugins: registering plugin-unload signal
prefs: Reading /root/.gaim/prefs.xml
prefs: Reading /usr/etc/gaim/prefs.xml
prefs: Error reading prefs: Failed to open file '/usr/etc/gaim/prefs.xml': No su                                                                                      ch file or directory
pounces: Error reading pounces: Failed to open file '/root/.gaim/pounces.xml': N                                                                                      o such file or directory
status: Error reading statuses: Failed to open file '/root/.gaim/status.xml': No                                                                                       such file or directory
Session Management: No SESSION_MANAGER found, aborting.
account: Connecting to account 0x81e55e0. gc = 0x81e53a0
connection: Connecting. gc = 0x81e53a0
connection: Calling serv_login
server: gaim 1.5.0 logging in amc252@hotmail.com using MSN
msn: new httpconn (0x81eca08)
dns: Created new DNS child 4057, there are now 1 children.
dns: Host 'messenger.hotmail.com' resolved
proxy: Connecting to messenger.hotmail.com:1863 with no proxy
proxy: Connect would have blocked.
proxy: Connected.
msn: C: NS 000: VER 1 MSNP9 MSNP8 CVR0
msn: S: NS 000: VER 1 MSNP9 MSNP8 CVR0
msn: C: NS 000: CVR 2 0x0409 winnt 5.1 i386 MSNMSGR 6.0.0602 MSMSGS amc252@hotma                                                                                      il.com
msn: S: NS 000: CVR 2 7.0.0816 7.0.0816 6.2.0205 http://msgr.dlservice.microsoft                                                                                      .com/download/4/b/c/4bc83bb2-18dd-486f-943f-332a9b3e01dc/Install_MSN_Messenger_D                                                                                      L.exe http://messenger.msn.com
msn: C: NS 000: USR 3 TWN I amc252@hotmail.com
msn: S: NS 000: XFR 3 NS 207.46.4.76:1863 0 65.54.239.210:1863
dns: Successfully sent DNS request to child 4057
dns: Host '207.46.4.76' resolved
proxy: Connecting to 207.46.4.76:1863 with no proxy
proxy: Connect would have blocked.
proxy: Connected.
msn: C: NS 000: VER 4 MSNP9 MSNP8 CVR0
msn: S: NS 000: VER 4 MSNP9 MSNP8 CVR0
msn: C: NS 000: CVR 5 0x0409 winnt 5.1 i386 MSNMSGR 6.0.0602 MSMSGS amc252@hotma                                                                                      il.com
msn: S: NS 000: CVR 5 7.0.0816 7.0.0816 6.2.0205 http://msgr.dlservice.microsoft                                                                                      .com/download/4/b/c/4bc83bb2-18dd-486f-943f-332a9b3e01dc/Install_MSN_Messenger_D                                                                                      L.exe http://messenger.msn.com
msn: C: NS 000: USR 6 TWN I amc252@hotmail.com
msn: S: NS 000: USR 6 TWN S lc=1033,id=507,tw=40,fs=1,ru=http%3A%2F%2Fmessenger%                                                                                      2Emsn%2Ecom,ct=1124763820,kpp=1,kv=7,ver=2.1.6000.1,rn=!3sYkZev,tpf=4dea9054ca78                                                                                      bbaa13882baaa179827b
dns: Successfully sent DNS request to child 4057
dns: Host 'nexus.passport.com' resolved
proxy: Connecting to nexus.passport.com:443 with no proxy
proxy: Connect would have blocked.
proxy: Connected.
gnutls: Handshaking
gnutls: Handshake failed. Error -67
account: Disconnecting account 0x81e55e0
connection: Disconnecting connection 0x81e53a0
msn: destroy httpconn (0x81eca08)
blist: Destroying
connection: Destroying connection 0x81e53a0
accounts: Writing accounts to disk.
main: Unloading all plugins
plugins: Unloading plugin GroupWise
plugins: Unloading plugin IRC
plugins: Unloading plugin MSN
plugins: Unloading plugin Zephyr
plugins: Unloading plugin Yahoo
plugins: Unloading plugin GNUTLS
plugins: Unloading plugin Jabber
plugins: Unloading plugin Tcl Plugin Loader
plugins: Unloading plugin SSL
plugins: Unloading plugin AIM/ICQ
plugins: Unloading plugin Perl Plugin Loader
plugins: Unloading plugin Gadu-Gadu
plugins: Unloading plugin Napster
prefs: /gaim/gtk/plugins/loaded changed, scheduling save.
GLib: g_hash_table_foreach: assertion `hash_table != NULL' failed
dns[4057]: Oops, father has gone, wait for me, wait...!
[root@tuxman ~]#


thanks

tuxman

Offline

#13 2005-08-23 17:18:31

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: gaim doesnt work with msn

think gnutls may be where the problem is.

gnutls: Handshaking
gnutls: Handshake failed. Error -67

looking up the error code, we find:-

GNUTLS_E_ASN1_ELEMENT_NOT_FOUND -67

so maybe check what version of gnutls you have running
pacman -Q gnutls
and then
pacman -S  gnutls

gnutls is a transport layer security thing, and maybe Msn is rejecting what it thinks maybe a malformed packet.

This could also explain why it works in Deb and not in Arch. ie its a dependency failing, not Gaim.

Not sure as these will help, but at least its working towards some resolution, not just "wtf happens!"

good luck
smile

Offline

#14 2005-08-25 05:02:42

tuxman
Member
From: Ensenada Mexico
Registered: 2005-08-12
Posts: 51

Re: gaim doesnt work with msn

I agree, this is about learning everyday a bit more about my system.
I did reinstall gnutls and gaim and the problem persists.
it must definitely be some sort of conflict cos I checked my debian version of gaim and is much older than the one in arch


thanks

tuxman

Offline

#15 2005-12-24 18:48:45

Cotton
Member
From: Cornwall, UK
Registered: 2004-09-17
Posts: 548

Re: gaim doesnt work with msn

Is this still a problem?

Offline

#16 2005-12-26 00:45:54

Cotton
Member
From: Cornwall, UK
Registered: 2004-09-17
Posts: 548

Re: gaim doesnt work with msn

I had the problem until I disabled the testing repository then reinstalled openssl, gaim & gnutls (and also loudmouth to meet a gnutls version dependency).

FWIW, this resulted in the following versions: gaim 1.5.0-2, gnutls-1.2.9-2, loudmouth-1.0.1-1 & openssl-0.9.7h-1

Offline

#17 2005-12-27 14:01:04

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: gaim doesnt work with msn

Offline

#18 2005-12-27 22:40:28

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 464

Re: gaim doesnt work with msn

funny you should mention, recently im getting a lot of segfaults too.
not sure why tho, variety of progs.

maybe time for a thorough clean up, update et al.

Offline

Board footer

Powered by FluxBB