You are not logged in.

#1 2005-08-13 01:26:29

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

dbus not staying up [solved]

Hi,

I upgraded to dbus 0.35.2-1 and it seems to just disappear.

Offline

#2 2005-08-13 03:08:52

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: dbus not staying up [solved]

what makes you say its disappering?
ls /var/run/daemons shows it not there?

can you provide more info?

Offline

#3 2005-08-13 03:57:05

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: dbus not staying up [solved]

I first noticed because hal was dead.  Then, looking at the hal messages, it was a problem with dbus.  With dbus 0.34-1:

ps -ef | grep dbus
nobody    5822     1  0 18:24 ?        00:00:00 /usr/bin/dbus-daemon --system

With dbus 0.35.2-1 I see nothing.  Looking through var/log I cannot find any dbus messages.  The process (looking at /var/run/dbus.pid) is just not there.

Offline

#4 2005-08-13 04:01:03

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: dbus not staying up [solved]

I was looking through the man pages and I see the problem might be /etc/dbus-1/system.conf in the new version specifies the non-existant messagebus user.  I will try adding that or changing back to nobody.

Update:
I added a user 'messagebus' and now dbus is working again.

Offline

#5 2005-08-13 06:08:48

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: dbus not staying up [solved]

Thanks, I also had this problem since yesterday but was to sleepy to resolve it...


Microshaft delenda est

Offline

#6 2005-08-13 22:07:36

colnago
Member
From: Victoria, BC
Registered: 2004-03-25
Posts: 438

Re: dbus not staying up [solved]

I posted a bug but it seems I was trigger happy.  Changing the /etc/dbus-1/system.conf file is the way to go...

Task closed (Fixed: Seems choosing dbus user is now possible from configure smile)

Offline

Board footer

Powered by FluxBB