You are not logged in.

#1 2012-07-19 01:30:18

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 163

[SOLVED] FGLRX on ASUS A53T - can't start X

Radeon driver works fine; switched to proprietary to test another issue I'm having (ignore for now). 
Problem: X doesn't start.  See below. Thanks in advance.

Relevant Xorg Errors:   

[    12.873] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled
[    12.873] (EE) fglrx(0): Invalid video BIOS signature!
[    12.873] (EE) fglrx(0): GetBIOSParameter failed
[    12.873] (EE) fglrx(0): PreInitAdapter failed
[    12.873] (EE) fglrx(0): PreInit failed
[    12.873] (II) fglrx(0): === [xdl_xs112_atiddxPreInit] === end
[    12.873] (II) fglrx(0): Interrupt handler Shutdown.
[    12.877] (II) UnloadModule: "fglrx"
[    12.878] (II) UnloadSubModule: "fglrxdrm"
[    12.878] (II) Unloading fglrxdrm
[    12.878] (II) UnloadSubModule: "fglrxdrm"
[    12.878] (EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
[    12.878] no screens found

Full Xorg.0.log

OS configs: 

xorg.conf (created by aticonfig --initial)

GRUB

rc.conf

mkinitcpio.conf

Kernel 3.4.5-1 (64bit)

Hardware info:

lspci

lshw

I've install catalyst-total from AUR, ran mkinitcpio with the fglrx module (this is done automatically) and added nomodeset to GRUB.  I've also tried falling back to the old xserver (as per the wiki) but it made no difference.  I also tried blacklisting the radeon driver.  Furthermore, the fgrlx driver works in Ubuntu (I had installed it on a separate drive as a test).

Any ideas?




EDIT: Fixed. See comment #4

Last edited by yochaigal (2012-07-21 13:57:24)

Offline

#2 2012-07-19 01:43:56

jwele
Member
Registered: 2012-07-03
Posts: 62

Re: [SOLVED] FGLRX on ASUS A53T - can't start X

Found this
http://www.x.org/wiki/FAQErrorMessages# … figuration.

Last edited by jwele (2012-07-19 01:45:17)

Offline

#3 2012-07-19 01:53:37

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 163

Re: [SOLVED] FGLRX on ASUS A53T - can't start X

I've found something else - in kernel.log this error started cropping up:

Jul 18 05:51:29 localhost kernel: [    5.167163] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167186] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167197] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167207] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167217] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167227] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167238] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167248] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167258] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167268] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167279] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167289] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167299] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167309] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167320] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167330] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167341] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167351] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167361] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167371] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167381] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167392] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167409] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
Jul 18 05:51:29 localhost kernel: [    5.167426] vgaarb: this pci device is not a vga device
Jul 18 05:51:29 localhost kernel: [    5.167437] vgaarb: this pci device is not a vga device

Last edited by yochaigal (2012-07-19 02:01:31)

Offline

#4 2012-07-21 13:54:13

yochaigal
Member
From: Boston
Registered: 2011-02-06
Posts: 163

Re: [SOLVED] FGLRX on ASUS A53T - can't start X

Fixed!

I got fglrx to work by REMOVING the BusID parameter from xorg.conf!
X started, but then had an ugly AMD watermark.  I removed this by running the script listed here.

Last edited by yochaigal (2012-07-21 13:57:45)

Offline

#5 2012-07-21 16:05:54

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,178

Re: [SOLVED] FGLRX on ASUS A53T - can't start X

I am glad you solved the problem.

Please do not cross post -- https://bbs.archlinux.org/viewtopic.php?id=145195

Closing.  If there is need for additional conversation, please continue in the other thread.

Edit: Reopened thread

Last edited by ewaller (2012-07-21 23:21:55)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#6 2012-07-21 23:26:26

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,178

Re: [SOLVED] FGLRX on ASUS A53T - can't start X

yochaigal,

I saw your PM.  I have not had a few good days -- I have made several errors moderating these forums.

Regardless, let me publicly apologize to you for my accusation you had cross posted.  Indeed, you did not.  I get to your beautiful city every couple years.  Next time I pass through, maybe I can buy you a beer.

ewaller


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB