You are not logged in.

#1 2005-08-15 13:41:04

whargoul
Member
From: Odense, Denmark
Registered: 2005-04-04
Posts: 546

Show danish characters in Aterm.

I got a little problem with mig aterm. When I am trying to write the danish characters in Aterm (æøå).
How di I set lanuage in aterm? I currently have my ~/.Xdefaults this way:

# A cool aterm ;-)

aterm*title: Cool terminal
aterm*loginShell: true
#aterm*font: -*-courier-medium-r-semicondensed-*-12-*-*-*-*-*-iso8859-1
aterm*font: -*-lucida-medium-r-normal-sans-10-100-75-75-p-66-iso8859-1
aterm*foreground: White
aterm*background: Black
aterm*saveLines: 6000
aterm*transparent: true
aterm*scrollBar: true
aterm*transpscrollbar: true
aterm*shading: 40
aterm*language: da_DK.ISO8859-15

Arch - It's something refreshing

Offline

#2 2005-08-15 17:54:15

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Show danish characters in Aterm.

you'll probably need to change your keyboard mapping. For me, typing
setxkbmap dk
enable me to type those symbols in aterm. If that works for you , you can change KEYMAP in rc.conf (it will affect the whole system) or add setxkbmap dk to your .bashrc (it will only affect your terminal and console)

Offline

#3 2005-08-15 18:55:43

whargoul
Member
From: Odense, Denmark
Registered: 2005-04-04
Posts: 546

Re: Show danish characters in Aterm.

Nope not working.

I should have said this before. It is only Aterm that has that problem. Xterm and Gnome Terminal is working fine.


Arch - It's something refreshing

Offline

#4 2005-08-15 22:30:59

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Show danish characters in Aterm.

I assume that you can also  input danish symbols in other apps like your editor, etc. Here's what I have in .Xdefault

aterm*transparent: true
aterm*scrollBar_right: true
aterm*transpscrollbar: true
aterm*saveLines: 32767
aterm*scrollTtyOutput: false
aterm*foreground: white
aterm*background: black
aterm*shading: 50
aterm*tintingType: true
#aterm*tinting: #c0c0c0
aterm*tinting: white
aterm*fading: 50

Try commenting:
aterm*language: da_DK.ISO8859-15
as language is not a valid variable. You can also try to comment/change your aterm*font.  Maybe that font doesn't support these characters.  I don't know what else to suggest.

EDIT: do you have latest aterm package?

Offline

#5 2005-08-15 23:03:51

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: Show danish characters in Aterm.

Could there be something amiss with the locale settings? Try

LC_CTYPE=da_DK aterm

Offline

#6 2005-08-16 14:12:26

whargoul
Member
From: Odense, Denmark
Registered: 2005-04-04
Posts: 546

Re: Show danish characters in Aterm.

Wow, thanks sh__, that just worked just fine. Thank you very much.  big_smile


Arch - It's something refreshing

Offline

#7 2005-08-16 14:32:29

whargoul
Member
From: Odense, Denmark
Registered: 2005-04-04
Posts: 546

Re: Show danish characters in Aterm.

No it didn't work just fine. It's only temporary. When I start a new Aterm I have the same problem.

Snowman: I have tried that one before, and it didn't work.
The latest aterm? Everytime I turn on my computer, I make sure my packages are upgraded. So I have version  1.0.0-1.


Arch - It's something refreshing

Offline

#8 2005-08-16 14:51:09

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: Show danish characters in Aterm.

Add

export LC_CTYPE=da_DK aterm

to your ~/.bashrc .


·¬»· i am shadowhand, powered by webfaction

Offline

Board footer

Powered by FluxBB