You are not logged in.

#1 2012-07-24 23:38:32

Onyros
Member
From: Lisbon, Portugal
Registered: 2007-10-11
Posts: 294

[SOLVED] vconsole.conf not setting up console font

I bit the bullet and changed from SysVinit to systemd, everything is pretty ironed up apart from the console font, which even though I added

FONT="ter-112n"

to vconsole.conf doesn't seem to affect the console font. Using

setfont ter-112n

works and changes the font accordingly.

I also tried adding both the keymap and consolefont hooks to mkinitcpio.conf, but I suppose it's not reading the consolefont option from vconsole.conf, as it threw out an error when booting and also defaulted to the usual console font. My rc.conf only lists daemons now.

Anyone else with this problem? Anyone with suggestions on how to enable the console font in this case?

edit: BTW, when I first set up the keymap in vconsole.conf, it only applied to the first tty; I circumvented this pretty much by chance, by adding double quotes, and now all ttys use the keymap I inserted there, in my case...

KEYMAP="pt-latin1"

Last edited by Onyros (2012-07-25 10:00:42)

Offline

#2 2012-07-24 23:48:12

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: [SOLVED] vconsole.conf not setting up console font

This is my working vconsole.conf. Does the file /usr/lib/systemd/system/sysinit.target.wants/systemd-vconsole-setup.service exist?

 % cat /etc/vconsole.conf
KEYMAP=de-latin1
FONT=lat9w-16
FONT_MAP=8859-1_to_uni

PS: If you use systemd, you should really get rid of rc.conf. It could be that the compattibilty-script always expects all configuration in rc.conf and when it is missing, then the default is used regardless of the systemd config files.
Find the matching systemd services and enable them, e.g.:
cron: cronie.service if you didn't switch the implementation
networkmanager: NetworkManager.service
ntpd: ntpd.service
Then remove the initscripts and install systemd-sysvcompat and systemd-sysvinit (AUR)

Last edited by progandy (2012-07-24 23:54:54)

Offline

#3 2012-07-25 00:11:22

Onyros
Member
From: Lisbon, Portugal
Registered: 2007-10-11
Posts: 294

Re: [SOLVED] vconsole.conf not setting up console font

I do have the systemd-vconsole-setup-service file, also tried your config, to no avail. It must be related to the compatibility script, indeed, even though when I set the consolefont back in the rc.conf - just to test it out - it still didn't load the font.

Still not ready - or sure - to ditch the initscripts for now. I am still testing systemd out before making the jump, but boy, do I miss just having to list the daemons, instead of having to scour for services tongue

Offline

#4 2012-07-25 09:14:38

d2ogch3n
Member
Registered: 2010-01-20
Posts: 42

Re: [SOLVED] vconsole.conf not setting up console font

I have the same issue here. I have tried both with keeping SysV scripts and with pure systemd as I have now. I've tested systemd twice previously over some months and never managed to get the terminus consolefont to load.

Incedentally Onyros you probably know but you can filter systemctl to only show services like;

$ systemctl -t service

Offline

#5 2012-07-25 09:45:59

Onyros
Member
From: Lisbon, Portugal
Registered: 2007-10-11
Posts: 294

Re: [SOLVED] vconsole.conf not setting up console font

Yes, I checked if the service had run or not, and this is what I got:

systemd-vconsole-setup.service       loaded active exited      Setup Virtual Console

I really can't get any font to load, it's not just terminus. I think there may be a solution here though. I'll try this later on and come back to report whether it was solved or not.

Last edited by Onyros (2012-07-25 10:03:22)

Offline

#6 2012-07-25 10:00:11

Onyros
Member
From: Lisbon, Portugal
Registered: 2007-10-11
Posts: 294

Re: [SOLVED] vconsole.conf not setting up console font

That's it smile

Tried the first solution and it worked, I didn't have i915 (in my case, for Intel graphics) module in mkinitcpio.conf.

Just added

MODULES="i915"

to /etc/mkinitcpio.conf, regenerated with

mkinitcpio -p linux

Rebooted and... voilá: terminus font on console.

Now, for the alternative methods, I know one can see the systemd order with

systemctl --order

but I still have to check on how to change said order.

I didn't notice my system booting any slower because I used this option, therefore I'm keeping it. Please feel free to add your experiences with both options 2 and 3 on that mailing list post.

Offline

#7 2012-07-25 15:43:00

d2ogch3n
Member
Registered: 2010-01-20
Posts: 42

Re: [SOLVED] vconsole.conf not setting up console font

Thanks Onyros, adding the module to /etc/mkinitcpio.conf worked for me too.

Offline

#8 2012-07-25 15:51:05

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: [SOLVED] vconsole.conf not setting up console font

Just FYI, the same problem occurred with initscripts: https://bugs.archlinux.org/task/29781 and https://bugs.archlinux.org/task/30482

Offline

Board footer

Powered by FluxBB