You are not logged in.

#1 2012-07-29 08:41:42

b52
Member
From: Germany
Registered: 2009-03-20
Posts: 49
Website

[SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

Hey fellas,

I didn't update my system for about five months but yesterday I went
the painful road of making my laptop up2date.

Well, turns out wlan stopped working...

[  276.000828] wlan0: authenticate with 00:16:01:d2:1c:c8
[  276.001982] wlan0: send auth to 00:16:01:d2:1c:c8 (try 1/3)
[  276.004925] wlan0: authenticated
[  276.006715] wlan0: associate with 00:16:01:d2:1c:c8 (try 1/3)
[  276.009164] wlan0: RX AssocResp from 00:16:01:d2:1c:c8 (capab=0x411 status=0 aid=5)
[  276.014551] wlan0: associated
[  285.140301] wlan0: deauthenticating from 00:16:01:d2:1c:c8 by local choice (reason=3)
[  285.149158] cfg80211: Calling CRDA to update world regulatory domain
[  285.154482] cfg80211: World regulatory domain updated:
[  285.154488] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  285.154496] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  285.154504] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  285.154510] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  285.154517] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  285.154524] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  285.154552] cfg80211: Calling CRDA for country: DE
[  285.160217] cfg80211: Regulatory domain changed to country: DE
[  285.160224] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  285.160232] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  285.160238] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  285.160245] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[  285.160251] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[  285.167273] iwlwifi 0000:0c:00.0: L1 Enabled; Disabling L0S
[  285.170304] iwlwifi 0000:0c:00.0: Radio type=0x1-0x2-0x0
[  285.937756] e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
[  286.040423] e1000e 0000:00:19.0: irq 45 for MSI/MSI-X

I have Dell Latitude E4300 using wicd with IPv6 disabled.

Suggestions and ideas are welcome.

Thanks a lot!

Last edited by b52 (2012-08-14 12:35:55)


srsly?

Offline

#2 2012-07-29 10:32:58

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

What wifi chipset? What driver?

Offline

#3 2012-07-29 12:15:59

b52
Member
From: Germany
Registered: 2009-03-20
Posts: 49
Website

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

# lspci -vvv
...
0c:00.0 Network controller: Intel Corporation WiFi Link 5100
	Subsystem: Intel Corporation WiFi Link 5100 AGN
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 47
	Region 0: Memory at f69fe000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
		Address: 00000000fee0300c  Data: 41a9
	Capabilities: [e0] Express (v1) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
			MaxPayload 128 bytes, MaxReadReq 128 bytes
		DevSta:	CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <128ns, L1 <32us
			ClockPM+ Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
	Capabilities: [100 v1] Advanced Error Reporting
		UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UESvrt:	DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
		CESta:	RxErr- BadTLP+ BadDLLP- Rollover- Timeout- NonFatalErr+
		CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
		AERCap:	First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-
	Capabilities: [140 v1] Device Serial Number 00-22-fb-ff-ff-52-d1-64
	Kernel driver in use: iwlwifi
% uname -a
Linux ruffneck 3.4.6-1-ARCH #1 SMP PREEMPT Fri Jul 20 08:21:26 CEST 2012 x86_64 GNU/Linux

srsly?

Offline

#4 2012-07-29 23:32:36

marcs
Member
From: Italy
Registered: 2007-09-07
Posts: 59

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

I got the same problem with my netbook (eeepc s101) that has wireless adapter: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
Same kernel of b52 but 32 bit version. Maybe is related with the new /etc/protocols /etc/services files and the changes with rc.conf ?

Offline

#5 2012-07-30 17:18:05

mzanetti
Member
Registered: 2008-09-05
Posts: 27

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

Same problem here, downgrading initscripts to 2012.06.3-2 seems to work around it for now.

Offline

#6 2012-07-31 17:57:00

marcs
Member
From: Italy
Registered: 2007-09-07
Posts: 59

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

The downgrade of initscripts worked for me too.

Offline

#7 2012-08-08 22:59:36

tastalian
Member
Registered: 2012-08-08
Posts: 1

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

Same problem here, downgrading (temporarily) solved the issue.

Has anyone filed a bug report on this?

Offline

#8 2012-08-10 02:41:35

whimse
Member
Registered: 2012-08-10
Posts: 1

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

I had both 'network' and 'networkmanager' enabled in rc.conf DAEMONS.
Disable 'network' and leave only 'networkmanager', and it helps me out. smile

Reference link: https://bugs.archlinux.org/task/30892

Last edited by whimse (2012-08-10 02:48:24)

Offline

#9 2012-08-14 12:35:38

b52
Member
From: Germany
Registered: 2009-03-20
Posts: 49
Website

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

I solved the problem by removing "wicd" and all wicd related directories/files like described in https://wiki.archlinux.org/index.php/Wicd


srsly?

Offline

#10 2012-11-06 20:29:23

kokesssss
Member
Registered: 2012-11-06
Posts: 6

Re: [SOLVED] wlan0: deauthenticating from * by local choice (reason=3)

I've suffered with simillar problem. I'm using netcfg. Solution on my machine was to completely leave sysvinit and initscripts and fully move to systemd.

Offline

Board footer

Powered by FluxBB