You are not logged in.

#1 2012-07-29 23:58:32

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 278
Website

[SOLVED]Stuck connect to gateway w/static IP on i686 w/2012.07.15 CD

Trying to install i686 from the 2012.07.15 CD on a test machine. (note: DHCP is not an option on this local network)

The local network has a gateway that is a combination router/firewall/DNS server.

If I use the manual method:

ip addr add <ip address>/<netmask> dev <interface>
ip route add default via <ip address>

After putting in the gateway, the console returns:

RTNETLINK answers:No such process

If I append "/etc/rc.conf" with:

interface=eth0
address=192.168.0.3
netmask=255.255.255.0
broadcast=192.168.0.255
gateway=192.168.0.1

also correcting the HOSTNAME

And then adding the nameserver to the "/etc/resolv.conf" and the hostname to "/etc/hosts"

then restarting the network with

rc.d restart network

I get connect: Network is unreachable when pinging the computers addr or the gateway, and I get a response when pinging 127.0.0.1.

If I run "ip a" there is no inet line with the host IP address in it.  If I run "ip r" there is a null return'

Any ideas?

Last edited by keepitsimpleengineer (2012-08-04 01:46:32)


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#2 2012-07-30 10:28:16

Minsc
Member
Registered: 2012-07-16
Posts: 78

Re: [SOLVED]Stuck connect to gateway w/static IP on i686 w/2012.07.15 CD

Use ifconfig instead of ip to setup your NIC:

ifconfig eth0 192.168.0.3
route add default gateway 192.168.0.1

It could be a problem with the ethernet drivers and the above ifconfig command will fail if this is the case.

Edit: fixed ip addresses

Last edited by Minsc (2012-07-30 10:30:12)

Offline

#3 2012-07-30 16:36:38

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 278
Website

Re: [SOLVED]Stuck connect to gateway w/static IP on i686 w/2012.07.15 CD

Minsc wrote:

Use ifconfig instead of ip to setup your NIC:

ifconfig eth0 192.168.0.3
route add default gateway 192.168.0.1

It could be a problem with the ethernet drivers and the above ifconfig command will fail if this is the case.

Edit: fixed ip addresses

Well I ran your suggested commands & now I can successfully ping the gateway and also ping google's DNS server 8.8.8.8.

After adding nameserver to the "/etc/resolv.conf " I can now successfully ping "google.com".

Thanks very much. ~ big_smile


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#4 2012-08-02 20:31:52

MajorTom
Member
From: Canada, GTA
Registered: 2008-09-12
Posts: 58

Re: [SOLVED]Stuck connect to gateway w/static IP on i686 w/2012.07.15 CD

I'd suggest sticking to using iproute2 instead of net-tools.

Perhaps the problem was the link was simply down? How about:

# ip link set dev eth0 up
# ip addr add 192.168.1.2/24 dev eth0
# ip route add default via 192.168.1.1
# echo "nameserver 8.8.8.8" >> /etc/resolv.conf

Last edited by MajorTom (2012-08-02 21:17:06)

Offline

#5 2012-08-02 20:39:38

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 278
Website

Re: [SOLVED]Stuck connect to gateway w/static IP on i686 w/2012.07.15 CD

MajorTom wrote:

…Perhaps the problem was the link was simply down? …


BTW: I verified the link was up over two days by pinging from the same machine booting windows.


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#6 2012-08-02 21:09:30

MajorTom
Member
From: Canada, GTA
Registered: 2008-09-12
Posts: 58

Re: [SOLVED]Stuck connect to gateway w/static IP on i686 w/2012.07.15 CD

I was able to reproduce it by incorrectly setting the address on the adapter, like so:

# ip addr add 192.168.1.2 dev eth0

This configures inet 192.168.1.2/32 and trying to add a route later will fail. If you specify the /24 mask, adding the route after should work:

# ip addr add 192.168.1.2/24 dev eth0

Offline

Board footer

Powered by FluxBB