You are not logged in.

#1 2012-08-01 07:21:02

Registered: 2012-01-16
Posts: 24

[pulseaudio] crackling in microphone recordings


I am using Gnome 3 with pulseaudio.
When I test recording with gstreamer-properties or Skype, terrible crackling comes along with my voice.

I tried

options snd-hda-intel position_fix=3



but none of 0,1,2,3 did help.
I tried nearly every possible mixer combination, none of them worked.

In windows my recordings are fine. And what really baffles me is this:
When I run pulseaudio through jack everything is fine aswell. But this is no longterm solution for me...

I start jack & pulseaudio like this:

jackd -r -d alsa &> /dev/null &
pulseaudio -L module-jack-sink -L module-jack-source &> /dev/null &

Any ideas why this is happening? Everything except recording is fine, if not perfect.
I am using the Realtek ALC888 codec.

Last edited by s4ms3milia (2012-08-01 07:51:44)


#2 2012-08-01 07:30:08

Registered: 2007-04-03
Posts: 3,645

Re: [pulseaudio] crackling in microphone recordings

A better test is the simpler:

arecord -vv -d 4 /tmp/test-mic.wav && aplay /tmp/test-mic.wav


#3 2012-08-01 07:46:24

Registered: 2012-01-16
Posts: 24

Re: [pulseaudio] crackling in microphone recordings

Ok, that sounds different. I don't want to say better, cause there is more background noise, but the crackling (robot voice..) is gone.
Seems like I was wrong, it must be pulseaudio then.
I didnt't know that when I select alsa in gstreamer-properties that my sound still gets piped through pulse..

I already tried the suggested pulse audio fixes from the wiki:

load-module module-udev-detect tsched=0


default-sample-rate = 44100 // 48000 // 96000

Last edited by s4ms3milia (2012-08-01 07:49:00)


#4 2012-11-19 19:50:56

Registered: 2012-11-19
Posts: 6

Re: [pulseaudio] crackling in microphone recordings

Hello.  I was just searching for a fix for this problem, and this was one of the first threads that came up on Google.  The solutions mentioned herein didn't work for me, but I did find something that does, so I think it only fair to post back.  (Note: I'm a Linux Mint user, but since this was one of the first things on Google's results page, and since the problem isn't Mint/Ubuntu-specific, I figure it's good form to post my solution here, anyway.)

Here's what I've discovered: there's a "proper" workaround, and a very dirty hack.  Both are below.  (The hack was mentioned here, previously.)

"Proper" workaround:

sudo -H alsamixer

...and set PCM to something substantially below maximum.  Having PCM at or near maximum causes crackling and distortion.  Mine is at "-4.40, -4.80"--whatever that means.  Then:

sudo -H alsactl store

The "-H" option tells sudo to use the current user's home directory instead of setting it to "/root".  Not using this option will result in a "home directory /home/blah is not ours" error.  This isn't necessary on all systems, presumably, and it can probably be done with "su", instead.

DIRTY hack:
To reduce the "crackling" in (some) multimedia apps at the expense of realtime performance, do this:

In /etc/pulse/, change this:

load-module module-udev-detect this:

load-module module-udev-detect tsched=0

This is a very dirty workaround that bypasses PulseAudio's scheduling mechanisms in favor of the traditional interrupt approach.  Use with caution.

I hope this helps you all, in case you haven't yet solved this problem.  I previously posted this on another Arch thread, since it was the very first Google result; but since this thread seems to be having a similar problem, I thought it acceptable to "double-post" it here, just this once.  :-)


Board footer

Powered by FluxBB