You are not logged in.

#1 2012-08-05 11:31:28

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 275
Website

[SOLVED]No sound on new i686 install with ALSA using SB Audigy 2 ZS

Previously posted at https://bbs.archlinux.org/viewtopic.php?id=146400

I replaced Xubuntu 12.04 on my 32bit legacy workstation which uses an Audigy 2 ZS soundcard (emu10k1) and analog outputs to a 5.1 amplified speaker set.

The old reliable "speaker-test -c2" produces no sound.

I use QasMixer and a screenshot of it's prior settings is at http://i.stack.imgur.com/h4vOe.png/ and the Arch setting are here http://img826.imageshack.us/img826/532/qasmixer.png

The ALSA information script is at http://pastebin.com/iRJamGBK. Note that is was run without USB microphone attached & with the mobo sound disabled in the BIOS.

I have been using the ALSA Wiki https://wiki.archlinux.org/index.php/Alsa and everything seems to check out.

I know the sound system is working because it works in the dual-boot WinXP.  It also produces an audible "thump" when unmuting Analog C with alsamixer.

I am perplexed and looking for suggestions. roll

Also here is the termout as suggested by Arch Wiki AKSA… ‥ .

~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887 Analog [ALC887 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887 Digital [ALC887 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 32/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  Subdevice #8: subdevice #8
  Subdevice #9: subdevice #9
  Subdevice #10: subdevice #10
  Subdevice #11: subdevice #11
  Subdevice #12: subdevice #12
  Subdevice #13: subdevice #13
  Subdevice #14: subdevice #14
  Subdevice #15: subdevice #15
  Subdevice #16: subdevice #16
  Subdevice #17: subdevice #17
  Subdevice #18: subdevice #18
  Subdevice #19: subdevice #19
  Subdevice #20: subdevice #20
  Subdevice #21: subdevice #21
  Subdevice #22: subdevice #22
  Subdevice #23: subdevice #23
  Subdevice #24: subdevice #24
  Subdevice #25: subdevice #25
  Subdevice #26: subdevice #26
  Subdevice #27: subdevice #27
  Subdevice #28: subdevice #28
  Subdevice #29: subdevice #29
  Subdevice #30: subdevice #30
  Subdevice #31: subdevice #31
card 2: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 2: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 3: emu10k1 [Multichannel Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 4: p16v [p16v]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
~$ sudo cat /etc/asound.conf
defaults.pcm.card 2
defaults.ctl.card 2
defaults.pcm.device 0
defaults.pcm.rate_converter "samplerate_best"

ctl.equal {
 type equal;
}

pcm.plugequal {
  type equal;
  # Modify the line below if you do not
  # want to use sound card 0.
  #slave.pcm "plughw:0,0";
  #by default we want to play from more sources at time:
  slave.pcm "plug:dmix";
}
#pcm.equal {
  # If you don't want the equalizer to be your
  # default soundcard comment the following
  # line and uncomment the above line. (You can
  # choose it as the output device by addressing
  # it with specific apps,eg mpg123 -a equal 06.Back_In_Black.mp3)
pcm.!default {
  type plug;
  slave.pcm plugequal;
}

pcm.upmix51 {
    type upmix
    slave.pcm "surround51"
    delay 15
    channels 6
}
~$ lsmod | grep '^snd' | column -t
snd_hda_codec_hdmi     21248   1
snd_hda_codec_realtek  51597   1
snd_emu10k1            121892  1
snd_usb_audio          75584   0
snd_util_mem           1836    1   snd_emu10k1
snd_ac97_codec         89868   1   snd_emu10k1
snd_hda_intel          20208   0
snd_usbmidi_lib        15548   1   snd_usb_audio
snd_rawmidi            14630   2   snd_usbmidi_lib,snd_emu10k1
snd_hda_codec          80733   3   snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_seq_device         4316    2   snd_rawmidi,snd_emu10k1
snd_pcm                61237   6   snd_usb_audio,snd_ac97_codec,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_emu10k1
snd_page_alloc         5901    3   snd_pcm,snd_hda_intel,snd_emu10k1
snd_hwdep              4746    3   snd_usb_audio,snd_hda_codec,snd_emu10k1
snd_timer              14902   2   snd_pcm,snd_emu10k1
snd                    44394   15  snd_hda_codec_realtek,snd_usb_audio,snd_ac97_codec,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_emu10k1,snd_seq_device

Last edited by keepitsimpleengineer (2012-08-06 16:05:54)


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#2 2012-08-05 11:53:29

ratcheer
Member
Registered: 2011-10-09
Posts: 498

Re: [SOLVED]No sound on new i686 install with ALSA using SB Audigy 2 ZS

I bought a new PC a year ago, in part because I couldn't get my Audigy 2 ZS to work with any current Linux distro. And, when some of the older distros were patched, it stopped working with them, too.

Tim

Offline

#3 2012-08-05 12:03:51

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 275
Website

Re: [SOLVED]No sound on new i686 install with ALSA using SB Audigy 2 ZS

Add'l info:
Sound Blaster Audigy mixer / default DSP code based on kernel version 3.5.

lspci out for the 2 audigy zs

02:01.0 Multimedia audio controller [0401]: Creative Labs SB Audigy [1102:0004] (rev 05)
	Subsystem: Creative Labs Device [1102:2005]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 19
	Region 0: I/O ports at da00 [size=64]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: snd_emu10k1

Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#4 2012-08-05 23:25:03

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 275
Website

Re: [SOLVED]No sound on new i686 install with ALSA using SB Audigy 2 ZS

Ok - this is getting weird. roll

After doing some other stuff regards to networking, I tried the alsamixer again.

...and the default soudcard was changed to the USB microphone?

Now there were no changes to hardware, not even reseating PCI cards.  The only change to the BIOS was, after booting from a CD using the BIOS boot menu (F12), the BIOS reset the hard disk boot order to its default (a non bootable drive) and I had to go into the BIOS to set the boot disk to the one with the boot loader.

So I ran aplay -l, and now the card is at 1 vice 2?

...so I edit ~/.asoundrc & /etc/asound.conf to match this, restart alsa, and now alsamixer shows the audigy card as the default.

But still zilch from speaker-test. yikes

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 32/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  Subdevice #8: subdevice #8
  Subdevice #9: subdevice #9
  Subdevice #10: subdevice #10
  Subdevice #11: subdevice #11
  Subdevice #12: subdevice #12
  Subdevice #13: subdevice #13
  Subdevice #14: subdevice #14
  Subdevice #15: subdevice #15
  Subdevice #16: subdevice #16
  Subdevice #17: subdevice #17
  Subdevice #18: subdevice #18
  Subdevice #19: subdevice #19
  Subdevice #20: subdevice #20
  Subdevice #21: subdevice #21
  Subdevice #22: subdevice #22
  Subdevice #23: subdevice #23
  Subdevice #24: subdevice #24
  Subdevice #25: subdevice #25
  Subdevice #26: subdevice #26
  Subdevice #27: subdevice #27
  Subdevice #28: subdevice #28
  Subdevice #29: subdevice #29
  Subdevice #30: subdevice #30
  Subdevice #31: subdevice #31
card 1: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 3: emu10k1 [Multichannel Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audigy2 [SB Audigy 2 ZS [SB0350a]], device 4: p16v [p16v]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

-----------------

When I installed Xubintu 12.04 on this hardware not too long ago, the only problem I had (with the audio) was to set the default sound card and unmute the Audigy Analog/Digital Output Jack (aka <Audigy A> )  in alsamixer.

Last edited by keepitsimpleengineer (2012-08-05 23:27:45)


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#5 2012-08-06 03:25:21

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 275
Website

Re: [SOLVED]No sound on new i686 install with ALSA using SB Audigy 2 ZS

In an effort to get the sound audible, I blacklisted snd_hda_intel (the unused HDMI part of the ATI video card).

The result was the audigy is now card 0 instead of one (as above) or 2 as before, from aplay -l

...so I edit ~/.asoundrc & /etc/asound.conf to match this, restart alsa, and now alsamixer shows the audigy card as the default.

But still zilch from speaker-test. yikes


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#6 2012-08-06 16:04:55

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 275
Website

Re: [SOLVED]No sound on new i686 install with ALSA using SB Audigy 2 ZS

After all these machinations, I dropped the 3.4.7-1-ARCH kernel, and installed the 3.0.38-1-lts.

Now I have sound.


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

#7 2012-08-12 18:38:53

keepitsimpleengineer
Member
From: San Joaquin Valley, CA
Registered: 2012-06-25
Posts: 275
Website

Re: [SOLVED]No sound on new i686 install with ALSA using SB Audigy 2 ZS

I tried the new 3.4.8.1 kernel and it also failed, so back to the linux-lts.


Al Einstein: "Man soll die Dinge so einfach machen wie möglich ~ aber nicht einfacher." (Things should be as simple as possible ~ but not too simple.)

Offline

Board footer

Powered by FluxBB