You are not logged in.

#1 2012-08-09 02:03:42

Steven Monday
Member
Registered: 2012-08-09
Posts: 4

[solved] vconsole.conf FONT setting is not respected in systemd

I recently converted my Arch system to a pure systemd setup (as described here), and everything seems to be working as before.

Well, almost everything.

Prior to switching over to systemd, I had already moved all config settings (except for the DAEMONS line) out of /etc/rc.conf and into the individual config files, and at that time, I had set up /etc/vconsole.conf as follows:

KEYMAP=us
FONT=ter-216n
FONT_MAP=8859-2

When running under initscripts, this was working fine, and I would get the nice Terminus font at my console TTYs. Now, running under systemd, the consoles are no longer using Terminus. Instead, I just get the default font (whatever it's called). It's as if the FONT I set in /etc/vconsole.conf is being ignored.

systemctl reports the following, indicating (I think) that the systemd-vconsole-setup service ran successfully:

[owner@computer ~]$ systemctl status systemd-vconsole-setup.service
systemd-vconsole-setup.service - Setup Virtual Console
	  Loaded: loaded (/usr/lib/systemd/system/systemd-vconsole-setup.service; static)
	  Active: active (exited) since Wed, 08 Aug 2012 08:31:51 -0700; 9h ago
	    Docs: man:systemd-vconsole-setup.service(8)
	          man:vconsole.conf(5)
	 Process: 151 ExecStart=/usr/lib/systemd/systemd-vconsole-setup (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/systemd-vconsole-setup.service

So, I'm stuck. Can anybody point me in the right direction?

Last edited by Steven Monday (2012-08-09 05:31:49)

Offline

#2 2012-08-09 02:21:15

tomegun
Developer
From: France
Registered: 2010-05-28
Posts: 661

Re: [solved] vconsole.conf FONT setting is not respected in systemd

Probably this is due to the vconsole being configured before your graphics drivers are loaded, and then the settings being lost when the drivers are loaded.

You could try ordering vconsole-setup After=/Wants= systemd-udev-settle.service. That's a bit of a hack, and will slow down your boot a bit, but at least it will tell us what the problem is.

Offline

#3 2012-08-09 05:05:57

ebal
Member
From: Athens, Greece
Registered: 2009-05-26
Posts: 224
Website

Re: [solved] vconsole.conf FONT setting is not respected in systemd

i am not sure, but i use

MAP=""

not

FONT_MAP


can you give it a try ?


https://balaskas.gr
Linux System Engineer - Registered Linux User #420129

Offline

#4 2012-08-09 05:29:03

Steven Monday
Member
Registered: 2012-08-09
Posts: 4

Re: [solved] vconsole.conf FONT setting is not respected in systemd

tomegun wrote:

... try ordering vconsole-setup After=/Wants= systemd-udev-settle.service.

I confirm that this works. Thanks for the tip.

(Specifically, I copied /usr/lib/systemd/system/systemd-vconsole-setup.service to /etc/systemd/system/, and then I put  systemd-udev-settle.service  into the  After=  and  Wants=  lines of that new file.)

I wonder: Was this problem specific to my particular hardware (an old Acer Aspire One, with xf86-video-intel driver)? Or is it a more general problem likely to affect many others? In either case, I would say it's a bug in  systemd-vconsole-setup.service.

Offline

#5 2012-08-09 09:22:44

89c51
Member
Registered: 2012-06-05
Posts: 734

Re: [solved] vconsole.conf FONT setting is not respected in systemd

i thing it should be

FONT_MAP=8859-2_to_uni

Offline

#6 2012-08-09 10:42:56

progandy
Member
Registered: 2012-05-17
Posts: 4,367

Re: [solved] vconsole.conf FONT setting is not respected in systemd

Steven Monday wrote:

I wonder: Was this problem specific to my particular hardware (an old Acer Aspire One, with xf86-video-intel driver)? Or is it a more general problem likely to affect many others? In either case, I would say it's a bug in  systemd-vconsole-setup.service.

I didn't modify the file, but then I use Early KMS start for my radeon driver.
https://wiki.archlinux.org/index.php/Ke … _KMS_start


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#7 2012-08-09 16:23:44

Steven Monday
Member
Registered: 2012-08-09
Posts: 4

Re: [solved] vconsole.conf FONT setting is not respected in systemd

89c51 wrote:

... it should be

FONT_MAP=8859-2_to_uni

Yes, you're right. I have updated my /etc/vconsole.conf accordingly.

However, I just tested this, and it turns out that my FONT_MAP mistake was not relevant to my original problem.

progandy wrote:

I didn't modify the file, but then I use Early KMS start for my radeon driver.
https://wiki.archlinux.org/index.php/Ke … _KMS_start

Interesting. It turns out that using early KMS start also solves my console font problem. I think I prefer this solution, since it doesn't involve overriding systemd-vconsole-setup.service. Enabling early KMS start feels like a less invasive change. As documented here, I simply added i915 to the MODULES line in /etc/mkinitcpio.conf, and then rebuilt the /boot/initramfs-* files.

Offline

#8 2013-11-07 10:53:47

raymondcal
Member
Registered: 2010-06-16
Posts: 47

Re: [solved] vconsole.conf FONT setting is not respected in systemd

Steven Monday wrote:
tomegun wrote:

... try ordering vconsole-setup After=/Wants= systemd-udev-settle.service.

I confirm that this works. Thanks for the tip.

(Specifically, I copied /usr/lib/systemd/system/systemd-vconsole-setup.service to /etc/systemd/system/, and then I put  systemd-udev-settle.service  into the  After=  and  Wants=  lines of that new file.)

I wonder: Was this problem specific to my particular hardware (an old Acer Aspire One, with xf86-video-intel driver)? Or is it a more general problem likely to affect many others? In either case, I would say it's a bug in  systemd-vconsole-setup.service.

Nice tip, it works for me too. In VMware, systemd-vconsole-setup.service seems to come to early in the boot process, and the keyboard map is not respected. With this tip, all is OK, thanks.

Offline

#9 2013-11-07 11:21:42

progandy
Member
Registered: 2012-05-17
Posts: 4,367

Re: [solved] vconsole.conf FONT setting is not respected in systemd

raymondcal wrote:

Nice tip, it works for me too. In VMware, systemd-vconsole-setup.service seems to come to early in the boot process, and the keyboard map is not respected. With this tip, all is OK, thanks.

Well, udev is working in the background and at some time it finds your graphics card and loads the driver. systemd runs in parallel and executes the vconsole-setup. That's a simple race condition which you can eliminate if you load the graphics driver with early kms. Then it gets loaded in the initramfs before systemd starts.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

Board footer

Powered by FluxBB