You are not logged in.

#1 2012-08-11 19:02:52

blackout23
Member
Registered: 2011-11-16
Posts: 780

LiveImage disable nouveau on boot [SOLVED]

Hello forum,

is there a way to let the Live CD ISO not load nouveau upon detecting my nvidia card? Blacklisting is not an option here obviously.
I tried using video=vesafb:1024x768-16 but that did not help. Once I'm in tty is there a way to unload nouveau and fallback to whatever
it is using before loading nouveau? rmmod nouveau won't help.

Problem is that my desktop PC monitor has some problems with the EDID which results in having a cropped image, which proves to be
a problem when doing "lsblk" and you don't see the device names since they are cut off.

I have to get to a X11 + nvidia installation so I can export my EDID and perform some patching on it and load it as a custom EDID so that my
whole monitor is detected corretly.

Regards,

blackout23

EDIT: Installing fbset and using fbset -g 1024 768 1024 768 16 did not help ony resulted in having a strange greenish rectangle in the the left corner still
not showing the first few pixles of the output.

Last edited by blackout23 (2012-08-11 19:15:54)

Offline

#2 2012-08-11 19:07:27

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: LiveImage disable nouveau on boot [SOLVED]

Press the Tab key over the i686 or x86_64 entry and add "nomodeset" at the end.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-08-11 19:15:36

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: LiveImage disable nouveau on boot [SOLVED]

You learn something new every day. This was most helpful! Gotta remember that.

Offline

#4 2012-12-24 05:48:14

ElectricPrism
Member
Registered: 2012-12-07
Posts: 28

Re: LiveImage disable nouveau on boot [SOLVED]

Tab on the Grub boot screen brought up the launch options:

.../boot/i686/archiso.img nomodeset

Worked like a charm getting rid of the "Doubble Vision" on my laptop that Nouveau created making TTY1 unreadable.

Offline

Board footer

Powered by FluxBB