You are not logged in.

#1 2012-08-11 20:09:33

wolfdogg
Member
From: Portland, OR, USA
Registered: 2011-05-21
Posts: 525

[solved] libc.so.6 version GLIBC_2.16 not found

i have tried to upgrade arch today, and i am getting too deep,
im stilll getting error message

pacman: /lib/libc.so.6 version GLIBC_2.16 not found (required by /usr/lib/libcurl.so.4)

i followed the instructions here https://wiki.archlinux.org/index.php/De … iki:usrlib and am not getting anywhere. i am following the instructions here https://bbs.archlinux.org/viewtopic.php?pid=1144268 and im also not getting anywhere with this. 
i did untar the package curl-7.26.0-1-x86_64.pkg.tar.xz from cache and tried to overwrite teh curl libs in /usr/lib and im still getting this error.  previously i ignored the unresolvable dependencies which i now feel is a mistake, the list is quite long, heres an example

warning: ignoring package glibc-2.16.0-2
warning: cannot resolve "glibc>=2.16", a dependency of "gcc-libs"
...

:: The following packages cannot be upgraded due to unresolvable dependencies:
     binutils  gcc  gcc-libs

Do you want to skip the above packages for this upgrade [y/N]

and the actual ones i ignored that i still have to upgrade because they have been ignored are as follows

pacman -Sd binutils dbus dbus-core gcc gcc-libs ghostscript glib2 glibmm gnutls grep gtk2 icu initscripts libcups libgl linux mesa mkinitcpio pcre php php-apache php-gd php-mcrypt php-pear phpmyadmin samba systemd-tools

im going to stop here until i get some assistance if possible before i break anything.  i do have my original curl libs backed up to /tmp/pacman_build/usr directory

where to go from here?

Last edited by wolfdogg (2012-08-12 06:45:49)


i "the local machine" have got a bunch of technoligocally adcanved slaves whoms intelligence is derived from the adomstraptr instructions..!

Offline

#2 2012-08-12 06:44:38

wolfdogg
Member
From: Portland, OR, USA
Registered: 2011-05-21
Posts: 525

Re: [solved] libc.so.6 version GLIBC_2.16 not found

ok, i was able to solve the error

libc.so.6 version GLIBC_2.16 not found

Curl needed to be downgraded because i did a pacman -Sd , and probably mistakenly upgraded curl without upgrading glibc.  I know this is mostly mentioned in the other post linked above, however the instructions werent clear enough.  note, i didnt have to use the LD_PRELOAD method.

this was how i was able to downgrage curl after enough messing around with it.

 cd /usr/lib
grep ./ libcurl*
mkdir /home/USERNAME/curl_backup/
mv libcurl.a libcurl.so libcurl.so.4 libcurl.so.4.2.0 /home/USERNAME/curl_backup
cd /home/USERNAME/curl_backup
wget http://arm.konnichi.com/2012/07/26/pool/packages/curl-7.26.0-1-<arch>.pkg.tar.xz
tar -xJf curl-7.26.0-1-<arch>.pkg.tar.xz
cd usr/lib
cp *.* /usr/lib

replace arch with either x86_64 or i686 depending on your architecture

Last edited by wolfdogg (2012-08-22 06:04:05)


i "the local machine" have got a bunch of technoligocally adcanved slaves whoms intelligence is derived from the adomstraptr instructions..!

Offline

#3 2012-08-14 01:02:31

MisterAnderson
Member
Registered: 2011-09-04
Posts: 284

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Hey worked great for me thanks.
I simply did this:

 sudo pacman -Syu --ignore glibc

and it upgraded fine, then I tried to do another -Syu and it came up with your error. Annoying since there was no reason, I did not force dependency ignores or anything. Fixed now though!


D:

Offline

#4 2012-08-14 07:53:14

md2k7
Member
Registered: 2011-01-22
Posts: 9

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Thanks wolfdogg!

I also had to move old stuff from

/lib/modules

by hand before glibc would update.

Offline

#5 2012-08-14 21:58:51

bostonvaulter
Member
Registered: 2008-07-17
Posts: 36

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Thanks @wolfdogg. Just a side note. If you are running a 32-bit machine you need to use this url for the curl package.

http://arm.konnichi.com/core/os/i686/cu … pkg.tar.xz

Offline

#6 2012-08-15 15:06:25

wolfdogg
Member
From: Portland, OR, USA
Registered: 2011-05-21
Posts: 525

Re: [solved] libc.so.6 version GLIBC_2.16 not found

glad i could help
@bostonvaulter, thanks,  i updated the post to reflect the architecture changes, although the address is different than the one you used.  they are both listed here http://arm.konnichi.com/2012/07/26/pool/packages/

Last edited by wolfdogg (2012-08-15 15:08:10)


i "the local machine" have got a bunch of technoligocally adcanved slaves whoms intelligence is derived from the adomstraptr instructions..!

Offline

#7 2012-08-15 17:16:12

reflets de vert
Member
Registered: 2010-03-20
Posts: 54
Website

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Hello,

I tested your method.

Now I have an other error message.

pacman -Syu
pacman error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory

I'm against internet totalitarians of any kind.
And like cheese's humor.

Offline

#8 2012-08-17 13:06:36

MisterAnderson
Member
Registered: 2011-09-04
Posts: 284

Re: [solved] libc.so.6 version GLIBC_2.16 not found

reflets de vert wrote:

Hello,

I tested your method.

Now I have an other error message.

pacman -Syu
pacman error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory

You probably needed to reinstall curl from your livecd environment as well.


D:

Offline

#9 2012-08-19 01:00:24

msx
Member
From: solar.system/earth/ar/bue/mdp
Registered: 2010-08-08
Posts: 184
Website

Re: [solved] libc.so.6 version GLIBC_2.16 not found

@wolfdogg: here, take another bean from me! +1


Enjoying i3wm w/ lifebar + j4-dmenu-desktop + tab_windows / fish shell / Emacs / tmux / Konsole / KDE apps
Arch + Linux-libre kernel: ParabolaGNULinux.org

Offline

#10 2012-08-22 10:20:54

Del Pede
Member
Registered: 2007-11-13
Posts: 27

Re: [solved] libc.so.6 version GLIBC_2.16 not found

wolfdogg wrote:

ok, i was able to solve the error

libc.so.6 version GLIBC_2.16 not found

Curl needed to be downgraded because i did a pacman -Sd , and probably mistakenly upgraded curl without upgrading glibc.  I know this is mostly mentioned in the other post linked above, however the instructions werent clear enough.  note, i didnt have to use the LD_PRELOAD method.

this was how i was able to downgrage curl after enough messing around with it.

 cd /usr/lib
grep ./ libcurl*
mkdir /home/USERNAME/curl_backup/
mv libcurl.a libcurl.so libcurl.so.4 libcurl.so.4.2.0 /home/USERNAME/curl_backup
cd /home/USERNAME/curl_backup
wget http://arm.konnichi.com/2012/07/26/pool/packages/curl-7.26.0-1-<arch>.pkg.tar.xz
tar -xJf curl-7.26.0-1-<arch>.pkg.tar.xz
cd usr/lib
cp *.* /usr/lib

replace arch with either x86_64 or i686 depending on your architecture

I followed this, and now I'm just getting the initial error again.

error: failed to commit transaction (conflicting files)
glibc: /lib exists in filesystem
Errors occurred, no packages were upgraded.

pacman -Syu --ignore glibc and pacman -Syu and pacman -Su fails with that error.

EDIT: I was a bit to quick it seems. i had to ignore curl in my initial upgrade. Now it works. Great guide. Very helpful

Last edited by Del Pede (2012-08-22 10:27:00)

Offline

#11 2012-08-23 15:13:36

thorn
Member
Registered: 2012-05-09
Posts: 6

Re: [solved] libc.so.6 version GLIBC_2.16 not found

tyvm, wish i could send some kisses to you!

Offline

#12 2012-08-25 11:20:42

wardmuylaert
Member
From: Brussels
Registered: 2011-12-21
Posts: 2
Website

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Wewt,  wasn't home for a few months and accidentally only ignored glibc, not curl (shame on me). Thanks for the hint on switching around curl (I moved the backed up things back afterwards). Looks like it solved things for now (though I'm still going through pacnews before I get around to restarting).

Edit: Yup, solved it completely. Thanks!

Last edited by wardmuylaert (2012-08-25 18:06:50)

Offline

#13 2012-09-04 06:59:24

gabuzo
Member
Registered: 2012-04-11
Posts: 6

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Thanks!

Offline

#14 2012-10-27 10:26:20

Triver
Member
Registered: 2009-03-29
Posts: 65

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Del Pede wrote:

I followed this, and now I'm just getting the initial error again.

error: failed to commit transaction (conflicting files)
glibc: /lib exists in filesystem
Errors occurred, no packages were upgraded.

pacman -Syu --ignore glibc and pacman -Syu and pacman -Su fails with that error.

EDIT: I was a bit to quick it seems. i had to ignore curl in my initial upgrade. Now it works. Great guide. Very helpful

Hi have have the same problem that you had (first I did everything according to the original instructions (I think), then I got the same problem as the thread starter, I followed his instructions and got what you described) but ignoring curl when updating doesn't help me, I'm still stuck here (actually I don't think he even wants to update curl as iti is not listed in my update list).

I would very much appreciate some help here since I'm stuck with this problem for some time now...

Here's what I get when I try to update now:

(152/152) checking for file conflicts                              [####################################] 100%
error: failed to commit transaction (conflicting files)
glibc: /lib exists in filesystem
fontconfig: /etc/fonts/conf.d/20-unhint-small-vera.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/29-replace-bitmap-fonts.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/30-metric-aliases.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/30-urw-aliases.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/40-nonlatin.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/45-latin.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/49-sansserif.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/50-user.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/51-local.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/60-latin.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/65-fonts-persian.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/65-nonlatin.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/69-unifont.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/80-delicious.conf exists in filesystem
fontconfig: /etc/fonts/conf.d/90-synthetic.conf exists in filesystem
Errors occurred, no packages were upgraded.

Offline

#15 2012-10-27 10:42:47

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: [solved] libc.so.6 version GLIBC_2.16 not found

@Triver, you may have to check for unpackaged files under /lib:

$ find /lib -exec pacman -Qo -- {} +

To be sure, also have a look in /lib yourself if there are any leftover files or directories.

The wiki page mentioned in the first post of this thread should provide all the commands you need to find and fix any issues with the glibc update.

fontconfig: https://www.archlinux.org/news/fontconf … -required/


ᶘ ᵒᴥᵒᶅ

Offline

#16 2012-10-27 10:49:35

Triver
Member
Registered: 2009-03-29
Posts: 65

Re: [solved] libc.so.6 version GLIBC_2.16 not found

okay so here's the output of the command:

error: cannot determine ownership of directory '/lib'
/lib/libnss_files-2.15.so is owned by glibc 2.15-12
/lib/libnss_db.so.2 is owned by glibc 2.15-12
/lib/libresolv.so.2 is owned by glibc 2.15-12
/lib/libutil.so.1 is owned by glibc 2.15-12
/lib/libc.so.6 is owned by glibc 2.15-12
/lib/libnss_nis-2.15.so is owned by glibc 2.15-12
/lib/libmemusage.so is owned by glibc 2.15-12
/lib/libBrokenLocale-2.15.so is owned by glibc 2.15-12
/lib/ld-linux.so.2 is owned by glibc 2.15-12
/lib/libnss_hesiod-2.15.so is owned by glibc 2.15-12
/lib/libSegFault.so is owned by glibc 2.15-12
/lib/libcrypt-2.15.so is owned by glibc 2.15-12
/lib/libnss_nisplus.so.2 is owned by glibc 2.15-12
/lib/libnsl-2.15.so is owned by glibc 2.15-12
/lib/libpthread-2.15.so is owned by glibc 2.15-12
/lib/libm-2.15.so is owned by glibc 2.15-12
/lib/libdl.so.2 is owned by glibc 2.15-12
/lib/ld-2.15.so is owned by glibc 2.15-12
/lib/libcidn-2.15.so is owned by glibc 2.15-12
/lib/libnss_files.so.2 is owned by glibc 2.15-12
/lib/libnss_nis.so.2 is owned by glibc 2.15-12
/lib/libresolv-2.15.so is owned by glibc 2.15-12
/lib/librt.so.1 is owned by glibc 2.15-12
/lib/libnss_compat-2.15.so is owned by glibc 2.15-12
/lib/libpcprofile.so is owned by glibc 2.15-12
/lib/libcidn.so.1 is owned by glibc 2.15-12
/lib/libnss_hesiod.so.2 is owned by glibc 2.15-12
/lib/libnss_db-2.15.so is owned by glibc 2.15-12
/lib/libdl-2.15.so is owned by glibc 2.15-12
/lib/libthread_db.so.1 is owned by glibc 2.15-12
/lib/libpthread.so.0 is owned by glibc 2.15-12
/lib/libnss_nisplus-2.15.so is owned by glibc 2.15-12
/lib/libm.so.6 is owned by glibc 2.15-12
/lib/libthread_db-1.0.so is owned by glibc 2.15-12
/lib/libnss_dns-2.15.so is owned by glibc 2.15-12
/lib/librt-2.15.so is owned by glibc 2.15-12
/lib/libutil-2.15.so is owned by glibc 2.15-12
/lib/libBrokenLocale.so.1 is owned by glibc 2.15-12
/lib/libc-2.15.so is owned by glibc 2.15-12
/lib/libcrypt.so.1 is owned by glibc 2.15-12
/lib/libanl.so.1 is owned by glibc 2.15-12
error: cannot determine ownership of directory '/lib/modules'
error: cannot determine ownership of directory '/lib/modules/3.1.9-2-ARCH'
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.ccwmap
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.ofmap
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.ieee1394map
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.pcimap
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.inputmap
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.usbmap
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.seriomap
error: No package owns /lib/modules/3.1.9-2-ARCH/modules.isapnpmap
error: cannot determine ownership of directory '/lib/modules/extramodules-3.2-ARCH'
error: cannot determine ownership of directory '/lib/modules/extramodules-3.2-ARCH/kernel'
error: cannot determine ownership of directory '/lib/modules/extramodules-3.2-ARCH/kernel/oss'
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_hdaudio.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_via97.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_cmpci.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_ali5455.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_envy24.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_imux.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_audiopci.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_midimix.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_ich.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_madi.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_solo.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_digi96.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_emu10k1x.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_midiloop.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/osscore.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_cs4281.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_envy24ht.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_cs461x.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_audioloop.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_via823x.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_trident.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_sbpci.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_geode.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_cmi878x.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_atiaudio.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_fmedia.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_sbxfi.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_ymf7xx.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_usb.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_audigyls.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_sblive.ko
error: No package owns /lib/modules/extramodules-3.2-ARCH/kernel/oss/oss_userdev.ko
/lib/libanl-2.15.so is owned by glibc 2.15-12
/lib/libnss_compat.so.2 is owned by glibc 2.15-12
/lib/libnsl.so.1 is owned by glibc 2.15-12
/lib/libnss_dns.so.2 is owned by glibc 2.15-12

if you say "have a look in /lib yourself if there are any leftover files or directories" then what files exactly do you mean? those who are still owned by glibc? and how do I move them properly (or is this already described in the wiki)?

Offline

#17 2012-10-27 10:52:57

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Ok if you're not using those old kernels anymore, just remove the modules directory:

# rm -rf /lib/modules

Then, per the wiki, manually install glibc:

# pacman -U http://pkgbuild.com/~allan/glibc-2.16.0-1-<arch>.pkg.tar.xz

Then proceed as normal.

Last edited by litemotiv (2012-10-27 11:00:00)


ᶘ ᵒᴥᵒᶅ

Offline

#18 2012-10-27 11:29:10

Triver
Member
Registered: 2009-03-29
Posts: 65

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Wow it actually worked, thank you so much (and to the threadstarter too) big_smile

A little sidenote here though, when I manually updated glibc as you suggested he showed me the messages

sbin/ldconfig: /usr/lib/libcurl.so.4 is not a symbolic link
...(generating locales here)...
ldconfig: /usr/lib/libcurl.so.4 is not a symbolic link

and he also showed me the first line when I did a pacman -Syu afterwards.

Should I worry or even do something about that?

Last edited by Triver (2012-10-27 11:35:15)

Offline

#19 2012-10-27 11:47:03

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Triver wrote:

Wow it actually worked, thank you so much (and to the threadstarter too) big_smile

A little sidenote here though, when I manually updated glibc as you suggested he showed me the messages

sbin/ldconfig: /usr/lib/libcurl.so.4 is not a symbolic link
...(generating locales here)...
ldconfig: /usr/lib/libcurl.so.4 is not a symbolic link

and he also showed me the first line when I did a pacman -Syu afterwards.

Should I worry or even do something about that?

That's probably because you manually restored curl before. They are supposed to be symlinked like this:

-rw-r--r-- 1 root root 796k Oct 11 11:19 libcurl.a
lrwxrwxrwx 1 root root   16 Oct 11 11:19 libcurl.so -> libcurl.so.4.2.0
lrwxrwxrwx 1 root root   16 Oct 11 11:19 libcurl.so.4 -> libcurl.so.4.2.0
-rwxr-xr-x 1 root root 390k Oct 11 11:19 libcurl.so.4.2.0

You can fix that manually, they are relative links so you should use the -r switch with ln.


ᶘ ᵒᴥᵒᶅ

Offline

#20 2012-10-27 11:56:17

Triver
Member
Registered: 2009-03-29
Posts: 65

Re: [solved] libc.so.6 version GLIBC_2.16 not found

So I have to do

ln -rs /lib/libcurl.so.4 libcurl.so.4.2.0

and that's it?
How can I check if the other links are correct?

Offline

#21 2012-10-27 12:12:08

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: [solved] libc.so.6 version GLIBC_2.16 not found

Triver wrote:

So I have to do

ln -rs /lib/libcurl.so.4 libcurl.so.4.2.0

and that's it?
How can I check if the other links are correct?

Like this:

# rm libcurl.so libcurl.so.4
# ln -rs /usr/lib/libcurl.so.4.2.0 libcurl.so
# ln -rs /usr/lib/libcurl.so.4.2.0 libcurl.so.4

ᶘ ᵒᴥᵒᶅ

Offline

#22 2012-10-27 12:16:54

Triver
Member
Registered: 2009-03-29
Posts: 65

Re: [solved] libc.so.6 version GLIBC_2.16 not found

excellent, thanks again for your fast reply wink

Offline

#23 2015-01-20 20:48:14

wolfdogg
Member
From: Portland, OR, USA
Registered: 2011-05-21
Posts: 525

Re: [solved] libc.so.6 version GLIBC_2.16 not found

i ran into this problem again and wanted to update the url so one can find the old version of curl.    the instructions on this page were flawless, and i remember was the only way i was able to get things to work, however i went back and looked everywhere and cant find the old curl version.

ftp://mirror.iprimus.com.au/archlinux/c … pkg.tar.xz
http://seblu.net/a/arm/packages/c/curl/

Can someone point me to a valid link of old curl versions, 7.26.xx to be exact. anybody?


the reason this is still an issue is because i have an older arch install cd (that needs updating) which i needed for rescue and after i ran pacman on it to install testdisk i ran into these problems.

EDIT: Disregard this anyhow, i realized i wasnt using my 2nd to newest arch iso, i was using my 3rd to newest, ouch.  i threw them both away and made a fresh one.  nice to see test disk is on these by default!

Last edited by wolfdogg (2015-01-20 23:54:54)


i "the local machine" have got a bunch of technoligocally adcanved slaves whoms intelligence is derived from the adomstraptr instructions..!

Offline

Board footer

Powered by FluxBB