You are not logged in.

#1 2005-08-22 13:30:13

arooaroo
Member
From: London, UK
Registered: 2005-01-13
Posts: 1,268
Website

Fonts have suddenly become large

Oh dear - more unexpected issues. I upgraded my system earlier and everything went smoothly. Here's the log:

[08/22/05 10:40] synchronizing package lists
[08/22/05 10:40] starting full system upgrade
[08/22/05 10:41] installed kernel26archck (2.6.12.archck5-1)
[08/22/05 10:41] upgraded ati-drivers (8.14.13-2 -> 8.16.20-1)
[08/22/05 10:41] upgraded automake (1.9.5-1 -> 1.9.6-1)
[08/22/05 10:41] upgraded imlib2 (1.2.0-2 -> 1.2.1-1)
[08/22/05 10:41] upgraded openldap (2.2.26-1 -> 2.2.28-1)
[08/22/05 10:41] upgraded perl-io-socket-ssl (0.95-1 -> 0.97-1)

I rebooted and loaded into KDE, and I noticed all the fonts had become larger than before. In both KDE apps and GTK apps. I look at my KDE setup and it reports the font sizes for things like menus are at size 10pt, but they look more like 12/14pt.

Now, with the first boot, I hadn't changed grub to use the new kernel, so that hadn't changed. Because the new kernel hadn't loaded, the ati-drivers failed to load. The fonts were big. I remedied the kernel - it and the ati module loaded fine. Fonts were still large.

My only real suspect therefore is imlib2. But this can't be involved, can it?

Anyone experienced this odd phenonemon?

Offline

#2 2005-08-22 16:18:55

keevn7
Member
From: Lancaster, OH, US
Registered: 2005-06-09
Posts: 206
Website

Re: Fonts have suddenly become large

Perhaps the DPI has changed for some reason, or your /etc/fonts/local.conf or whatnot has been altered. I am not sure if KDE sets a DPI or not, but look for that setting in the configuration. If you have no luck there, try adding the following to ~/.Xdefaults and logging out and back in.

Xft.dpi: 96

This will work only if KDE uses XFT. Cheers.

Offline

#3 2005-08-22 17:15:23

arooaroo
Member
From: London, UK
Registered: 2005-01-13
Posts: 1,268
Website

Re: Fonts have suddenly become large

keevn7 wrote:

Perhaps the DPI has changed for some reason, or your /etc/fonts/local.conf or whatnot has been altered. I am not sure if KDE sets a DPI or not, but look for that setting in the configuration. If you have no luck there, try adding the following to ~/.Xdefaults and logging out and back in.

Xft.dpi: 96

This will work only if KDE uses XFT. Cheers.

Well, I had forgotten to mention that I had checked the timestamps of all the files in /etc/fonts and none of them have been modified for months - so I don't think it's that.

Wouldn't DPI issues affect everything, like icons and images, and not just fonts. Because for me, it's just text that's changed.

Is there a utility for finding the current DPI?

Offline

#4 2005-08-22 21:31:44

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: Fonts have suddenly become large

xdpyinfo|grep resolution

Offline

#5 2005-08-22 22:28:35

Kern
Member
From: UK
Registered: 2005-02-09
Posts: 460

Re: Fonts have suddenly become large

upgraded ati-drivers (8.14.13-2 -> 8.16.20-1)

Maybe the way the graphics drivers interact with X ...

http://lists.pcxperience.com/pipermail/ … 04960.html
similar issue with nvidia.... maybe ati too ? or same mechanism.

how are you starting your X session ?
http://www.linuxquestions.org/questions/history/349300
may also be worth a read ....

hth or at least point you in the right direction.

Offline

#6 2005-08-22 22:34:29

arooaroo
Member
From: London, UK
Registered: 2005-01-13
Posts: 1,268
Website

Re: Fonts have suddenly become large

Interesting. I am using kdm. If that's it then I don't know why it's suddenly become an issue as it was a while ago since kdm was updated. hmmm... I shall investigate.

Ta

Offline

#7 2005-08-22 23:04:32

arooaroo
Member
From: London, UK
Registered: 2005-01-13
Posts: 1,268
Website

Re: Fonts have suddenly become large

Kern, thanks for all your efforts, although, for now, I opted for a different solution.

Basically, I've got rid of the ati drivers and opted for xorg's radeon drivers. Too be honest, I wasn't doing any 3d stuff in Linux anyway.

I rebuilt an xorg.conf with hwd and all is back to normal.

So, I guess it was ati drivers. I'm sure it could be solved. I mean, I had been using them without a hitch for ages. Although, I did update them recently with the kernel upgrade, and so perhaps its had a lot to do with that. All conjecture at the moment though.

Thanks again.

Offline

#8 2005-08-23 04:17:22

keevn7
Member
From: Lancaster, OH, US
Registered: 2005-06-09
Posts: 206
Website

Re: Fonts have suddenly become large

Just to comment on the DPI part, DPI settings only affect fonts.

Offline

#9 2005-08-23 12:02:42

arooaroo
Member
From: London, UK
Registered: 2005-01-13
Posts: 1,268
Website

Re: Fonts have suddenly become large

Interestingly enough, the DPI issue must have played a part. With the ATI drivers (and it's fglxconfig generated xorg.conf) the DPI was a 98x96 (which struck me as a little odd).

Now, with standard xorg radeon drivers and basic xorg, DPI is 75x75. (I'm using a LCD screen at 1280x800, btw).

Offline

#10 2005-08-23 18:25:45

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: Fonts have suddenly become large

hmm... 98x96 does sound alittle high for 1280x800 res.

Offline

Board footer

Powered by FluxBB