You are not logged in.

#1 2012-08-23 23:55:15

Loser777
Member
Registered: 2011-05-12
Posts: 28

Power saving breaks wireless on T420?

I'm currently using wicd on my laptop, and university-public connectivity issues aside, my connection is dropping out on private networks when the wireless goes idle. The signal strength is excellent, I know this because a neighboring identical laptop running Ubuntu does not experience the same issue with wireless.

I have PCI-E power management disabled in BIOS and created a file in /etc/pm/power.d/wireless (excecutable) as according to the wicd wiki article.

Running iwconfig wlan0 power off returns:

Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.

Offline

#2 2012-08-24 05:03:42

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Power saving breaks wireless on T420?

It would really help to know what your wireless card is, what you mean by "idle" and so forth.  Is teh ThinkPad brand new?  What does lspci -v tell you about the wireless card.  You are really not going to get much of an answer unless you stop expecting the community to make assumptions about a majority of your circumstances.

Offline

#3 2012-08-24 05:37:47

Loser777
Member
Registered: 2011-05-12
Posts: 28

Re: Power saving breaks wireless on T420?

The T420 is about 1 year old.

Lscpi output:

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

To verify that it is indeed a power saving issue:

[84607.227848] wlan0: deauthenticating from xx:xx:xx:xx:xx:xx by local choice (reason=3)

Last edited by Loser777 (2012-08-24 05:41:32)

Offline

#4 2012-08-27 05:38:52

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Power saving breaks wireless on T420?

I have that crappy adapter also.  I just successfully flashed my bios to enable use of a Intel Centrino card and it is AWESOME!  Anyway, try disabling the firmware low power state (fwlps) by adding the following to /etc/modprobe.d/rtl8192ce.conf

rtl8192ce options fwlps=0 ips=0

I am not sure if "airplane mode" is what this is, but I sure as hell was never able to figure out how to use low power state in the card when it was on.  And unless it was off, I had some crazy latency issues.

Edit: on yeah, and either reboot, or remove the module and load it again.  ie...

# modprobe -r rtl8192ce
# modprobe rtl8192ce

you can check to make sure it is off with

$ systool -vm rtl8192ce

Edit: update rtl8192ce.conf w/ ips=0

Last edited by WonderWoofy (2012-08-27 06:04:22)

Offline

#5 2012-08-27 06:03:24

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Power saving breaks wireless on T420?

Ah yes, the deauthenicating bullsh*t, I had that too.  It drove me crazy.  Although it did not go away completely, disabling the fwlps certainly helped.  I also appended ips=0 to that line as t is also a pwoer save controlling "feature"  that may help too.

Offline

#6 2012-09-12 12:13:28

T.J.S.
Member
Registered: 2012-08-14
Posts: 83

Re: Power saving breaks wireless on T420?

WonderWoofy wrote:
rtl8192ce options fwlps=0 ips=0

Actually it's:

options rtl8192ce fwlps=0 ips=0

In case someone hasn't read the wiki about modprobe (and doesn't pay attention to the bootup messages).


Btw, in my case it works better with ips=1 (someone care to explain what that means?). I have more packet losses when far away from router, but at least it doesn't get disconnected so often. I will update further though in the future, but that's my first impression.

edit: I spoke too soon. I have many disconnection issues when I'm not close to the router.
The upside is that I don't have the latency issues when I'm rather close to it, which is sufficient for now.

Last edited by T.J.S. (2012-09-12 18:00:11)

Offline

#7 2012-09-13 03:54:49

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Power saving breaks wireless on T420?

dyslexia...


Edit: ips is some kind of power save.  It is listed as "link power save" by modinfo, but why it starts with an "i" is beyond me.

Last edited by WonderWoofy (2012-09-13 03:56:17)

Offline

Board footer

Powered by FluxBB