You are not logged in.

#1 2012-08-30 12:45:44

anta40
Member
From: Jakarta, Indonesia
Registered: 2010-03-01
Posts: 79

[SOLVED] failed to execute /sbin/init

Today I did an upgrade, and failed:

...
error: failed to commit transaction (conflicting files)
glibc: /lib64 exists in filesystem
Errors occurred, no packages were upgraded.

So I did a "pacman -Syu --force". Then I tried to reboot, but it didn't work, so I turned off and on the computer manually.
I got this:
http://i244.photobucket.com/albums/gg6/ … _error.jpg

Now I'm trying sbillaudelle's suggestion. I failed at creating the symlink:

sh: ln: not found

Now how do I fix this?

Last edited by anta40 (2012-09-22 16:43:16)

Offline

#2 2012-08-30 14:03:26

masteryod
Member
Registered: 2010-05-19
Posts: 429

Re: [SOLVED] failed to execute /sbin/init

Sweet jesus, how many times we have to repeat this:

Never use --force switch unless your were told exactly how to do so in official archlinux.org news and/or you know EXACTLY what you're doing! and even so it won't be on whole upgrade (pacman -Syu) but on particular package!

If your upgrade don't go smoothly first thing you do is calm down and then... google! (preferably with keyword archlinux It's faster than searching Arch linux forums. If there is nothing on forums you start new topic.

When was the last time you did system upgrade? Did you went successfully through glibc upgrade earlier? https://www.archlinux.org/news/the-lib- … a-symlink/

Last edited by masteryod (2012-08-30 14:19:25)

Offline

#3 2012-08-30 15:47:30

anta40
Member
From: Jakarta, Indonesia
Registered: 2010-03-01
Posts: 79

Re: [SOLVED] failed to execute /sbin/init

Yeah sorry, it was a very stupid mistake, and I actually just read about that this afternoon. sad

The last time I did the upgrade was about 2 months ago, and it went smooth.

Offline

#4 2012-08-30 19:29:02

masteryod
Member
Registered: 2010-05-19
Posts: 429

Re: [SOLVED] failed to execute /sbin/init

OK, lesson learned. If I remember correctly there was a topic about someone else screwing glibc upgrade with --force so look it up. There is a lot other topics about that (in)famous glibc upgrade to search for, because people doesn't check archlinux.org if upgrade doesn't go smooth - which reminds me: the very first thing to do in cases like this is to check archlinux.org news section, then google/forums. Actually reading archlinux.org news section is recommended before every upgrade but it's more convenient to do this the other way around - situations that require reading official news are fairly rare.

Good luck smile

PS If it's possible try to upgrade more frequently, once a week or two is sane recommendation (maybe weekends if you use Arch as a work horse). That way system is easier to maintain (e.g. .pacnew files). Also in case of breakage there is fewer suspects/smaller damages. Personally I do upgrades on daily basis, even couple of times per day - but this is personal machine not used in critical tasks.

Last edited by masteryod (2012-08-30 19:30:24)

Offline

#5 2012-08-31 15:48:13

anta40
Member
From: Jakarta, Indonesia
Registered: 2010-03-01
Posts: 79

Re: [SOLVED] failed to execute /sbin/init

OK, I decided to use chroot chroot
I followed it step by step (my disk has 3 partitions, FYI: /dev/sda1 = Windows, /dev/sda2 = data partition. /dev/sda3= Linux).

Failed at chroot part:

# chroot . /bin/bash
chroot: failed to run command /bin/bash: No such file or directory

I did more search, and found eaep's post, which tells us how to repair glibc

#cp /mnt/arch/var/cache/pacman/pkg/glibc-2.16.0-4-x86_64.pkg.tar.xz /mnt/arch/
#tar -Jxvf glibc-2.16.0-4-x86_64.pkg.tar.xz
tar: lib: Cannot create symlink to `usr/lib': File exists
tar: lib64: Cannot create symlink to `usr/lib': File exists
tar: Ignoring unknown extended header keyword: `SCHILY.fflags' 
tar: Ignoring unknown extended header keyword: `SCHILY.fflags'
tar: Ignoring unknown extended header keyword: `SCHILY.fflags'
tar: Existing with failure status due to previous errors                                                 :(

What to do with usr/lib now? There are lots of .so.* files in it.

Last edited by anta40 (2012-08-31 15:48:38)

Offline

#6 2012-09-01 09:59:23

anta40
Member
From: Jakarta, Indonesia
Registered: 2010-03-01
Posts: 79

Re: [SOLVED] failed to execute /sbin/init

Is is safe to rename /usr/lib, and then repeat the tar process?

Offline

#7 2012-09-22 02:15:43

anta40
Member
From: Jakarta, Indonesia
Registered: 2010-03-01
Posts: 79

Re: [SOLVED] failed to execute /sbin/init

So I renamed lib to lib-original and lib64 to lib64-orignial, and repeated the tar part. It worked.
After that, I reboot my laptop.

During booting, I found "loading user specified modules.... [FAIL]". No more kernel panic, at least
Finally, the KDM appeared.

I couldn't move the cursor. Also Ctrl+Alt+F1 didn't work. How to fix this?

Last edited by anta40 (2012-09-22 02:16:33)

Offline

#8 2012-09-22 16:42:38

anta40
Member
From: Jakarta, Indonesia
Registered: 2010-03-01
Posts: 79

Re: [SOLVED] failed to execute /sbin/init

Solved. What I did was repeat the chroot again, and then ran "pacman -Su".
Reboot after installation was done.

Offline

Board footer

Powered by FluxBB