You are not logged in.

#1 2005-08-27 07:13:18

sven
Member
Registered: 2005-02-01
Posts: 311

[SOLVED] Firefox and bad fonts

I would like to start using Firefox and its excellent plugins, but the only thing that prevents me are the fonts. They seem plain evil!

They are fuzzy and somehow too large and CTRL++ or CTRL+- won't help with the look. Take a loot at these:

firefox.jpg
Firefox: fonts are fuzzy and some characters are looking like painted - see the copyright sign for example! :evil: Also the distance between different characters in a word doesnt seem to be equal all the times and that makes it hard to grasp the word.

mozilla.jpg
Mozilla Suite: crisp and clear

I think it is somehow xft - related, because I downloaded the standard Mozilla suite build and it also had these awful fonts and then tried the non-xft build and fonts were ok. In Appearance-Fonts they are described as Serif -> adobe-times-iso8859-1, Sans-serif -> adobe-helvetica-iso8859-1 and so on. How could I get these fonts appear in Firefox, too?

I have tried to compile Firefox myself with disable-xft option, but it fails with an error about gtk not being found in pkgconfig path.

Offline

#2 2005-08-27 07:52:05

Cotton
Member
From: Cornwall, UK
Registered: 2004-09-17
Posts: 547

Re: [SOLVED] Firefox and bad fonts

Try using the Bitstream Vera fonts.

Offline

#3 2005-08-27 08:14:28

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 799

Re: [SOLVED] Firefox and bad fonts

If you're using KDE:

Control Centre -> Appearance -> Fonts

1) Tick "Use anti-aliasing for fonts" then click "Configure"
2) Tick "Exclude range" then set from = 0 and to = 7 (experiment with this)
3) On my 17 inch TFT I also tick "Use sub-pixel hinting" (RGB, slight)

You need to log out and in to see the new effect.

Offline

#4 2005-08-27 09:33:47

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

Thanks, guys, I tried both things, but still they did not help with the problem. I can't help myself comparing firefox with mozilla suite... I'll try to find the build I am using so everyone can try it, too.

I have disabled anti-aliasing altogether because I like clear fonts. I am using only smoothansi 10 for everything except General (for it Smoothansi 13) in KDE because all the others seemed messed up somehow. In Konsole I am using "Fixed [Misc]" Regular 15.

Offline

#5 2005-08-27 09:54:27

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

Now I tried Arch' build of mozilla and it is even worse than firefox! Fonts seem  badly broken. And font names are completely different between my version (1.7.10) and Arch (1.7.8 ) version. See the screenshots of mozilla fonts tab and on the background there is mozilla start page:
Arch build
my build

In Arch build fonts seem to have jagged edges even when I try to change their size or type to Bitstream Vera. Bad looks with browsers have always been way too much familiar to me when I have tried other Linux distros. I think this should be fixed in Arch per default so no newbies would be deterred away because of this.

Offline

#6 2005-08-27 10:11:46

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

Here is the newest good-looking build: http://ftp.mozilla.org/pub/mozilla.org/ … .11.tar.gz

I think the program layout fonts being bad was partly related to gtk font settings, this is how I remember I fixed them for mozilla suite.

Offline

#7 2005-08-27 11:03:29

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

I tried Opera now, and fonts are bad there, too.
opera.jpg

Offline

#8 2005-08-27 12:20:14

ghostwalker
Member
From: Tacoma, WA
Registered: 2004-07-28
Posts: 140

Re: [SOLVED] Firefox and bad fonts

Also what is commented/not-commented out in /etc/fonts/local.conf look like?


P4 2.8Ghz @ 2.8Ghz SL6WT
Zalman CNPS7000-Cu
865PE Neo-2 LS BIOs 2.4
512mb Mushkin Level II
160GB Maxtor HD
Geforce 4 440MX
Antec 3700 1 exhaust and 1 intake fans
Linux 2.6.x
Linux user 314187
ArchLinux

Offline

#9 2005-08-27 13:36:42

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

/etc/fonts/local.conf looks like this:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>

        <!--Use the Auto-Hinter-->
        <match target="pattern">
                <edit name="autohint" mode="assign">
                        <bool>true</bool>
                </edit>
        </match>
<!--
Disable anti-aliasing for fonts that are size <=12
        <match target="pattern">
                <test qual="any" name="size" compare="less_eq">
                        <int>12</int>
                </test>
                <edit name="antialias" mode="assign"><bool>false</bool></edit>
        </match>
-->

<!--
Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
</fontconfig>

Offline

#10 2005-08-27 15:25:40

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: [SOLVED] Firefox and bad fonts

I have had bad luck with the autohinter. I comment that one out.
If you are using an lcd, uncommen the sub-pixel-rendering  section.
then do fc-cache -fv


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#11 2005-08-27 16:01:09

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: [SOLVED] Firefox and bad fonts

Firefox and thunderbird on archlinux use Pango for font rendering. To configure pango, you could install control-center and launch gnome-font-properties, though pango picks up Xft settings also.

Offline

#12 2005-08-27 17:33:25

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

I checked from where I changed font settings for gtk programs - it is at .gtkrc-2.0

style "user-font" {
    font_name = "smoothansi 13"
}
widget_class "*" style "user-font"

gnome-font-properties did not seem to have any effect on started programs,like Firefox. Would it also be needed to restart X after making changes to gnome-font-properties?

Disabling autohinter did not have any effect either. Now the fonts in both Firefox and Opera are looking the same, just like in that screenshot from Opera.

Got to check that Gentoo wiki then...

Offline

#13 2005-08-29 06:56:37

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: [SOLVED] Firefox and bad fonts

i'd mess around with the about:config settings in firefox, as I'm not too sure what you're looking for - from the first post, the top shot is antialiased (which is what I like) and the bottom is not.

Offline

#14 2005-08-29 08:42:11

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

Well, it is more a matter of taste then smile I want all to be as clear as possible - no antialiasing,no fuzzyness.

It is only now when I have started to want to use Firefox so I have little experience with it. I tried to change about:config settings, too, but seems Firefox refuses to accept any changes. I tried to change fonts in Firefox settings, but it doesn't seem to accept change there,either. When I close it and restart it after a change, fonts on all pages look just like in that picture I took from Opera.

I followed the Gentoo guide and it seems to make things a bit worse for X - it is harder to "get a grip" of fonts. Perhaps it is autohinting. In Opera and Firefox they did look better, but still not as good as the ones my build of Mozilla Suite has.

Offline

#15 2005-08-29 09:42:50

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

I think disabling xft and rebuilding Firefox is a solution to my problem - I found a blog article, where there is xft build and non-xft build. And fonts in non-xft build of Firefox are looking just like in this Mozilla Suite I have been using.

Offline

#16 2005-08-29 09:54:51

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

I am still having trouble compiling the Firefox. Here's where compilation fails:

checking for gtk+-2.0 >= 1.3.7... Package gtk+-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'gtk+-2.0' found
configure: error: Library requirements (gtk+-2.0 >= 1.3.7) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
make: *** No targets specified and no makefile found.  Stop.
==> ERROR: Build Failed.  Aborting...

Offline

#17 2005-08-29 10:41:12

keevn7
Member
From: Lancaster, OH, US
Registered: 2005-06-09
Posts: 206
Website

Re: [SOLVED] Firefox and bad fonts

What you call "crisp", I just call "aliased". The fonts in Opera are also aliased, which makes them look poor. Your Firefox's fonts look nice, except the fact that the autohinter is making them look sloppy. Comment that part out and see how it looks.

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>

        <!--Use the Auto-Hinter-->
        <!--<match target="pattern">
                <edit name="autohint" mode="assign">
                        <bool>true</bool>
                </edit>
        </match>-->
<!--
Disable anti-aliasing for fonts that are size <=12
        <match target="pattern">
                <test qual="any" name="size" compare="less_eq">
                        <int>12</int>
                </test>
                <edit name="antialias" mode="assign"><bool>false</bool></edit>
        </match>
-->

<!--
Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
</fontconfig>

Cheers.

Offline

#18 2005-08-29 11:09:57

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

ok, keevn7 - I commented out all in ~/.font.conf and /etc/fonts/local.conf - now fonts are looking pretty good in both Opera and Firefox. The quality is just the same in both of them:

opera2.jpg
Here is a screencap from Opera

BTW I have been with those aliased fonts in Mozilla Suite since February and that's why started to like them smile

I'd be happy, if anyone still knows how to make Firefox compilation to work. I would like to try out different compilation options.

Offline

#19 2005-08-29 15:05:13

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: [SOLVED] Firefox and bad fonts

Make sure you have pkgconfig 0.19 and make sure you have gtk2 installed. There's been a version of pkgconfig which took the wrong includepath for pkg-config files, so /usr/lib/pkgconfig was excluded.

Offline

#20 2005-08-29 15:20:06

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

Thanks, JGC! I had pkgconfig v. 0.18 and when I updated to 0.19, compilation started up.

Offline

#21 2005-08-29 15:26:32

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: [SOLVED] Firefox and bad fonts

sven wrote:

I think disabling xft and rebuilding Firefox is a solution to my problem - I found a blog article, where there is xft build and non-xft build. And fonts in non-xft build of Firefox are looking just like in this Mozilla Suite I have been using.

For the record, you *do not* need to recompile firefox to enable/disable xft... like I said in an earlier post, in the url type "about:config" and change the "freetype2" settings (I think that's what it's called)

Offline

#22 2005-08-29 15:37:45

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

I checked about:config again and there is option font.FreeType2.enable and set this to false. That seemed to set fonts to be just like just like in that Mozilla Suite.

Offline

#23 2005-08-29 16:32:25

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: [SOLVED] Firefox and bad fonts

sven wrote:

I checked about:config again and there is option font.FreeType2.enable and set this to false. That seemed to set fonts to be just like just like in that Mozilla Suite.

That's what you wanted, correct?

Offline

#24 2005-08-29 17:16:53

sven
Member
Registered: 2005-02-01
Posts: 311

Re: [SOLVED] Firefox and bad fonts

Yes, that was my intention with fonts in Firefox. Thanks!

Offline

#25 2005-08-29 20:17:08

keevn7
Member
From: Lancaster, OH, US
Registered: 2005-06-09
Posts: 206
Website

Re: [SOLVED] Firefox and bad fonts

Aliased fonts make my eyes hurt. I get enough of them in WindowsXP when I play Maple Story. Good luck with them. tongue

Offline

Board footer

Powered by FluxBB