You are not logged in.

#1 2012-09-08 22:40:04

LyCC
Member
Registered: 2012-09-05
Posts: 92

[SOLVED] Bino 3D Player

Hi everyone,

Website: http://bino3d.org/
The package is allready in AUR ( https://aur.archlinux.org/packages.php? … _Search=Go ) , one is orphan, the other is from git and doesn't  build either.
I tried to build from Git, but it doesn't work, nor the stable 1.4.0 version (i get duplicate declaration erros), nor the prev. 1.3.5.
Can anyone please compile this to make a package?
Thanks.

Edit: i managed to compile version 1.2, so this will do, unfortunatly it's missing some new features ... but that's that, 1.3.5, 1.4 stable, doesn't compile, in other distros the package is allready 1.4 sad

Last edited by LyCC (2012-09-18 20:33:15)

Offline

#2 2012-09-17 09:49:42

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [SOLVED] Bino 3D Player

i'm able to compile latest version of bino (through AUR)

neither errors nor problems

if you post the output when you try to compile the app i'll be more useful


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#3 2012-09-18 20:33:03

LyCC
Member
Registered: 2012-09-05
Posts: 92

Re: [SOLVED] Bino 3D Player

Hi, thank you,
i just tried it again, now it compiles, guess the problem was in the source on git.

One question, i had 1.2 installed, now i installed the 1.4 package over with pacman -U, that upgrades the old package right? Or better i should remove the old one first (in this cases). Thx.

Last edited by LyCC (2012-09-18 20:34:16)

Offline

#4 2012-09-19 08:27:12

nTia89
Banned
From: varese, italy
Registered: 2008-12-22
Posts: 1,230

Re: [SOLVED] Bino 3D Player

if the packages are the same (they have exactly the same name) then pacman do it automatically

otherwise you should remove the old one before install the new, but, if the PKGBUILD is well done (it contains the conflict array....) trying to install the new one, pacman should notice that the two packages are not compatible (together) and suggests you to replace or not


+pc: custom | AMD Opteron 175 | nForce4 Ultra | 2GB ram DDR400 | nVidia 9800GT 1GB | ArchLinux x86_64 w/ openbox
+laptop: Apple | MacBook (2,1) | 2GB ram | Mac OS X 10.4 -> DIED
+ultrabook: Dell | XPS 13 (9343) | 8GB ram | 256GB ssd | FullHD display | Windows 8.1 64bit ArchLinux x86_64 w/ Gnome

Offline

#5 2012-09-22 23:39:14

LyCC
Member
Registered: 2012-09-05
Posts: 92

Re: [SOLVED] Bino 3D Player

Thx.

Offline

Board footer

Powered by FluxBB