You are not logged in.

#1 2012-09-09 19:11:47

From: /world/europe/uk/england
Registered: 2011-04-30
Posts: 202

[SOLVED] Restore Syslinux after Windows install

So, I'm the coming days, as you all know, Windows 8 will be released. I am planning on upgrading Windows 7 to Windows 8 (I'm doing a clean install, actually). Trouble is, this creates the annoying problem of Syslinux (or GRUB) being destroyed, which will stop me booting into Arch Linux.

How would I go about restoring Syslinux once Windows 8 has been installed?

Last edited by oldtimeyjunk (2012-11-04 01:27:11)

"... being a Linux user is sort of like living in a house inhabited by a large family of carpenters and architects. Every morning when you wake up, the house is a little different. Maybe there is a new turret, or some walls have moved. Or perhaps someone has temporarily removed the floor under your bed." - Unix for Dummies, 2nd Edition


#2 2012-09-09 19:38:20

From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Restore Syslinux after Windows install

- Mount the root partition on /mnt.
- Mount the boot partition (if you have one) on /mnt/boot.
- Run "arch-chroot /mnt", and proceed with the instructions from the Beginner's Guide for whichever bootloader you want: … bootloader

You're welcome. Don't forget to mark the topic as solved.

"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).


#3 2012-09-09 21:39:28

From: Denmark
Registered: 2010-06-19
Posts: 667

Re: [SOLVED] Restore Syslinux after Windows install

You can also just mount root partition under /mnt and run:

syslinux-install_update -c /mnt -iam


#4 2012-11-03 20:10:30

From: Belfast, UK
Registered: 2012-07-07
Posts: 203

Re: [SOLVED] Restore Syslinux after Windows install

Sweet! Many thanks @mhertz I had exactly this issue after installing Win7 again.

syslinux-install_update -c /mnt -iam

....reinstalled syslinux and kept my previous configuration. Rebooted and everything is working as normal smile


Board footer

Powered by FluxBB