You are not logged in.

#1 2012-09-10 18:17:40

aliasbody
Member
From: Portugal
Registered: 2010-12-16
Posts: 156
Website

Problems with Wireless since last update of NetworkManager

Hello Everyone,

Yesterday I updated NetworkManager (and also, wpa_supplicant if I remember right, and kdeplasma-applets-networkmanagement). The problem now is that I connect to my Wireless and then after a few seconds (maybe 1minute max), I can't use my internet connection anymore, but the applet says that it is still connected. To make it work again I need to disconnect and then re-connect again.

Here are the information I can give :

lspci

03:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network

Kernel.log

Sep 10 19:10:02 localhost kernel: [ 1324.198049] wlan0: authenticate with 2c:b0:5d:b8:76:b2
Sep 10 19:10:02 localhost kernel: [ 1324.210490] wlan0: send auth to 2c:b0:5d:b8:76:b2 (try 1/3)
Sep 10 19:10:02 localhost kernel: [ 1324.212868] wlan0: authenticated
Sep 10 19:10:02 localhost kernel: [ 1324.219892] wlan0: associate with 2c:b0:5d:b8:76:b2 (try 1/3)
Sep 10 19:10:02 localhost kernel: [ 1324.223747] wlan0: RX AssocResp from 2c:b0:5d:b8:76:b2 (capab=0x411 status=0 aid=1)
Sep 10 19:10:02 localhost kernel: [ 1324.223829] wlan0: associated

Errors.log

Sep 10 18:48:09 localhost /usr/sbin/crond[435]: (CRON) INFO (Syslog will be used instead of sendmail.): No such file or directory
Sep 10 18:48:10 localhost NetworkManager[401]: <error> [1347299290.630837] [wifi-utils-nl80211.c:669] nl80211_wiphy_info_handler(): Don't know the meaning of NL80211_ATTR_CIPHER_SUITES 0x000fac06.
Sep 10 18:48:19 localhost kdm_greet[563]: Cannot load /usr/share/apps/kdm/faces/.default.face: No such file or directory
Sep 10 18:48:45 localhost dhclient: can't create /var/lib/dhclient/dhclient-510854b1-14d2-4151-beb1-051d264b184d-wlan0.lease: No such file or directory
Sep 10 18:48:46 localhost dhclient: can't create /var/lib/dhclient/dhclient-510854b1-14d2-4151-beb1-051d264b184d-wlan0.lease: No such file or directory
Sep 10 18:54:24 localhost kernel: [  385.834000] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 18:54:24 localhost kernel: [  385.834011] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 18:54:27 localhost dhclient: can't create /var/lib/dhclient/dhclient-510854b1-14d2-4151-beb1-051d264b184d-wlan0.lease: No such file or directory
Sep 10 18:54:36 localhost dhclient: can't create /var/lib/dhclient/dhclient-510854b1-14d2-4151-beb1-051d264b184d-wlan0.lease: No such file or directory
Sep 10 18:56:06 localhost kernel: [  487.895676] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 18:56:06 localhost kernel: [  487.895686] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 19:00:20 localhost kernel: [  741.590311] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 19:00:20 localhost kernel: [  741.590324] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 19:00:20 localhost kernel: [  741.590329] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 19:00:43 localhost kernel: [  765.332093] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 19:04:52 localhost kernel: [ 1014.346686] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 10 19:04:52 localhost kernel: [ 1014.346696] ath: phy0: TX while HW is in FULL_SLEEP mode
[maria@Maria-PC ~]$ iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:"CABOVISAO-EA70"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 2C:B0:5D:B8:76:B2   
          Bit Rate=39 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=44/70  Signal level=-66 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4   Missed beacon:0

Thanks in Advance,
Luis Da Costa


Arch Linux - They see me rollin', they hatin'

Offline

#2 2012-09-10 20:08:24

6ng4n
Member
Registered: 2012-02-07
Posts: 74

Re: Problems with Wireless since last update of NetworkManager

what about rfkill list

Offline

#3 2012-09-10 20:19:35

aliasbody
Member
From: Portugal
Registered: 2010-12-16
Posts: 156
Website

Re: Problems with Wireless since last update of NetworkManager

6ng4n wrote:

what about rfkill list

This is the output of rfkill :

0: acer-wireless: Wireless LAN
           Soft blocked: no
           Hard blocked: no
1: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no

Arch Linux - They see me rollin', they hatin'

Offline

#4 2012-09-10 20:22:06

aliasbody
Member
From: Portugal
Registered: 2010-12-16
Posts: 156
Website

Re: Problems with Wireless since last update of NetworkManager

The only solution is to Downgrade those packages and it solves the problem for now :S... Weird that I didn't found anyone with the same problem (I need to test it on my others laptops).


Arch Linux - They see me rollin', they hatin'

Offline

#5 2012-09-10 20:56:54

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 728

Re: Problems with Wireless since last update of NetworkManager

aliasbody wrote:

The only solution is to Downgrade those packages and it solves the problem for now :S... Weird that I didn't found anyone with the same problem (I need to test it on my others laptops).

I was away for a few days and this evening did a pacman -Syu on a laptop with ipw2200 - and I am having similar and severe loss of connection on wireless - networkmanager was one of the updates - not sure what best to do here!

I use KDE but this should not be dependent on the kde plasma-networkmanagement package - I guess I should downgrade and see if it helps though it is late in the UK so I will leave this till tomorrow now.

I would imagine others are or will have similar issues.

Last edited by mcloaked (2012-09-10 20:57:40)


Mike C

Offline

#6 2012-09-11 06:54:05

Legogris
Member
Registered: 2012-09-11
Posts: 36

Re: Problems with Wireless since last update of NetworkManager

Similar symptoms here. However, my problem was not solved by downgrading networkmanager (tried to networkmanager-0.9.4.0-6, same issue here).
nm-applet correctly lists available interfaces and tries to authenticate to my AP, gets an IP right away but straight after I lose it and then it looks like it's trying to reconnect for a long time. Sometimes it seems like I connected after a while and get an IP, but can't really do anything except ping my own IP.

lspci:
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

rfkill list:

0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

errors.log:

Sep 11 10:45:13 localhost NetworkManager[1770]: <error> [1347353113.507334] [wifi-utils-nl80211.c:669] nl80211_wiphy_info_handler(): Don't know the meaning of NL80211_ATTR_CIPHER_SUITES 0x000fac06.
Sep 11 10:45:13 localhost dhcpcd[1775]: eth0: sendmsg: Cannot assign requested address
Sep 11 10:45:14 localhost kernel: [  926.006420] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:15 localhost dhcpcd[1816]: wlan0: sendmsg: Cannot assign requested address
Sep 11 10:45:25 localhost kernel: [  937.115320] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.115335] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.115340] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.124019] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.124534] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:37 localhost kernel: [  949.224720] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:37 localhost kernel: [  949.227004] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:40 localhost kernel: [  951.331039] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:40 localhost kernel: [  951.331753] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:41 localhost NetworkManager[1770]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
Sep 11 10:45:52 localhost kernel: [  964.248318] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:52 localhost kernel: [  964.248936] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:04 localhost kernel: [  975.841375] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:04 localhost kernel: [  975.841916] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:08 localhost kernel: [  980.055647] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:08 localhost kernel: [  980.056881] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:10 localhost NetworkManager[1770]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
Sep 11 10:46:24 localhost kernel: [  996.151206] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:24 localhost kernel: [  996.152140] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:36 localhost kernel: [ 1008.052517] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:36 localhost kernel: [ 1008.053539] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:41 localhost NetworkManager[1770]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
Sep 11 10:46:52 localhost kernel: [ 1024.155202] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:46:52 localhost kernel: [ 1024.155824] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:47:04 localhost kernel: [ 1035.752317] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:47:04 localhost kernel: [ 1035.753108] ath: phy0: TX while HW is in FULL_SLEEP mode

kernel.log:

Sep 11 10:45:13 localhost kernel: [  924.885910] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sep 11 10:45:14 localhost kernel: [  925.939685] wlan0: authenticate with 00:16:a6:12:e0:b0
Sep 11 10:45:14 localhost kernel: [  925.952192] wlan0: send auth to 00:16:a6:12:e0:b0 (try 1/3)
Sep 11 10:45:14 localhost kernel: [  925.954290] wlan0: authenticated
Sep 11 10:45:14 localhost kernel: [  925.961756] wlan0: associate with 00:16:a6:12:e0:b0 (try 1/3)
Sep 11 10:45:14 localhost kernel: [  925.966830] wlan0: RX AssocResp from 00:16:a6:12:e0:b0 (capab=0x411 status=0 aid=3)
Sep 11 10:45:14 localhost kernel: [  925.968369] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Sep 11 10:45:14 localhost kernel: [  925.968430] wlan0: associated
Sep 11 10:45:14 localhost kernel: [  925.976822] wlan0: disassociating from 00:16:a6:12:e0:b0 by local choice (reason=3)
Sep 11 10:45:14 localhost kernel: [  926.005689] cfg80211: Calling CRDA to update world regulatory domain
Sep 11 10:45:14 localhost kernel: [  926.006412] wlan0: deauthenticating from 00:16:a6:12:e0:b0 by local choice (reason=3)
Sep 11 10:45:14 localhost kernel: [  926.006420] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:15 localhost kernel: [  927.055728] wlan0: authenticate with 00:16:a6:12:e0:b0
Sep 11 10:45:15 localhost kernel: [  927.068456] wlan0: send auth to 00:16:a6:12:e0:b0 (try 1/3)
Sep 11 10:45:15 localhost kernel: [  927.071092] wlan0: authenticated
Sep 11 10:45:15 localhost kernel: [  927.081434] wlan0: associate with 00:16:a6:12:e0:b0 (try 1/3)
Sep 11 10:45:15 localhost kernel: [  927.086812] wlan0: RX AssocResp from 00:16:a6:12:e0:b0 (capab=0x411 status=0 aid=3)
Sep 11 10:45:15 localhost kernel: [  927.087724] wlan0: associated
Sep 11 10:45:25 localhost kernel: [  937.086690] wlan0: disassociating from 00:16:a6:12:e0:b0 by local choice (reason=3)
Sep 11 10:45:25 localhost kernel: [  937.115320] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.115335] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.115340] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.122145] cfg80211: Calling CRDA to update world regulatory domain
Sep 11 10:45:25 localhost kernel: [  937.123996] wlan0: deauthenticating from 00:16:a6:12:e0:b0 by local choice (reason=3)
Sep 11 10:45:25 localhost kernel: [  937.124019] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:25 localhost kernel: [  937.124517] wlan0: deauthenticating from 00:16:a6:12:e0:b0 by local choice (reason=3)
Sep 11 10:45:25 localhost kernel: [  937.124534] ath: phy0: TX while HW is in FULL_SLEEP mode
Sep 11 10:45:27 localhost kernel: [  939.175379] wlan0: authenticate with 00:16:a6:12:e0:b0
Sep 11 10:45:27 localhost kernel: [  939.187967] wlan0: send auth to 00:16:a6:12:e0:b0 (try 1/3)
Sep 11 10:45:27 localhost kernel: [  939.190312] wlan0: authenticated
Sep 11 10:45:27 localhost kernel: [  939.197572] wlan0: associate with 00:16:a6:12:e0:b0 (try 1/3)
Sep 11 10:45:27 localhost kernel: [  939.201946] wlan0: RX AssocResp from 00:16:a6:12:e0:b0 (capab=0x411 status=0 aid=3)
Sep 11 10:45:27 localhost kernel: [  939.203598] wlan0: associated

All with latest network-manager. I might add that it was some months since I actually used wireless on this computer.

Offline

#7 2012-09-11 07:42:42

aliasbody
Member
From: Portugal
Registered: 2010-12-16
Posts: 156
Website

Re: Problems with Wireless since last update of NetworkManager

It seems to be a problem with Atheros Wireless cards :S...

Maybe a change on the driver code, I will try it on my other laptop with Atheros Wireless Card to see if the problem persist.


Arch Linux - They see me rollin', they hatin'

Offline

#8 2012-09-12 14:59:38

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 728

Re: Problems with Wireless since last update of NetworkManager

mcloaked wrote:
aliasbody wrote:

The only solution is to Downgrade those packages and it solves the problem for now :S... Weird that I didn't found anyone with the same problem (I need to test it on my others laptops).

I was away for a few days and this evening did a pacman -Syu on a laptop with ipw2200 - and I am having similar and severe loss of connection on wireless - networkmanager was one of the updates - not sure what best to do here!

I use KDE but this should not be dependent on the kde plasma-networkmanagement package - I guess I should downgrade and see if it helps though it is late in the UK so I will leave this till tomorrow now.

I would imagine others are or will have similar issues.

Today booting the same machine wireless is working - it is possible that the problem I had is intermittent - but I will have to test over a period and see if the problem returns.


Mike C

Offline

#9 2012-09-19 08:51:29

Aarin
Member
From: Lisbon, Portugal
Registered: 2008-01-12
Posts: 18

Re: Problems with Wireless since last update of NetworkManager

I'm having the same "ath: phy0: TX while HW is in FULL_SLEEP mode" problem on a fresh install using only wicd-curses on TTY1 (I just have base and base-devel installed).

So perhaps the problem is in the kernel driver... no? I'm using the 3.5.3-arch btw

Last edited by Aarin (2012-09-19 08:52:27)


Using a HP dv6-3180sp: Intel Core i5-460M, ATI HD5650 1gb

Offline

#10 2012-09-21 14:32:51

archie0
Member
Registered: 2012-02-26
Posts: 144

Re: Problems with Wireless since last update of NetworkManager

Getting the same error on reboot/shut down. In my case, it happened after updating the Linux kernel.

Offline

#11 2012-09-21 18:56:06

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 728

Re: Problems with Wireless since last update of NetworkManager

It turned out to be flaky hardware - I bought a replacement wireless card (Intel Pro 2200BG) and it as worked flawlessly ever since replacing the wireless card.


Mike C

Offline

#12 2012-09-24 05:17:48

archie0
Member
Registered: 2012-02-26
Posts: 144

Re: Problems with Wireless since last update of NetworkManager

Hmm. I am still getting this. Only occurs when I'm rebooting from KDE.

Offline

#13 2012-09-26 06:14:47

archie0
Member
Registered: 2012-02-26
Posts: 144

Re: Problems with Wireless since last update of NetworkManager

SystemD solved my problem, I guess it's not the hardware after all.

Offline

#14 2012-09-26 08:22:45

aqeeliz
Member
Registered: 2007-10-13
Posts: 31

Re: Problems with Wireless since last update of NetworkManager

Similar problem here, started happened last night.

I am not at my home right now so can't check all the info. One thing I noticed that when my connection stops working (but network manager shows that it is still connected), pinging anything gives following error:

ping: sendmsg: No buffer space available

I can try downgrading, if pacman hasn't removed old packages from cache, any other suggestions?

Offline

#15 2012-10-17 19:05:22

Wikimig
Developer
From: France
Registered: 2004-12-10
Posts: 77
Website

Re: Problems with Wireless since last update of NetworkManager

I'm having similar issues on a server with no networkmanager so problems does not come from it.

> SystemD solved my problem, I guess it's not the hardware after all.
Really? This is Arch! Not Ubuntu! wink

Offline

#16 2012-10-20 07:12:11

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Problems with Wireless since last update of NetworkManager

For what its worth my wife's laptop has numerous wireless problems with the link dropping out using her Atheros wireless with NetworkManager. Removing NetworkManager and using WPASupplicant instead solved the problem. NetworkManager seems to work fine with any other wireless adapter.

Andrew

Offline

#17 2012-10-20 07:49:12

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problems with Wireless since last update of NetworkManager

@fdservices, if that is the case, you know you could always just use netcfg, as it is just a shell script wrapper for wpa_supplicant.

Offline

#18 2012-10-20 11:44:09

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Problems with Wireless since last update of NetworkManager

Right, I didn't know that. Thanks.

Offline

#19 2012-10-25 06:03:17

szebenyib
Member
From: LHBP
Registered: 2011-10-18
Posts: 64

Re: Problems with Wireless since last update of NetworkManager

Hello,

I'm also affected by this. (Atheros adapter on sony vaio, plus networkmanager - just installed Arch yesterday)
Has there been any progress on this issue? Upon booting my laptop, right when the login prompt appears, these messages come every second as long as I do not shut down my wifi by set ip link wlan0 down.

Offline

#20 2012-10-25 07:26:11

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Problems with Wireless since last update of NetworkManager

Use WPAsupplicant or netcfg if you have an atheros adapter. NetworkManager seems to have problems with atheros.

Offline

#21 2012-10-25 15:14:54

lastchancetosee
Member
From: Berlin
Registered: 2009-02-19
Posts: 118

Re: Problems with Wireless since last update of NetworkManager

Problem exists with net-auto-wireless as well, but so far it's OK if I connect manually with netcfg.

Maybe the issue is not with the daemons per se, but with them being started too early?

[edit: Scratch that. It just happened while using netcfg as well. I'm using systemd, so archie isn't on the money either.
'full sleep' sound like standby-related.]

Last edited by lastchancetosee (2012-10-25 15:40:13)


My ship don't crash! She crashes, you crashed her!

Offline

#22 2012-10-25 15:30:06

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Problems with Wireless since last update of NetworkManager

Sorry, I don't know anything about netcfg, I just set my wife's laptop to use WPAsupplicant direct. Providing the APs are set up correctly it roams fine. I could not get NetworkManager to hold up the connection for more than half an hour at a time. Very annoying if you are listening to Radio 4 big_smile

Offline

#23 2012-10-25 15:46:41

lastchancetosee
Member
From: Berlin
Registered: 2009-02-19
Posts: 118

Re: Problems with Wireless since last update of NetworkManager

The problem persists with netcfg (see edit above), and since that is just a wrapper WPAsupplicant really should have a problem as well. Maybe you're just lucky. I'll give it a try anyway.


My ship don't crash! She crashes, you crashed her!

Offline

#24 2012-10-25 17:04:34

fdservices
Member
From: France
Registered: 2012-02-06
Posts: 318

Re: Problems with Wireless since last update of NetworkManager

OK need to look into this further

wpa_supplicant.conf contains:
network={
    psk="passkey"
    priority=1
    scan_ssid=0
    ssid="SSID"
}


I start wpa_supplicant with:
# wpa_supplicant -B -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0 -D wext
then get an address with
# dhclient wlan0
then I check the route and the gateway are correct, just in case.

You doing anything different?

I have not yet updated my wife to systemd.

Sorry if I am a bit vague, I put it all into a script which runs at startup.

Last edited by fdservices (2012-10-25 17:05:12)

Offline

#25 2012-10-25 18:56:51

lastchancetosee
Member
From: Berlin
Registered: 2009-02-19
Posts: 118

Re: Problems with Wireless since last update of NetworkManager

You doing anything different?

I didn't have time to test wpa_supplicant without netcfg. I've now just used your .conf. I'd need to look into the netcfg-script, but I assume that at least the wpa_supplicant command is the same. Looks pretty standard and it's what I would have used as well.

Now for the interesting part:
- I've been unable to reproduce the error with manual calls to wpa_supplicant and dhcpcd (I don't use dhclient) like you do.
- Killing wpa_supplicant after connecting to the network consistently produces the HW-in-full-sleep error.


So the question seems to be: What does netcfg do when connecting besides starting wpa_supplicant and dhcpcd?

I have not yet updated my wife to systemd.

Now there's a sentence open to interpretation ...

Last edited by lastchancetosee (2012-10-25 18:58:05)


My ship don't crash! She crashes, you crashed her!

Offline

Board footer

Powered by FluxBB