You are not logged in.

#1 2012-09-19 09:22:18

ajaykumar
Member
From: India
Registered: 2010-08-04
Posts: 34
Website

[SOLVED]geany -- Error -- Configuration directory could not be created

Hi all,

This is the error I am getting with using geany,

Configuration directory could not be created (Permission denied).
There could be some problems using Geany without a configuration directory.
Start Geany anyway?

Though geany is working fine, I dont understand what the error means.
So, Can anyone help me with a solution ?

Thanks in advance.

With regards
Ajay Kumar G

Last edited by ajaykumar (2012-09-19 10:31:40)


With regards,
Ajay Kumar G
Nanos Gigantum Humeris Insidentis

Offline

#2 2012-09-19 09:53:58

aqeeliz
Member
Registered: 2007-10-13
Posts: 31

Re: [SOLVED]geany -- Error -- Configuration directory could not be created

It seems geany can not create (or maybe access) it's configuration directory (should be ~/.geany or something in ~/.config), see if you can find anything there. If the directory already exists, you may have to edit it's permission, if not, you can try creating it (though I am not sure which would be the right place for it).

As for what would happen if you keep using Geany anyway, you won't be able to save any configuration. That is, any changes you made to Geany, would be lost when you close it (that is, Geany's configuration, any other file you edit should be saved properly).

Offline

#3 2012-09-19 10:31:22

ajaykumar
Member
From: India
Registered: 2010-08-04
Posts: 34
Website

Re: [SOLVED]geany -- Error -- Configuration directory could not be created

Hi aqeeliz,

Thanks for the suggestions, it solved the problem.

I found out that my user was not granted permission for  '~/.config/geany', I changed the permission of rwx to my user and its working now.

And previously when I used option Start Geany Anyway, it used to save the document without any problem. I think, the permission problem was faced because, I just installed lxde and copied some files from /etc/xdg/ to .config/openbox folder as root. Hence, the permissions got changed.

Thank you once again smile

With regards,
Ajay Kumar G


With regards,
Ajay Kumar G
Nanos Gigantum Humeris Insidentis

Offline

Board footer

Powered by FluxBB