You are not logged in.

#1 2012-09-21 07:22:22

marko2010
Member
Registered: 2010-04-17
Posts: 66

[SOLVED] "nomodeset" trick no longer works - blank screen old GeForce2

I am installing Arch on an old Dell laptop with a NV11 GeForce2 video chipset. Although adding "nomodeset" to the kernel pararmeters line works fine when I boot from the Arch install CD, I can not get a console or anything else when I boot from the new install. What happens is the message "Grub Loading Welcome to GRUB!" appears for a split second, then the screen goes completely dark.

I have tried to temporaraly change the boot parameters on the new install by pressing the SHIFT button when grub2 is loading, but the the screen goes blank before displaying anything to edit.

I also used the Arch install CD to chroot into my new install and change my "/etc/default/grub" so the kernel parameter line reads:
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

...and updating my grub.cfg afterwards, but this makes no difference -- I still get a blank screen on my new install.




I

Last edited by marko2010 (2012-09-23 19:49:30)

Offline

#2 2012-09-23 19:46:45

marko2010
Member
Registered: 2010-04-17
Posts: 66

Re: [SOLVED] "nomodeset" trick no longer works - blank screen old GeForce2

I just found out that if I add a vga=791 to my kernel option line in /etc/default/grub (being sure to update my grub.cfg afterwards), I can get a working console instead of just a blank screen. So my /etc/default/grub has the following:

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset  vga=791"

This works, I can at least start working in command line mode, but of course since nouveau driver needs KMS I'll need to remove this when getting X going. That's another problem, so I am marking this thread as "SOLVED"

Last edited by marko2010 (2012-09-23 19:47:53)

Offline

#3 2012-09-28 07:52:36

marko2010
Member
Registered: 2010-04-17
Posts: 66

Re: [SOLVED] "nomodeset" trick no longer works - blank screen old GeForce2

Just an addendum to the solution above:
The 'GRUB_CMDLINE_LINUX_DEFAULT="nomodeset  vga=791"' fix was not perfect. Although it got me a console to log into, I could not get a grub menu because the screen would go blank briefly  when grub loaded , so I could never select the kernel I want to boot into. Even pressing SHIFT or ALT would not get me a grub boot menu.

About a week later I found a much better solution:

1. Change grub kernel boot line to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

2. Then follow the instructions in the Arch Wiki about setting the frame buffer resolution using the new method:
https://wiki.archlinux.org/index.php/Gr … figuration

So in my case I changed the line in my grub file to:
GRUB_GFXMODE=1280x1024x16

your values are likely to vary depending upon what you get when you run the # hwinfo --framebuffer command

Now I have working grub menu and working X using the nv driver. smile

don't forget to update your grub.cfg too. I forgot the first time so saw no changes at first.

Offline

Board footer

Powered by FluxBB