You are not logged in.

#1 2012-09-23 07:18:46

Registered: 2012-09-23
Posts: 1

Failed to retrieve git package from all mirrors [Solved]

Hi there. I'm having trouble installing git. Everything else I've installed has been fine (and I have installed other things while this problem persists)

$ sudo pacman -S git
resolving dependencies...
looking for inter-conflicts...

Targets (2): perl-error-0.17018-1  git-1.7.12-1

Total Download Size:    2.66 MiB
Total Installed Size:   17.00 MiB

Proceed with installation? [Y/n]
:: Retrieving packages from extra...
error: failed retrieving file 'git-1.7.12-1-x86_64.pkg.tar.xz' from : The requested URL returned error: 404 Not Found

I leave pacman running through all the other mirrors, and it just cannot find the file on any of them.

When I look at … os/x86_64/ I see that there is git- which is named differently to the target pacman is looking for (git-1.7.12-1-x86_64.pkg.tar.xz)

I'm new to arch and pacman. Where could this inconsistency be coming from, and how would I go about resolving it?

EDIT: Just found the -y option in the pacman man page. Solved!

Last edited by oadams (2012-09-23 07:26:37)


Board footer

Powered by FluxBB