You are not logged in.

#1 2012-09-24 21:06:08

santodelaespada
Member
Registered: 2009-04-15
Posts: 50

e4rat + systemd = No DM [SOLVED]

I changed to systemd a while ago, and I use e4rat to improve speed on boot and to preload part of my desktop environment.
But when used in conjunction, the desktop manager (LXDM) is not loaded most of the time.
If I change back to not using e4rat it does load everytime.
I tested on other pc with e4rat and sysvinit and there's no problem there neither.

I'm using systemd readahead instead, but it does not preload my desktop on ram. I really prefer the e4rat-preload.

Is there something I can do to use e4rat and systemd on this conditions?

PS: everything else loads just fine, just the DM is not. I get the getty login.

Last edited by santodelaespada (2012-10-05 14:46:00)

Offline

#2 2012-09-24 23:34:10

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,683
Website

Re: e4rat + systemd = No DM [SOLVED]

I use e4rat with systemd and it works great.  Your not trying to use e4rat and systemd's readahead at the same time are you?  I don't use a DM, instead I boot to tty but have autologin and xinit is ran (conditionally) from bashrc.  Have you tried this sort of set up to narrow down whether it is actually a DM problem?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Online

#3 2012-09-24 23:44:39

santodelaespada
Member
Registered: 2009-04-15
Posts: 50

Re: e4rat + systemd = No DM [SOLVED]

Trilby wrote:

I use e4rat with systemd and it works great.  Your not trying to use e4rat and systemd's readahead at the same time are you?

No, I use systemd readahead only because I cant use e4rat and load the dm with the lxdm.service unit automatically
 

Trilby wrote:

Have you tried this sort of set up to narrow down whether it is actually a DM problem?

DM loads just fine under any other conditions. It loads only 1 out of 10 with e4rat + systemd (no readahead)

I do not collect often, but relocate after updates on DE, firefox, linux kernel.
It works fine the first couple of times, but on later boots I have to load manually the DM.

Offline

#4 2012-10-05 14:45:44

santodelaespada
Member
Registered: 2009-04-15
Posts: 50

Re: e4rat + systemd = No DM [SOLVED]

On recent update this seems to be fixed.
Marking  as Solved

Offline

Board footer

Powered by FluxBB