You are not logged in.

#1 2012-09-25 09:54:06

madjo
Member
Registered: 2012-09-25
Posts: 4

[Solved] pacstrap fails on invalid signature for glibc

I'm trying a fresh install of Arch, but while following the beginner's guide, I encounter an issue when running `pacstrap /mnt base base-devel`.

When it has downloaded all packages and it finishes checking package integrity, I keep getting this:

error: glibc: signature from "Allan McRae <..>" is invalid

I have already tried `pacman-key --init` and `pacman-key --populate archlinux`. But that doesn't solve the issue.

I have also tried a different mirror, but that too didn't solve the issue.

What am I doing wrong? And how can I solve this problem.


*EDIT* Solved, I found out that pacstrap stored the database on /mnt/var/, by removing it and redownloading the packages, it solved my issue.

Last edited by madjo (2012-09-25 10:18:28)

Offline

#2 2012-09-25 11:45:34

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,731

Re: [Solved] pacstrap fails on invalid signature for glibc

For future reference, you don't have to delete the whole cache, just the package that is corrupt. (in /mnt/var/cache/pacman/pkg/)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

Board footer

Powered by FluxBB