You are not logged in.

#1 2012-09-28 08:38:34

rg_arc
Member
From: Hattiesburg
Registered: 2011-03-20
Posts: 497
Website

Opera font issue: Default font will not change [SOLVED]

I noticed that every page I visit from Opera except this archlinux website has this horrible monospaced font displayed. I went to the font settings in Opera and switched defaults to sans serif fonts but still this monospaced font is everywhere.

I checked author mode and user mode and each mode displays the same font. Firefox and Chromium don't have this problem, however, I did notice that when I play a youtube video or use something with flash player the font inside the video frame is the exact same font as Opera's font.

Here is a screenshot: http://imageshack.us/photo/my-images/155/operafont.png/

Has anyone else experienced this problem? I had Opera before on a different install of Arch Linux and I never had this much trouble with fonts.

Last edited by rg_arc (2012-09-29 19:31:40)

Offline

#2 2012-09-29 02:51:21

rg_arc
Member
From: Hattiesburg
Registered: 2011-03-20
Posts: 497
Website

Re: Opera font issue: Default font will not change [SOLVED]

Would this have anything to do with the new fontconfig update?

Offline

#3 2012-09-29 03:22:05

bwat47
Member
Registered: 2009-10-07
Posts: 638

Re: Opera font issue: Default font will not change [SOLVED]

No problems here: http://i.imgur.com/0xJSv.png

Try going into opera:config, and checking "prefer fontconfig settings" That should make opera respect your fontconfig settings directly as opposed to using DE and/or xft settings.

Last edited by bwat47 (2012-09-29 03:23:37)

Offline

#4 2012-09-29 03:39:10

rg_arc
Member
From: Hattiesburg
Registered: 2011-03-20
Posts: 497
Website

Re: Opera font issue: Default font will not change [SOLVED]

yeah that certainly didn't change anything. I see that the font has better rendering... but the font style didn't change a bit.

Offline

#5 2012-09-29 06:35:17

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Opera font issue: Default font will not change [SOLVED]

Perhaps you do not have the necessary fonts installed.  I have good looking fonts here using Opera 12.02.

FTR, here are the fonts I have installed:

# pacman -Ss font | grep installed
extra/fluidsynth 1.1.6-1 [installed]
extra/fontconfig 2.10.1-2 [installed]
extra/fontsproto 2.1.2-1 [installed]
extra/gsfonts 1.0.7pre44-3 [installed]
extra/libfontenc 1.1.1-1 [installed]
extra/libxfont 1.4.5-1 [installed]
extra/ttf-bitstream-vera 1.10-8 [installed]
extra/ttf-dejavu 2.33-3 [installed]
extra/ttf-freefont 20120503-1 [installed]
extra/xorg-bdftopcf 1.0.3-2 (xorg xorg-apps) [installed]
extra/xorg-font-util 1.3.0-1 (xorg-fonts xorg) [installed]
extra/xorg-font-utils 7.6-3 [installed]
extra/xorg-fonts-100dpi 1.0.1-4 (xorg) [installed]
extra/xorg-fonts-75dpi 1.0.1-4 (xorg) [installed]
extra/xorg-fonts-alias 1.0.2-2 [installed]
extra/xorg-fonts-encodings 1.0.4-3 (xorg-fonts xorg) [installed]
extra/xorg-fonts-misc 1.0.1-2 [installed]
extra/xorg-fonts-type1 7.4-2 [installed]
extra/xorg-mkfontdir 1.0.7-1 (xorg xorg-apps) [installed]
extra/xorg-mkfontscale 1.1.0-1 (xorg-apps xorg) [installed]
extra/xorg-xfontsel 1.0.4-1 [installed]
community/ttf-liberation 2.00.0-1 [installed]
multilib/lib32-fontconfig 2.10.1-1 [installed]
multilib/lib32-libxft 2.3.1-1 [installed]

I am using the Bitstream Vera fonts in Opera, along with the infinality patches.
http://www.infinality.net/blog/infinali … e-patches/

In
opera:config#UserPrefs [paste in address bar and press enter]
I have "Draw Anti-Aliased Fonts" checked, and "Enable Webfonts" checked.

Offline

#6 2012-09-29 08:03:09

rg_arc
Member
From: Hattiesburg
Registered: 2011-03-20
Posts: 497
Website

Re: Opera font issue: Default font will not change [SOLVED]

I have those already checked as well in my preferences... and also I have most of those fonts already installed as well. I get this output when I update my font cache:

$ fc-cache -vf
Fontconfig warning: "/etc/fonts/infinality/conf.d/60-group-non-tt-fonts.conf", line 483: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/60-group-tt-fonts.conf", line 262: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/62-tt-monospace-rendering.conf", line 27: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/62-tt-traced-bitmap-rendering.conf", line 21: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/62-tt-traced-bitmap-rendering.conf", line 50: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/80-selective-rendering-inf-win-lin.conf", line 16: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/80-selective-rendering-inf-win-lin.conf", line 31: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/80-selective-rendering-inf-win-lin.conf", line 102: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/80-selective-rendering-inf-win-lin.conf", line 119: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/80-selective-rendering-inf-win-lin.conf", line 138: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/infinality/conf.d/80-selective-rendering-inf-win-lin.conf", line 158: Having multiple values in <test> isn't supported and may not works as expected
/usr/share/fonts: caching, new cache contents: 0 fonts, 10 dirs
/usr/share/fonts/100dpi: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/75dpi: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/TTF: caching, new cache contents: 80 fonts, 0 dirs
/usr/share/fonts/Type1: caching, new cache contents: 35 fonts, 0 dirs
/usr/share/fonts/cyrillic: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/local: caching, new cache contents: 36 fonts, 0 dirs
/usr/share/fonts/misc: caching, new cache contents: 59 fonts, 0 dirs
/usr/share/fonts/speedo: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/util: caching, new cache contents: 0 fonts, 0 dirs
/home/ricky/.local/share/fonts: skipping, no such directory
/home/ricky/.fonts: skipping, no such directory
/var/cache/fontconfig: not cleaning unwritable cache directory
/home/ricky/.cache/fontconfig: cleaning cache directory
/home/ricky/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
$

I wonder if that might have something to do with my Opera problems? I remember having to delete all those files recently according to the arch linux news before updating the system.. and after I did that I keep getting outputs similar to this.

Offline

#7 2012-09-29 08:22:16

w0ng
Member
From: Australia
Registered: 2009-06-04
Posts: 88
Website

Re: Opera font issue: Default font will not change [SOLVED]

Those infinality warnings are a known issue and nothing to worry about.

As a temporary workaround, replace those files with these to suppress the warnings:

https://gist.github.com/3802778
https://gist.github.com/3802779
https://gist.github.com/3802780
https://gist.github.com/3802782
https://gist.github.com/3802783

Offline

#8 2012-09-29 08:35:33

rg_arc
Member
From: Hattiesburg
Registered: 2011-03-20
Posts: 497
Website

Re: Opera font issue: Default font will not change [SOLVED]

ah ok cool... also, will this help with Opera's config? I noticed that its sort of system wide depending on the application. Mostly, everything uses a sans serif font I picked out but every now and then I see that monospaced font pop up. Namely in Libreoffice Writer in the menus. I am using 96 dpi setting. I did play around with the dpi once and set it to 101 or something like that and had it set to custom. I put it back to automatic 96 dpi.

I honestly don't know what all of this has to do with Opera, but, I feel Opera is an indication of something else going on in the system I am not aware of... and I would love to get to the bottom of it.

rgedit: Also, I will try to see if this will help me out a bit http://my.opera.com/community/forums/to … id=1519202

I will leave that there as a reference for anyone looking for some explainations to the problem. I don't know if I should sym link that or not though.

edit#2:

$ fc-match Arial
FreeMono.ttf: "FreeMono" "нормален"

I guess that may be what is going on.

Last edited by rg_arc (2012-09-29 08:44:46)

Offline

#9 2012-09-29 10:32:14

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Opera font issue: Default font will not change [SOLVED]

rg_arc wrote:

edit#2:

$ fc-match Arial
FreeMono.ttf: "FreeMono" "нормален"

I guess that may be what is going on.

Yeah, got something going on up there.

$ fc-match Arial
arial.ttf: "Arial" "Normal"

EDIT:  I forgot, I had also installed the Windows 7 fonts since I also have Windows 7 on this laptop.
https://wiki.archlinux.org/index.php/MS_Fonts

EDIT 2:  I see there is a more verbose version of the command that you may find useful.

$ fc-match -v "Arial" | egrep 'family|hint'
	family: "Arial"(s)
	familylang: "en"(s)
	hintstyle: 3(i)(s)
	hinting: FcTrue(s)
	autohint: FcFalse(s)

Last edited by David Batson (2012-09-29 10:59:41)

Offline

#10 2012-09-29 19:01:11

rg_arc
Member
From: Hattiesburg
Registered: 2011-03-20
Posts: 497
Website

Re: Opera font issue: Default font will not change [SOLVED]

$ fc-match -v "Arial" | egrep 'family|hint'
	family: "FreeMono"(s)
	familylang: "en"(s)
	hintstyle: 3(i)(w)
	hinting: FcTrue(w)
	autohint: FcTrue(w)
	force_autohint: FcFalse(w)

This is my output... I see there is alot more going on here than I expected.. I am not sure what is the best option honestly.

Offline

#11 2012-09-29 19:28:03

rg_arc
Member
From: Hattiesburg
Registered: 2011-03-20
Posts: 497
Website

Re: Opera font issue: Default font will not change [SOLVED]

$ fc-match -v "Arial" | egrep 'family|hint'
	family: "Liberation Sans"(s)
	familylang: "en"(s)
	hintstyle: 3(i)(w)
	hinting: FcTrue(w)
	autohint: FcFalse(w)
	force_autohint: FcFalse(w)

This is my new output after creating a symbolic link accordingly.

[conf.d]$ sudo ln -s /etc/fonts/conf.avail/30-metric-aliases.conf

I am not sure whether this will cause other problems.. but so far Opera fonts look much better than before thanks to this fix.

Last edited by rg_arc (2012-09-29 19:31:05)

Offline

Board footer

Powered by FluxBB