I am in need to install the ruby-msgpack from AUR https://aur.archlinux.org/packages.php?ID=58013
But it requires ruby v1.8.
Do I need to downgrade ruby from version 1.9.3p194 from the repo, if so how?
Or is there a way I can modify the PKGBUILD file for the purpose?
Last edited by odp (2012-09-29 15:29:42)
Ok, I left the AUR package ruby-msgpack alone and downloaded source.
Compiled and added ~/.gem/ruby/1.9.1/bin to PATH and installed.
Ran the included test scripts and Ok'ed the install.
From other AUR packages that depended on ruby-msgpack I removed it as a dependency in the PKGBUILD file.
Last edited by odp (2012-09-29 15:30:03)