You are not logged in.

#1 2012-09-30 17:02:32

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

[SOLVED] Attempting to build conky-lua

Trying to get conky-1.9.0 to work with lua, got all the flags set so it does, but anytime I attempt to run make on it, It constantly gives me this error.

Making all in src
make[1]: Entering directory `/home/multimoon/Documents/conky-1.9.0/src'
make  all-am
make[2]: Entering directory `/home/multimoon/Documents/conky-1.9.0/src'
make[2]: Leaving directory `/home/multimoon/Documents/conky-1.9.0/src'
make[1]: Leaving directory `/home/multimoon/Documents/conky-1.9.0/src'
Making all in doc
make[1]: Entering directory `/home/multimoon/Documents/conky-1.9.0/doc'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/multimoon/Documents/conky-1.9.0/doc'
Making all in lua
make[1]: Entering directory `/home/multimoon/Documents/conky-1.9.0/lua'
Makefile:678: *** missing separator.  Stop.
make[1]: Leaving directory `/home/multimoon/Documents/conky-1.9.0/lua'
make: *** [all-recursive] Error 1

I'm decent with linux, rather new to Archlinux, so If anyone can give me a hand, I would appreciate it.

Last edited by Multimoon (2012-10-13 02:38:51)


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#2 2012-10-09 14:43:49

rtoijala
Member
Registered: 2011-09-11
Posts: 31

Re: [SOLVED] Attempting to build conky-lua

Are you using the AUR package? http://aur.archlinux.org/packages.php?ID=31589
I just built the package and it works.

Offline

#3 2012-10-09 20:37:39

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: [SOLVED] Attempting to build conky-lua

Did not make a difference, but after a bit of googling I found a missing package that the PKGBUILD did not include for. My problem still though is I'm getting "Conky: llua_do_call: function conky_main execution failed: attempt to call a nil value" when I try to run my conky config. Default, unconfigured conky DOES work, I'm trying to use Conky Orange (http://gnome-look.org/content/show.php?content=137503)

-Edit:
Ran it in debug mode, got the following information, I did install cairo, and I upgraded both to check.
        no field package.preload['cairo']
        no file './cairo.lua'
        no file '/usr/share/lua/5.1/cairo.lua'
        no file '/usr/share/lua/5.1/cairo/init.lua'
        no file '/usr/lib/lua/5.1/cairo.lua'
        no file '/usr/lib/lua/5.1/cairo/init.lua'
        no file '/usr/local/lib/conky/libcairo.so'
        no file './cairo.so'
        no file '/usr/lib/lua/5.1/cairo.so'
        no file '/usr/lib/lua/5.1/loadall.so'

Last edited by Multimoon (2012-10-09 20:41:50)


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#4 2012-10-10 15:19:48

rtoijala
Member
Registered: 2011-09-11
Posts: 31

Re: [SOLVED] Attempting to build conky-lua

Did not make a difference, but after a bit of googling I found a missing package that the PKGBUILD did not include for.

I am having difficulty understanding this. What do you mean by "that the PKGBUILD did not include for"?

I downloaded and tried Conky Orange. I had no problems running it.
Could you paste the PKGBUILD you are using for conky? Is it conky-lua from the AUR?

Can you make sure you have cairo installed? pacman -Qs cairo

Offline

#5 2012-10-10 20:39:18

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: [SOLVED] Attempting to build conky-lua

Yes I have Cairo installed. I am now using the official AUR package, and I have it installed, but I'm still getting the above errors when attempting to run conky_orange.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#6 2012-10-11 13:38:54

rtoijala
Member
Registered: 2011-09-11
Posts: 31

Re: [SOLVED] Attempting to build conky-lua

When I run the Conky Orange, conky tries to find the following files:

./cairo.lua
/usr/share/lua/5.1/cairo.lua
/usr/share/lua/5.1/cairo/init.lua
/usr/lib/lua/5.1/cairo.lua
/usr/lib/lua/5.1/cairo/init.lua
/usr/lib/conky/libcairo.so

It finds the last one.

However, you post that it tries /usr/local/lib/conky/libcairo.so.

Could you please paste in the output from the following commands:

# pacman -Ql conky-lua
# find /usr -name libcairo.so

Offline

#7 2012-10-11 20:18:33

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: [SOLVED] Attempting to build conky-lua

Output for pacman -Ql conky-lua:

   conky-lua /etc/conky/conky.conf
   conky-lua /etc/conky/conky_no_x11.conf
   conky-lua /usr/
   conky-lua /usr/bin/
   conky-lua /usr/bin/conky
   conky-lua /usr/lib/
   conky-lua /usr/lib/conky/
   conky-lua /usr/lib/conky/libcairo.a
   conky-lua /usr/lib/conky/libcairo.la
   conky-lua /usr/lib/conky/libcairo.so
   conky-lua /usr/lib/conky/libcairo.so.0
   conky-lua /usr/lib/conky/libcairo.so.0.0.0
   conky-lua /usr/lib/conky/libimlib2.a
   conky-lua /usr/lib/conky/libimlib2.la
   conky-lua /usr/lib/conky/libimlib2.so
   conky-lua /usr/lib/conky/libimlib2.so.0
   conky-lua /usr/lib/conky/libimlib2.so.0.0.0
   conky-lua /usr/share/
   conky-lua /usr/share/licenses/
   conky-lua /usr/share/licenses/conky/
   conky-lua /usr/share/licenses/conky/LICENSE
   conky-lua /usr/share/man/
   conky-lua /usr/share/man/man1/
   conky-lua /usr/share/man/man1/conky.1.gz
   conky-lua /usr/share/vim/
   conky-lua /usr/share/vim/vimfiles/
   conky-lua /usr/share/vim/vimfiles/ftdetect/
   conky-lua /usr/share/vim/vimfiles/ftdetect/conkyrc.vim
   conky-lua /usr/share/vim/vimfiles/syntax/
   conky-lua /usr/share/vim/vimfiles/syntax/conkyrc.vim

Then for find:

/usr/lib/libcairo.so
/usr/lib/conky/libcairo.so

Last edited by Multimoon (2012-10-11 20:19:04)


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#8 2012-10-12 14:11:42

rtoijala
Member
Registered: 2011-09-11
Posts: 31

Re: [SOLVED] Attempting to build conky-lua

I am running out of ideas.
As a sanity check, can you paste the output of

conky -v

The libcairo.so file is there, but on your system, conky is looking in /usr/local instead of /usr.
The only thing I can think of is that you rebuild and reinstall the package, using the PKGBUILD exactly as it is.
That means either

yaourt -S conky-lua

or downloading the PKGBUILD from https://aur.archlinux.org/packages/co/c … a/PKGBUILD and using makepkg.

Offline

#9 2012-10-12 21:27:37

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: [SOLVED] Attempting to build conky-lua

All the lua bindings are enabled. I tried yaourt, no difference. I'm going to reinstall Arch this weekend anyway to fully get rid of KDE and switch to pure openbox, so I'll post if it's working then or not.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#10 2012-10-12 21:28:24

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Attempting to build conky-lua

I don't know why you need to reinstall the whole system to rid yourself of kde.

Offline

#11 2012-10-12 21:38:58

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: [SOLVED] Attempting to build conky-lua

Not just KDE, I want to start with a fresh system again. Plus I need the practice.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#12 2012-10-13 02:35:23

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: [SOLVED] Attempting to build conky-lua

Well, after reinstalling and getting OpenBox to the form I like it in, Conky-lua is working perfectly, I must have just had a bug. Thanks for your help though.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

Board footer

Powered by FluxBB