You are not logged in.

#1 2012-09-30 20:43:17

Nathorr
Member
Registered: 2012-09-30
Posts: 1

Text in terminal looks weird after first reboot

Hi, Arch Linux newbie here!

I just managed to install Arch Linux for the first time. I followed the Beginner's Guide and everything went well until the first reboot. After Grub, my screen looks like this:

http://i.imgur.com/S8cdP.jpg
http://i.imgur.com/hCWyE.jpg

Did I do something wrong or what? I'm trying to install it to the old celeron 1,2GHz -based PC with integrated graphic card, using VGA cable.

I haven't tried to reinstall yet.

Thank you!

E: Replaced Dropbox-links with imgur.

Last edited by Nathorr (2012-10-01 07:35:59)

Offline

#2 2012-09-30 21:02:49

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Text in terminal looks weird after first reboot

Hi, and welcome to the forum.

First of all, please don't use your Dropbox account to post pictures. These will probably stay up less than if you used an image hosting site (ompldr.org, imgur.com, etc), and the next person that searches for this information won't have a clear comparison, because those links are gone once you delete them from your computer (i.e. from the Dropbox folder).

Second, there's no need to reinstall. Try disabling the KMS (kernel mode setting): https://wiki.archlinux.org/index.php/KM … odesetting


And don't forget to mark it as solved (by editing the first post), so that other people (including yourself sometimes) may find useful.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-09-30 21:29:33

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,059
Website

Re: Text in terminal looks weird after first reboot

If you install again the same way, do you think there will be a difference to your first result? Also post some more info about your system, start with the output of   $ lspci | grep VGA .

Last edited by teateawhy (2012-09-30 21:29:50)

Offline

#4 2012-10-01 07:02:19

hunterthomson
Member
Registered: 2008-06-22
Posts: 794
Website

Re: Text in terminal looks weird after first reboot

Hum, that dose look strange.

It seems that you need to boot back into the Live CD or USB. Then arch-chroot back into the system.
https://wiki.archlinux.org/index.php/Be … ase_system

Then I'd install the "terminus-font" font.
After that make sure you have the "Locale" set correctly
Then to set the virtual console font to use the newly installed terminus fonts. I have this set:
/etc/vconsole.conf

KEYMAP=us
FONT=ter-v12n
FONT_MAP=

You cat check out what is in here to see the avalable fonts:

ls /usr/share/kbd/consolefonts/

And can use the "setfont" command to try them out first. Like so:

setfont ter-v12n

Also, for my Intel HD4000 graphics I had to add the i915 video driver module to the MODULES= in /etc/mkinitcpio.conf then recreate the inital ramdisk to get the font to load at boot with systemd.
https://wiki.archlinux.org/index.php/Be … nvironment

Owe, and stick with it. It can be a kind of sharp learning curve, but it is well worth it, and after a month with Arch you will love it wink

Last edited by hunterthomson (2012-10-01 07:21:39)


OpenBSD-current Thinkpad X230, i7-3520M, 16GB CL9 Kingston, Samsung 830 256GB
Contributor: linux-grsec

Offline

Board footer

Powered by FluxBB