You are not logged in.

#1 2012-09-30 22:36:24

ngrammel
Member
Registered: 2012-09-30
Posts: 2

[Solved] WiFi issues

Hey folks, I've run into a little issue; any help is greatly appreciated. I am connecting to a university wifi, and I managed to connect when booted into the CD. Once I installed and chrooted into the new installation, I was unable to connect. I installed netcfg as per the wiki Beginner's Guide, and used the same config file. However when I run netcfg to connect, I get an error: "WPA Authentication/Association Failed"
The network is WPA2 Enterprise; and I used wpa-configsection. Everything works fine when I'm not in "arch-chroot /mnt". I've also tried using wifi-menu: it detects the handmade file, but throws the same error. An auto-generated file does not work.

Again, any help is greatly appreciated.

Last edited by ngrammel (2012-10-06 20:38:20)

Offline

#2 2012-09-30 22:52:33

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] WiFi issues

Why are you trying to set up the network before rebooting?  If you have the network working from the live media, arch-chroot should automagically copy /etc/resolv.conf to /mnt/etc/resolv.conf for you so that you nave network connectivity when you actually enter the chroot.  Did you not even try to use the network/internet after you chroot-ed?

Think of it this way, you have a computer with one wifi card, right?  So why the hell would you think that you could effectively connect to the same access point (router) twice from the same piece of wardware?  That just doesn't make a lick of sense in my head...

Offline

#3 2012-10-01 00:33:05

ngrammel
Member
Registered: 2012-09-30
Posts: 2

Re: [Solved] WiFi issues

I'm sorry, it does seem rather silly now. I was following the guide, which seemed to suggest that the network was to be configured while still in chroot. I could have sworn I was getting an unknown host from ping after chrooting, but I must have been delusional because it seems to be working now. Thanks for straightening that out for me, and sorry for the trouble.

Offline

#4 2012-10-01 00:45:56

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] WiFi issues

Glad you got it sorted out.  Don't forget to be a good community member and mark your post as solved.  (This can be done by using the "edit" button in your fist post and appending [Solved] to your title.)

Offline

Board footer

Powered by FluxBB