You are not logged in.

#1 2012-10-01 12:54:21

From: Denmark
Registered: 2009-11-04
Posts: 62

[SOLVED sorta] Can't find device file for built-in microphone

I have a Lenovo ThinkPad X200 with a built-in webcam and microphone. I want to be able to record video and sound using mencoder and other commandline applications. Therefore I (think that I) need to know my microphone's device file.

The problem is that none of the usual device files are there (no /dev/dsp*, no /dev/audio*, no /dev/mix* -- and according to 'find' no similarly named files in the subdirs either) The microphone is there and working as evidenced by PulseAudio settings apps and a test I just did using the Gnome application Sound Recorder. PulseAudio refers to the input/output devices as "Built-in Audio Analog Stereo" but doesn't give up anything like device files.

Any suggestions?

EDIT: Using VLC to access the devices seems to reveal that Pulseaudio has thrown out the idea of using files to represent hardware. While the webcam has a file (/dev/video0 or something like that) the microphone is refered to as "hw0:0". I still don't know how I would direct mencoder to use "hw0:0" but VLC represents good enough alternative for my needs.

Last edited by madchine (2012-10-12 21:23:45)


#2 2012-10-01 13:30:12

Registered: 2007-04-03
Posts: 3,645

Re: [SOLVED sorta] Can't find device file for built-in microphone

Look in /dev/snd/ (for ALSA, anyway).

But one does not record directly from those "files". Use an app, e.g.:

arecord -vv -d 4 /tmp/test-mic.wav && aplay /tmp/test-mic.wav


Board footer

Powered by FluxBB