You are not logged in.

#1 2012-10-01 17:11:57

tladuke
Member
Registered: 2009-07-23
Posts: 171

Can't connect to MPD anymore [~solved]

I haven't used it in a week or two. I changed over to systemd in that time. Not sure what that would have to do with it.

ncmpcpp (on same machine as mpd) segfaults after showing a blank screen for a while. Theremin on a remote machine can't connect. mpc seems to work. But it takes like 30 seconds to do anything.


i run mpd as a user. mpd still starts fine, but i get a lot of avahi stuff after

% mpd --no-daemon --stdout -v
config: loading file /tank/conf/.mpdconf
path: path_set_fs_charset: fs charset is: UTF-8
pcm: libsamplerate converter 'Fastest Sinc Interpolator'
database: reading DB
output: No "audio_output" defined in config file
output: Attempt to detect audio output device
output: Attempting to detect a alsa audio device
output: Successfully detected a alsa audio device
disabling the last.fm playlist plugin because account is not configured
disabling the soundcloud playlist plugin because API key is not set
daemon: opening pid file
daemon: writing pid file
avahi: Initializing interface
avahi: Client changed to state 101
avahi: Client is CONNECTING
state_file: Loading state file /tank/conf/mpd/state
avahi: Client changed to state 100
avahi: Client Disconnected, will reconnect shortly
avahi: Client changed to state 101
avahi: Client is CONNECTING
avahi: Client changed to state 100
avahi: Client Disconnected, will reconnect shortly
avahi: Client changed to state 101
avahi: Client is CONNECTING
avahi: Client changed to state 100
avahi: Client Disconnected, will reconnect shortly
...

then when i open ncmpcpp

vahi: Client changed to state 101
avahi: Client is CONNECTING
client: [0] opened from 127.0.0.1:41430
avahi: Client changed to state 100
avahi: Client Disconnected, will reconnect shortly
avahi: Client changed to state 101
avahi: Client is CONNECTING
client: [1] opened from 127.0.0.1:41431
client: [0] process command "status"
client: [0] command returned 0
client: [0] expired
client: [0] closed
client: [1] process command "status"
client: [1] command returned 0
client: [1] process command "idle"
client: [1] command returned 1
avahi: Client changed to state 100
avahi: Client Disconnected, will reconnect shortly
avahi: Client changed to state 101
avahi: Client is CONNECTING
avahi: Client changed to state 100
avahi: Client Disconnected, will reconnect shortly
avahi: Client changed to state 101
avahi: Client is CONNECTING
client: [1] process command "plchanges "0""
client: [1] command returned 0
client: [1] expired
client: [1] closed
avahi: Client changed to state 100
avahi: Client Disconnected, will reconnect shortly

[1]    15057 segmentation fault (core dumped)  ncmpcpp


Been reading the forums and other google hits;
Before I started having problems, I didn't put bind_to_address in my mpd conf.
I tried
bind_to_address "192.168.82.82"
bind_to_address "127.0.0.1"

tried commenting out the ipv6 line in /etc/hosts

tried downgrading mpd but it didn't help. Must be something with my system?

Last edited by tladuke (2012-10-01 18:17:28)

Offline

#2 2012-10-01 18:17:05

tladuke
Member
Registered: 2009-07-23
Posts: 171

Re: Can't connect to MPD anymore [~solved]

zeroconf_enabled                "no"

fixed it. i don't know what's wrong with avahi, but oh well.

edit:
the real problem was /var/run and /var/lock had never been converted to symlinks, like the arch news said to do months ago.

Last edited by tladuke (2012-10-05 22:17:46)

Offline

Board footer

Powered by FluxBB