You are not logged in.

#1 2012-10-03 00:13:11

darthpenguin
Member
Registered: 2011-09-16
Posts: 80

[SOLVED]Can't print to my Brother DCP-7065dn after upgrade to systemd.

Hi All,

I have a pure systemd installation and I'm having issues printing. I have a Brother DCP-7065dn which works well on my Ubuntu laptop with the drivers availible from Brother. I downloaded and installed the drivers for this printer from the AUR and added the printer to cups (both lpd and usb). When I print a test page cups reports that the job completed succesfully but the printer does not print. Not sure what is wrong. Has anyone else had printing issues after upgrading to systemd? Any thought on how I can get this printer working?

Thanks

Edit: BTW. Brother offers deb and rpm packages for their Linux drivers. I installed the deb packages on an Ubuntu machine and I can print over the network (lpd) with no problems. I also installed the brother on may arch system using the wrong drivers just to see what would happen. Using the DCP-7045N Foomatic/Postscript driver I can communicate with the printer (progress) but printing a test page results in the printer spitting out a lot of blank pages. I can also print to an HP from my arch laptop with no problems. So the issue seems to be with the drivers for the Brother DCP-7065dn from the AUR. Not sure how I'm going to fix this. I can't install the rpm or deb packages on my machine. and I don't want to switch to a red-hat or debian system if I can avoid it.

Final Edit: SOLVED! I need to learn to go back and read comments. In the AUR there was a comment regurding this exact issue. I needed to enable multilib repository and install lib32-glibc. Now it works. \(^_^)/

Last edited by darthpenguin (2012-10-04 08:41:29)

Offline

Board footer

Powered by FluxBB