You are not logged in.

#1 2012-10-04 07:18:31

gauthma
Member
Registered: 2010-02-16
Posts: 186
Website

Version conflict on update of Haskell packages

Hello all,

Like the subject says, when updating, I got this:

warning: haskell-http: local (4000.2.5-1) is newer than testing (4000.2.4-1)
warning: haskell-parsec: local (3.1.3-3) is newer than testing (3.1.3-1)
warning: haskell-random: local (1.0.1.1-7) is newer than testing (1.0.1.1-3)
warning: haskell-zlib: local (0.5.4.0-1) is newer than testing (0.5.3.3-5)
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-base64-bytestring: requires ghc=7.4.2-1
:: haskell-blaze-builder: requires ghc=7.4.2-1
:: haskell-blaze-html: requires ghc=7.4.2-1
:: haskell-blaze-markup: requires ghc=7.4.2-1
:: haskell-citeproc-hs: requires ghc=7.4.2-1
:: haskell-digest: requires ghc=7.4.2-1
:: haskell-highlighting-kate: requires ghc=7.4.2-1
:: haskell-http: requires ghc=7.4.2-1
:: haskell-json: requires ghc=7.4.2-1
:: haskell-mtl: requires ghc=7.4.2-1
:: haskell-network: requires ghc=7.4.2-1
:: haskell-pandoc: requires ghc=7.4.2-1
:: haskell-pandoc-types: requires ghc=7.4.2-1
:: haskell-parsec: requires ghc=7.4.2-1
:: haskell-random: requires ghc=7.4.2-1
:: haskell-regex-base: requires ghc=7.4.2-1
:: haskell-regex-pcre-builtin: requires ghc=7.4.2-1
:: haskell-syb: requires ghc=7.4.2-1
:: haskell-tagsoup: requires ghc=7.4.2-1
:: haskell-temporary: requires ghc=7.4.2-1
:: haskell-texmath: requires ghc=7.4.2-1
:: haskell-text: requires ghc=7.4.2-1
:: haskell-transformers: requires ghc=7.4.2-1
:: haskell-utf8-string: requires ghc=7.4.2-1
:: haskell-xml: requires ghc=7.4.2-1
:: haskell-zip-archive: requires ghc=7.4.2-1
:: haskell-zlib: requires ghc=7.4.2-1

I was (and am) using the [haskell] repo, but not the [haskell-extra] one. I added it, and tried to update, but it made no difference. To make matters even weirder, the error messages are about needing version 7.4.2-1 of ghc, but that IS the version I have installed!

# pacman -Qi ghc
Name           : ghc
Version        : 7.4.2-1
URL            : http://www.haskell.org/ghc/
Licenses       : custom
Groups         : None
Provides       : haskell-array=0.4.0.0  haskell-base=4.5.1.0  haskell-binary=0.5.1.0  haskell-bin-package-db=0.0.0.0
                 haskell-bytestring=0.9.2.1  haskell-containers=0.4.2.1  haskell-deepseq=1.3.0.0
                 haskell-directory=1.1.0.2  haskell-extensible-exceptions=0.1.1.4  haskell-filepath=1.3.0.0
                 haskell-ghc-prim=0.2.0.0  haskell-haskell2010=1.1.0.1  haskell-haskell98=2.0.0.1  haskell-hoopl=3.8.7.3
                 haskell-hpc=0.5.1.1  haskell-integer-gmp=0.4.0.0  haskell-old-locale=1.0.0.4  haskell-old-time=1.1.0.0
                 haskell-pretty=1.1.1.0  haskell-process=1.1.0.1  haskell-template-haskell=2.7.0.0  haskell-time=1.4
                 haskell-unix=2.5.1.1  haskell-cabal=1.14.0
Depends On     : perl  gmp>=5.0  gcc
Optional Deps  : None
Required By    : haskell-base64-bytestring  haskell-blaze-builder  haskell-blaze-html  haskell-blaze-markup
                 haskell-citeproc-hs  haskell-digest  haskell-highlighting-kate  haskell-http  haskell-json  haskell-mtl
                 haskell-network  haskell-pandoc  haskell-pandoc-types  haskell-parsec  haskell-random  haskell-regex-base
                 haskell-regex-pcre-builtin  haskell-syb  haskell-tagsoup  haskell-temporary  haskell-texmath
                 haskell-text  haskell-transformers  haskell-utf8-string  haskell-xml  haskell-zip-archive  haskell-zlib
Conflicts With : None
Replaces       : haskell-array<0.4.0.0  haskell-base<4.5.1.0  haskell-binary<0.5.1.0  haskell-bin-package-db<0.0.0.0
                 haskell-bytestring<0.9.2.1  haskell-containers<0.4.2.1  haskell-deepseq<1.3.0.0
                 haskell-directory<1.1.0.2  haskell-extensible-exceptions<0.1.1.4  haskell-filepath<1.3.0.0
                 haskell-ghc-prim<0.2.0.0  haskell-haskell2010<1.1.0.1  haskell-haskell98<2.0.0.1  haskell-hoopl<3.8.7.3
                 haskell-hpc<0.5.1.1  haskell-integer-gmp<0.4.0.0  haskell-old-locale<1.0.0.4  haskell-old-time<1.1.0.0
                 haskell-pretty<1.1.1.0  haskell-process<1.1.0.1  haskell-template-haskell<2.7.0.0  haskell-time<1.4
                 haskell-unix<2.5.1.1  haskell-cabal<1.14.0
Installed Size : 748172.00 KiB
Packager       : Thomas Dziedzic <gostrc@gmail.com>
Architecture   : x86_64
Build Date     : Mon 11 Jun 2012 12:48:50 AM WEST
Install Date   : Tue 28 Aug 2012 03:24:17 PM WEST
Install Reason : Installed as a dependency for another package
Install Script : Yes
Description    : The Glasgow Haskell Compiler

Btw, despite running testing, I don't need the [haskell-testing] repo enabled... right? (currently it is not so)

EDIT: adding [haskell-testing] did not solve the problem...

Last edited by gauthma (2012-10-04 14:09:29)

Offline

#2 2012-10-04 10:16:32

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: Version conflict on update of Haskell packages

Like any other library update, AUR packages require your attention.

Offline

#3 2012-10-04 10:49:31

Awebb
Member
Registered: 2010-05-06
Posts: 4,178

Re: Version conflict on update of Haskell packages

Is [haskell] an official arch repo?

Online

#4 2012-10-04 11:19:22

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: Version conflict on update of Haskell packages

Awebb wrote:

Is [haskell] an official arch repo?

No: https://wiki.archlinux.org/index.php/Un … positories

gauthma wrote:

To make matters even weirder, the error messages are about needing version 7.4.2-1 of ghc, but that IS the version I have installed!

That error says you can't update package foo, because it needs a specific version of package bar and you are about to update bar.
ghc got updated from version 7.4.2-1 in [extra] to 7.6.1-1 in [testing] and [haskell] still has version 7.4.2-1 at the moment.

Haskell packages in the official repos have just been updated, so wait a bit until your server gets them or switch to a more up-to-date one.
As you can see, the packages from [testing] depend on 7.6.1-1 http://www.archlinux.org/packages/testi … skell-mtl/


Edit: [haskell-testing] has the updated packages

Repository     : haskell-testing
Name           : haskell-base64-bytestring
...
Depends On     : ghc=7.6.1-1

Last edited by karol (2012-10-04 11:45:31)

Offline

#5 2012-10-04 13:05:06

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 6,816

Re: Version conflict on update of Haskell packages

karol wrote:
Awebb wrote:

Is [haskell] an official arch repo?

No: https://wiki.archlinux.org/index.php/Un … positories

Thanks karol.

Moving to AUR Issues, for want of a better place. OP, you may want to specify a better title.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#6 2012-10-04 14:12:24

gauthma
Member
Registered: 2010-02-16
Posts: 186
Website

Re: Version conflict on update of Haskell packages

So, from what I understand, given that haskell packages in the official repos have just been updated, I now have to wait until the packages in the unsupported arch-haskell repo get rebuilt, right? (or do that myself, locally)

EDIT: improved the title, thanks for the suggestion, ngoonee

Last edited by gauthma (2012-10-04 14:13:48)

Offline

#7 2012-10-04 14:36:16

Awebb
Member
Registered: 2010-05-06
Posts: 4,178

Re: Version conflict on update of Haskell packages

karol wrote:
Awebb wrote:

Is [haskell] an official arch repo?

No: https://wiki.archlinux.org/index.php/Un … positories

Thanks. Although it was meant as a homework-assignment for the OP ;-)

Online

#8 2012-10-04 14:37:20

gauthma
Member
Registered: 2010-02-16
Posts: 186
Website

Re: Version conflict on update of Haskell packages

Awebb wrote:
karol wrote:
Awebb wrote:

Is [haskell] an official arch repo?

No: https://wiki.archlinux.org/index.php/Un … positories

Thanks. Although it was meant as a homework-assignment for the OP ;-)

guilty as charged sad sorry about that.

Offline

Board footer

Powered by FluxBB