You are not logged in.

#1 2012-10-04 08:10:22

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

[SOLVED]how to autologin to all of the tty's using systemd

Hi Friends. I want to autologin to all the tty's (i.e. from 1 to 6) at my system startup .I want to do this cause I am the only user of  the system and also i dont use X server.I mainly use the  virtual consoles (i.e tty's from 1 to 6). I am running arch with systemd. The method given in the wiki is for one console only. Can someone explain me to do this for all the virtual console i.e. all the tty's ?  Many Thanks.

Last edited by Pranavg1890 (2012-10-04 09:37:01)


Using Openbox + Tint2 + Idesk

Offline

#2 2012-10-04 08:28:07

Šaran
Member
From: Bosnia
Registered: 2011-09-03
Posts: 407

Re: [SOLVED]how to autologin to all of the tty's using systemd

ln -sf /usr/lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@tty2.service

Repeat this for remaining vts - change @tty2 to @tty3 an so on.

Offline

#3 2012-10-04 09:09:55

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED]how to autologin to all of the tty's using systemd

@ Saran. It is not working. Do I need to do some steps after that? Also can you please tell me step by step procedure to enable autologin service for all the tty's . Thanks.

Last edited by Pranavg1890 (2012-10-04 09:11:24)


Using Openbox + Tint2 + Idesk

Offline

#4 2012-10-04 09:16:57

progandy
Member
Registered: 2012-05-17
Posts: 2,152

Re: [SOLVED]how to autologin to all of the tty's using systemd

First copy getty@.service to /etc/systemd/system/getty@.service. Add the autologin parameters, remove symlinks for tty2 and up and fix the symlink for tty1.
If you only want to log into specific ttys, read the wiki https://wiki.archlinux.org/index.php/Au … al_console

Last edited by progandy (2012-10-04 09:22:23)

Offline

#5 2012-10-04 09:32:27

Pranavg1890
Member
From: Nagpur,India
Registered: 2012-09-07
Posts: 111

Re: [SOLVED]how to autologin to all of the tty's using systemd

@progandy . After following sarans instructions, It worked for me after disabling the respective getty services and then adding all the getty services as alias in [Install] section of autologin@.service and enabling then respective autologin services. Many thanks. Friends. Now, I mark this thread as Solved.


Using Openbox + Tint2 + Idesk

Offline

Board footer

Powered by FluxBB