You are not logged in.

#1 2012-10-05 21:21:36

Registered: 2011-03-05
Posts: 67

[SOLVED] xf86-video-intel (sna) 2.20.9 crashes during xrandr operation

Hello All!

I noticed a kind of serious problem the other day: running

xrandr --output HDMI2 --rotate inverted

will cause a seg fault and crash X.  Here's the message that will be left in
your terminal:

0: /usr/bin/X (xorg_backtrace+0x36) [0x560366]
1: /usr/bin/X (0x400000+0x1640c9) [0x5640c9]
2: /usr/lib/ (0x7f545be2e000+0xf170) [0x7f545be3d170]
3: /usr/lib/xorg/modules/drivers/ (0x7f5458e05000+0xb5ff2) [0x7f5458ebaff2]
4: /usr/lib/xorg/modules/drivers/ (0x7f5458e05000+0xbc92c) [0x7f5458ec192c]
5: /usr/lib/xorg/modules/drivers/ (0x7f5458e05000+0x6b0d8) [0x7f5458e700d8]
6: /usr/lib/xorg/modules/drivers/ (0x7f5458e05000+0x5cb27) [0x7f5458e61b27]
7: /usr/bin/X (BlockHandler+0x4a) [0x4382da]
8: /usr/bin/X (WaitForSomething+0x114) [0x55d714]
9: /usr/bin/X (0x400000+0x34281) [0x434281]
10: /usr/bin/X (0x400000+0x23615) [0x423615]
11: /usr/lib/ (__libc_start_main+0xf5) [0x7f545acda725]
12: /usr/bin/X (0x400000+0x238ed) [0x4238ed]

Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

This happens to me on a lenovo X220T.  I also have a lenovo U350 (not sandy
bridge), and that works fine.  Can anyone else confirm this so I can get a bug
report started?

A few notes:
* Reverting to the 2.20.8 driver fixes the issue.
* It doesn't matter which screen I rotate, or if I have externals connected at
  all.  xrandr seems to always crash.
* My kernel is slightly outdated (3.4.9-1), due to some other X220T issues:


*EDIT*: searching a little harder discovers this bug:
Which I think is the same thing.  I'll try to help them out...

*EDIT2*: Sorry for all the noise!  I think this issue is resolved upstream:
I'll mark this as solved.

Last edited by wes (2012-10-05 21:44:45)


Board footer

Powered by FluxBB