You are not logged in.

#1 2012-10-07 06:18:25

thaldyron
Member
Registered: 2009-10-16
Posts: 9

[SOLVED] Can't upgrade due to libtool and libltdl

I'm trying to upgrade my system using

pacman -Syu --ignore glibc,curl

due to the "/lib exists on filesystem" errors according to the advice on the wiki. However, I'm still getting the following error:

error: failed to prepare transaction (could not satisfy dependencies)
:: libtool: requires libltdl=2.4

Any ideas how to resolve this?

(I've tried searching but only found problems related to libltdl and libtool-multilib, which have been fixed meanwhile.)

Last edited by thaldyron (2012-10-08 03:16:48)

Offline

#2 2012-10-07 07:15:25

Allan
is always right
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,463
Website

Re: [SOLVED] Can't upgrade due to libtool and libltdl

Those instructions probably do not work any more...   Try:

pacman -U http://pkgbuild.com/~allan/glibc-2.16.0-1-i686.pkg.tar.xz
pacman -Su --ignore glibc

Online

#3 2012-10-07 11:21:57

thaldyron
Member
Registered: 2009-10-16
Posts: 9

Re: [SOLVED] Can't upgrade due to libtool and libltdl

Allan wrote:

Those instructions probably do not work any more...   Try:

pacman -U http://pkgbuild.com/~allan/glibc-2.16.0-1-i686.pkg.tar.xz
pacman -Su --ignore glibc

That's what I did, but I still get the same error.

Offline

#4 2012-10-07 16:43:37

thaldyron
Member
Registered: 2009-10-16
Posts: 9

Re: [SOLVED] Can't upgrade due to libtool and libltdl

So I guess my only option is to reinstall from scratch, right?

Offline

#5 2012-10-08 03:16:33

thaldyron
Member
Registered: 2009-10-16
Posts: 9

Re: [SOLVED] Can't upgrade due to libtool and libltdl

Apparently I could fix it by installing tzdata first and then following up with the above commands.

Offline

Board footer

Powered by FluxBB