You are not logged in.

#1 2012-10-09 13:08:42

Cagnulein
Member
From: Modena, Italy
Registered: 2006-04-03
Posts: 258
Website

[SOLVED] Gdb shared libraries issue

Hi,
I'm working on ARM system with gdb 7.1 (i've tried 7.5 too). I'm using this tool to debug an application composed by several shared libraries.
If I debug this application on the ARM side, with gdb 7.1 i can see the shared loaded libraries (digiting "share"). Perfect!
I'm trying to do the same thing remotelly with gdb for arm on windows host and gdbserver on ARM.
So I have:
1) gdb on windows for arm v.7.4.1 (i've tried 7.3.1 too)
2) gdbserver on arm v.7.1 (i've tried 7.5 too)

On Windows I can debug everything flawless except for the shared libraries: infact, when i tried to digit "share" it says there isn't any shared loaded libraries. I'm absolutely sure that at least one library has loaded (on arm side the same situation works fine).

In gcc on arm, when i ask for shared loaded libraries ("share") it calls function solib.c:info_sharedlibrary_command with full support for solib. (and it works fine)
Instead, when i ask for the same command on gdb on windows and gdbserver on arm, it passes the command "qXfer:libraries:read:" that doesn't manage any solib, only dlls! And the dlls list is obviously empty.

Did i miss something?

Last edited by Cagnulein (2012-10-10 05:42:19)

Offline

#2 2012-10-10 05:42:08

Cagnulein
Member
From: Modena, Italy
Registered: 2006-04-03
Posts: 258
Website

Re: [SOLVED] Gdb shared libraries issue

Offline

Board footer

Powered by FluxBB