You are not logged in.

#1 2012-10-10 14:39:55

Takeo
Member
Registered: 2012-10-10
Posts: 3

[SOLVED] Unable to boot Archiso USB in UEFI mode

Hello Everyone ! big_smile

I'm trying to create an UEFI bootable USB from the latest ISO : 2012.10.06. I first tried following this section of the wiki : https://wiki.archlinux.org/index.php/Un … B_from_ISO with an usb key formatted as an EFI System (of type "ef00" in gdisk) and with a FAT32 partition on it.

All steps went right but when i try to boot with this key from the EFI menu, i get an infinite black screen and the usb key led isn't blinking so i suppose it's not loading.
I have refind already installed on my system. When i try booting the key from refind, I get the same result but with a clue : it stays blocked at loading bootx64.efi.

I just tried another way of creating my bootable usb key by following the archiso README : https://projects.archlinux.org/archiso. … EADME#n237
It results in the same situation.

I've tried the two ways a few times and with two different usb keys so i think i didn't miss any step. (The filesystem label is right)
The section of the wiki I mentionned is changing every day so maybe it's not ready ? Moreover, a new command has been added about removing a [BOOT] file, i don't have this file when extracting with bsdtar.

The md5sum of the iso is ok.
My computer is an ASUS N56VM.
Everything worked fine with the previous iso of archlinux.
I didn't find anyone on the forum with the same problem so if anybody knows how I should do or where I could get more information, I would be grateful. smile

PS : I'm sorry for the mistakes in english, this is not my mother tongue hmm .

Last edited by Takeo (2012-10-14 21:19:32)

Offline

#2 2012-10-10 14:58:36

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Why are you making a EFI System Partition for you USB key?  This is not necessary I don't think (unless it is some quirk specific to your machine).  You simply need to make a fat16 or fat32 partition, extract the contents of the iso to it and proceed from there.  I think maybe by making a ESP, the machine wants to load something from that, while in reality, you want it to be loading from the patition the iso is expanded to.

Offline

#3 2012-10-10 15:08:25

Takeo
Member
Registered: 2012-10-10
Posts: 3

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Thank you for your answer. I first tried like you say, only with a FAT32 partition, as described in the wiki. However, I also get a black screen. In this file : https://projects.archlinux.org/archiso. … EADME#n237 , they say to create an ESP.

Last edited by Takeo (2012-10-11 11:13:41)

Offline

#4 2012-10-12 01:00:48

felipec
Member
Registered: 2011-12-29
Posts: 10

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Takeo wrote:

All steps went right but when i try to boot with this key from the EFI menu, i get an infinite black screen and the usb key led isn't blinking so i suppose it's not loading.

I got the same issue. After hours of debugging I finally understand the problem: gummiboot doesn't detect any menu entry, and goes into a bug that hangs it. I have a patch to fix that particular bug, but instead of hanging you will see a proper error.

The real problem is in gnu-efi, which is not wrapping the Windows x86 calls correctly, so it's a matter of luck if the compiler manages to organize the code in a proper way.

You can try with this package: http://felipec.org/arch-linux/gummiboot … pkg.tar.xz

Offline

#5 2012-10-12 01:22:16

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

@felipc: Please report this in bug tracker with the patch and also upstream. This needs to be fixed since both archiso and archboot now use gummiboot. Is the same issue present in rEFInd and efilinux?

Offline

#6 2012-10-12 01:41:08

felipec
Member
Registered: 2011-12-29
Posts: 10

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

the.ridikulus.rat wrote:

@felipc: Please report this in bug tracker with the patch and also upstream. This needs to be fixed since both archiso and archboot now use gummiboot. Is the same issue present in rEFInd and efilinux?

I don't know. If they use gnu-efi, then probably yes.

Offline

#7 2012-10-12 02:36:36

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Your patch is for gummiboot or gnu-efi? Does it fix the actual issue or simply displays an error message without actually booting any menuentry?

EDIT: Is this issue fixed in gnu-efi 3.0r upstream release?

Last edited by the.ridikulus.rat (2012-10-12 02:41:36)

Offline

#8 2012-10-12 03:00:02

felipec
Member
Registered: 2011-12-29
Posts: 10

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

the.ridikulus.rat wrote:

Your patch is for gummiboot or gnu-efi? Does it fix the actual issue or simply displays an error message without actually booting any menuentry?

EDIT: Is this issue fixed in gnu-efi 3.0r upstream release?

I have fixes for both. The ones for gummiboot will prevent the hang, and will display the error message properly. The one for gnu-efi actually fixes the issue.

Offline

#9 2012-10-12 03:28:41

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Can you post the patches or src.tar.gz files for both pkgs in pastebin/dropbox?

Offline

#10 2012-10-12 03:33:14

felipec
Member
Registered: 2011-12-29
Posts: 10

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

The one for gummiboot is already in upstream:

http://cgit.freedesktop.org/gummiboot/c … efea5115a3

And here's the one for gnu-efi:

http://people.freedesktop.org/~felipec/ … -fix.patch

Offline

#11 2012-10-12 03:45:38

felipec
Member
Registered: 2011-12-29
Posts: 10

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Offline

#12 2012-10-12 08:11:24

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Is this issue fixed in updated extra/gummiboot-efi 6-2 pkg?

Offline

#13 2012-10-12 08:34:41

felipec
Member
Registered: 2011-12-29
Posts: 10

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

FTR. Once installed, copy /usr/lib/gummiboot/gummibootx64.efi to your USB /EFI/boot/bootx64.efi

Offline

#14 2012-10-12 13:17:08

12oz.oleg
Member
Registered: 2012-02-03
Posts: 7

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Copying new gummibootx64.efi (from both 6-2 and 7-1 pkg versions) to USB didn't solve the problem for me.

Last edited by 12oz.oleg (2012-10-12 13:17:50)

Offline

#15 2012-10-12 13:30:53

Takeo
Member
Registered: 2012-10-10
Posts: 3

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

Copying works fine for me. Thank you felipec and the.ridikulus.rat smile

Edit : Should we add something about it in the wiki ? Which configurations does it affect ?

Last edited by Takeo (2012-10-12 13:37:29)

Offline

#16 2012-10-12 13:42:45

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

@12oz.oleg: Your system info? What is the firmware spec. version?

Offline

#17 2012-10-12 16:55:25

12oz.oleg
Member
Registered: 2012-02-03
Posts: 7

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

HP 6930p notebook, latest BIOS rev.

Offline

#18 2012-10-12 20:35:50

felipec
Member
Registered: 2011-12-29
Posts: 10

Re: [SOLVED] Unable to boot Archiso USB in UEFI mode

@12oz.oleg: What instructions are you following? What problem exactly do you have?

Offline

Board footer

Powered by FluxBB