You are not logged in.

#1 2012-10-11 22:09:57

fredbezies
Member
Registered: 2011-07-28
Posts: 303

[gnome 3] PrintScreen key doesn't launch gnome-screenshot

Hello.

I'm facing a weird - I mean a very weird one - problem since I reinstalled from scratch a few days ago my computer.

Ok. I'm using archlinux + gnome 3 with testing repo enabled and fully up-to-date. And a fully systemd one if it is important.


1) Video : nouveau driver ; nvidia driver shows same problem
2) Installed gnome 3 fully : gnome + gnome extra + gnome-utils
3) All bindings are correctly set in gnome system preferences.

When I press PrintScreen, nothing happens. Nothing.  Gnome-screenshot from command line start and also when I search it.

I tried :

1) new key for screen capture : nothing
2) binding PrintScreen to launch another program : nothing
3) another keyboard : nothing

I didn't tweak anything just installed gnome, gnome extra and gnome utils on setup time.

If you have an idea, I'm glad to hear it.

By the way, my install is very genuine, no tweaks besides the window button ones and date, using gnome-tweak-tool. Only extension : alternative-status-menu.

Thanks.

Last edited by fredbezies (2012-10-11 22:30:45)

Offline

#2 2012-10-11 23:02:27

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 392

Re: [gnome 3] PrintScreen key doesn't launch gnome-screenshot

fredbezies wrote:

Hello.

I'm facing a weird - I mean a very weird one - problem since I reinstalled from scratch a few days ago my computer.

Ok. I'm using archlinux + gnome 3 with testing repo enabled and fully up-to-date. And a fully systemd one if it is important.


1) Video : nouveau driver ; nvidia driver shows same problem
2) Installed gnome 3 fully : gnome + gnome extra + gnome-utils
3) All bindings are correctly set in gnome system preferences.

When I press PrintScreen, nothing happens. Nothing.  Gnome-screenshot from command line start and also when I search it.

I tried :

1) new key for screen capture : nothing
2) binding PrintScreen to launch another program : nothing
3) another keyboard : nothing

I didn't tweak anything just installed gnome, gnome extra and gnome utils on setup time.

If you have an idea, I'm glad to hear it.

By the way, my install is very genuine, no tweaks besides the window button ones and date, using gnome-tweak-tool. Only extension : alternative-status-menu.

Thanks.

That is normal behavior. It takes a screenshot but presents no dialog so the screenshot is saved I beleive to your home directory. See this forum post: http://forums.linuxmint.com/viewtopic.php?f=47&t=103522

I just went into keyboard settings and remapped PrntScr to "gnome-screenshot --interactive". Now I get the dialog.


Registered Linux user #436067

Offline

#3 2012-10-12 05:36:50

fredbezies
Member
Registered: 2011-07-28
Posts: 303

Re: [gnome 3] PrintScreen key doesn't launch gnome-screenshot

oboedad55 wrote:

[...]

That is normal behavior. It takes a screenshot but presents no dialog so the screenshot is saved I beleive to your home directory. See this forum post: http://forums.linuxmint.com/viewtopic.php?f=47&t=103522

I just went into keyboard settings and remapped PrntScr to "gnome-screenshot --interactive". Now I get the dialog.

I have nothing. Not a flash, not a single saved screenshot. Nothing. I got this behaviour before, but not anymore. Remapping PrntScn doesn't work, as I said in my original post.

My laptop still get this behaviour, not more desktop computer. So there is a bug somewhere.

Well, any other idea ?

Thanks.

Offline

#4 2012-10-12 05:49:38

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 392

Re: [gnome 3] PrintScreen key doesn't launch gnome-screenshot

fredbezies wrote:
oboedad55 wrote:

[...]

That is normal behavior. It takes a screenshot but presents no dialog so the screenshot is saved I believe to your home directory. See this forum post: http://forums.linuxmint.com/viewtopic.php?f=47&t=103522

I just went into keyboard settings and remapped PrntScr to "gnome-screenshot --interactive". Now I get the dialog.

I have nothing. Not a flash, not a single saved screenshot. Nothing. I got this behaviour before, but not anymore. Remapping PrntScn doesn't work, as I said in my original post.

My laptop still get this behaviour, not more desktop computer. So there is a bug somewhere.

Well, any other idea ?

Thanks.

Ah, I didn't notice you were running testing. Sorry about that. Is this Gnome-shell 3.6 then? I'm still running 3.4.2, also with pure systemd, and don't have this issue. Perhaps it's a bug with the the new Gnome-shell. File a bug report?


Registered Linux user #436067

Offline

#5 2012-10-12 05:51:16

fredbezies
Member
Registered: 2011-07-28
Posts: 303

Re: [gnome 3] PrintScreen key doesn't launch gnome-screenshot

oboedad55 wrote:
fredbezies wrote:
oboedad55 wrote:

That is normal behavior. It takes a screenshot but presents no dialog so the screenshot is saved I believe to your home directory. See this forum post: http://forums.linuxmint.com/viewtopic.php?f=47&t=103522

I just went into keyboard settings and remapped PrntScr to "gnome-screenshot --interactive". Now I get the dialog.

I have nothing. Not a flash, not a single saved screenshot. Nothing. I got this behaviour before, but not anymore. Remapping PrntScn doesn't work, as I said in my original post.

My laptop still get this behaviour, not more desktop computer. So there is a bug somewhere.

Well, any other idea ?

Thanks.

Ah, I didn't notice you were running testing. Sorry about that. Is this Gnome-shell 3.6 then? I'm still running 3.4.2, also with pure systemd, and don't have this issue. Perhaps it's a bug with the the new Gnome-shell. File a bug report?

No. Still Gnome 3.4.2. Pure Systemd here too. So, it is very weird. Xorg bug, maybe ? Post on arch-general mailing list, no answer. Opening a bug, I will see.

EDIT : bug opened => https://bugs.archlinux.org/task/31910

Last edited by fredbezies (2012-10-12 05:59:36)

Offline

#6 2012-10-16 20:46:23

oboedad55
Member
From: Baku
Registered: 2011-04-05
Posts: 392

Re: [gnome 3] PrintScreen key doesn't launch gnome-screenshot

fredbezies wrote:
oboedad55 wrote:
fredbezies wrote:

I have nothing. Not a flash, not a single saved screenshot. Nothing. I got this behaviour before, but not anymore. Remapping PrntScn doesn't work, as I said in my original post.

My laptop still get this behaviour, not more desktop computer. So there is a bug somewhere.

Well, any other idea ?

Thanks.

Ah, I didn't notice you were running testing. Sorry about that. Is this Gnome-shell 3.6 then? I'm still running 3.4.2, also with pure systemd, and don't have this issue. Perhaps it's a bug with the the new Gnome-shell. File a bug report?

No. Still Gnome 3.4.2. Pure Systemd here too. So, it is very weird. Xorg bug, maybe ? Post on arch-general mailing list, no answer. Opening a bug, I will see.

EDIT : bug opened => https://bugs.archlinux.org/task/31910

OK, I added myself to the bug report. I now have no shortcut keys working.


Registered Linux user #436067

Offline

#7 2012-10-17 02:54:19

emtorres
Member
From: Corrientes, Argentina
Registered: 2010-03-03
Posts: 11
Website

Re: [gnome 3] PrintScreen key doesn't launch gnome-screenshot

Hi, here I had the same problem, in the meanwhile you can downgrade some packages:

downgrade xf86-input-evdev to 2.7.3-1
downgrade xorg-server to 1.12.4-1
downgrade xorg-server-common to 1.12.4-1

Offline

Board footer

Powered by FluxBB