You are not logged in.

#1 2012-10-12 09:44:09

pingpong
Member
From: Los Angeles
Registered: 2010-12-30
Posts: 96

[Solved] grub2 installation problem

I reinstall grub2 by following the wiki

# modprobe dm-mod
# grub-install --target=i386-pc --grub-setup=/bin/true --recheck --debug /dev/sda
# mkdir -p /boot/grub/locale
# cp /usr/share/locale/en@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo

the last step "cp..." resulted in a No space left on device error.

And now I cannot boot into my system anymore. I read the related discussion on this forum but don't seem to find this error being discussed.
Please help

Last edited by pingpong (2012-10-13 06:07:46)

Offline

#2 2012-10-12 10:31:11

pingpong
Member
From: Los Angeles
Registered: 2010-12-30
Posts: 96

Re: [Solved] grub2 installation problem

I moved the old locale directory to my home directory (boot the system with a liveCD, Parted Magic to be specific) and managed to copy the grub.mo file to /boot/grub/locale/en.mo

However, I got screwed up somewhere along the process and lost the grub.cfg that was generated by grub-mkconfig.

I guess I need some instructions on how to reinstall grub if I can only boot from a liveCD. I'm clueless on this. Really need and appreciate some help.

Offline

#3 2012-10-12 11:25:53

qinohe
Member
From: A Dutch location..)
Registered: 2012-06-20
Posts: 649

Re: [Solved] grub2 installation problem

Well, I don't know if it's a typo, but..
Your copy is different than the one in the wiki, should be;

# cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo

-I can give you a ladder, but you need to climb it yourself-

Offline

#4 2012-10-12 14:33:46

pingpong
Member
From: Los Angeles
Registered: 2010-12-30
Posts: 96

Re: [Solved] grub2 installation problem

It must be a typo then... although I was just copy-and-paste, strange.
In any case, I screwed up so the system is unusable now...

Offline

#5 2012-10-13 01:37:52

pingpong
Member
From: Los Angeles
Registered: 2010-12-30
Posts: 96

Re: [Solved] grub2 installation problem

Alright, I managed to use install lilo on the system and bootup. So a step forward.

But then again I try to install grub2 by following the wiki. This time it complains "Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting" when I ran

 
grub-install --target=i386-pc --recheck --debug /dev/sda

May I get some help on how to switch from lilo to grub2 ?

Thanks in advance

Offline

#6 2012-10-13 01:54:20

wizardskill
Member
From: US
Registered: 2012-08-23
Posts: 3
Website

Re: [Solved] grub2 installation problem

I followed the unofficial beginner's guide to install grub2, worked like a charm.


Arch Multilib & KDE

Offline

#7 2012-10-13 02:09:56

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [Solved] grub2 installation problem

If you got lilo working, I don't understand why you feel as though you need grub. 

In any case, if you insist on using grub, all you have to do is boot from a livecd (the arch install cd works great), and then chroot into your installation and reinstall.  I don't know that reinstallation of grub itself is necessary, so much as a recreation og grub.cfg. 

See here https://wiki.archlinux.org/index.php/Grub2

Offline

#8 2012-10-13 06:07:22

pingpong
Member
From: Los Angeles
Registered: 2010-12-30
Posts: 96

Re: [Solved] grub2 installation problem

You perfectly right WonderWoofy, Lilo is fine. Just that I screwed up by updating Grub so I felt like to get back up where I felt down.
I finally found and old Arch install CD (instead of using Parted magic) and did exactly when you said. My problem is solved now. Thanks for the suggestion.

Offline

Board footer

Powered by FluxBB