You are not logged in.

#1 2012-10-13 16:55:53

Registered: 2008-12-23
Posts: 11

TeX font installation with tllocalmgr

I installed a font (OpenSans) this morning for TeX Live through tllocalmgr and noticed that it doesn't update the updmap.cfg file with the proper "Map" command.  This caused an error when compiling my TeX document:

LaTeX Font Warning: Some font shapes were not available, defaults substituted.


kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 2+293/600 --dpi 1493 OpenSans-Regular-01
mktexpk: don't know how to create bitmap font for OpenSans-Regular-01.
mktexpk: perhaps OpenSans-Regular-01 is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.
(see the transcript file for additional information)
!pdfTeX error: pdflatex (file OpenSans-Regular-01): Font OpenSans-Regular-01 at

I needed the following line to /usr/share/texmf/web2c/updmap.cfg and rerun updmap or updmap-sys.


Hope this helps anyone else installing fonts on Arch Linux.


#2 2012-10-13 23:58:52

From: Cymru
Registered: 2011-11-27
Posts: 6,082

Re: TeX font installation with tllocalmgr

Note that I do not use Arch's version of TeX Live.

It is generally considered better to use updmap-sys than updmap. The latter can lead to weird, difficult to identify errors later. At least on a standard install, using updmap-sys is recommended unless you do not have that option (because you do not have permission to write to the system TeX trees, for example).

Also, is that really the correct tree to add the information to?

Last edited by cfr (2012-10-14 00:03:15)

How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L


Board footer

Powered by FluxBB