You are not logged in.

#1 2012-10-13 17:41:48

Registered: 2010-08-12
Posts: 93

[SOLVED] Ipython indentation Error


I get this error every time I start IPython2 in my home directory.  If I start if from any other directory, there is no error.  Any ideas on how to fix this?

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/IPython/", line 43, in <module>
    from .config.loader import Config
  File "/usr/lib/python2.7/site-packages/IPython/config/", line 16, in <module>
    from .application import *
  File "/usr/lib/python2.7/site-packages/IPython/config/", line 29, in <module>
    from IPython.external.decorator import decorator
  File "/usr/lib/python2.7/site-packages/IPython/external/decorator/", line 4, in <module>
    from _decorator import *
  File "/usr/lib/python2.7/site-packages/IPython/external/decorator/", line 39, in <module>
    import sys, re, inspect
  File "/usr/lib/python2.7/", line 39, in <module>
    import tokenize
  File "", line 13
IndentationError: expected an indented block

Last edited by ayr0 (2013-03-06 08:23:53)


#2 2012-10-15 15:31:55

Registered: 2009-01-22
Posts: 114

Re: [SOLVED] Ipython indentation Error

Dumb question - you don't have a file in your home directory, do you? I've gotten busted by that type of problem more times than I care to admit.


Linux User #353 - SLS -> Slackware -> Red Hat -> Mandrake -> Fedora -> Arch


#3 2013-03-06 08:23:38

Registered: 2010-08-12
Posts: 93

Re: [SOLVED] Ipython indentation Error

I realize this is old.  I kept having the same problem, and when I searched the forums, found my old thread.

So, yeah, I had a in my home directory. I removed it and everything works like a charm!  Marking as solved.


Board footer

Powered by FluxBB