You are not logged in.

#1 2012-10-14 11:41:36

GregW
Member
From: 53°24'N 2°35'W
Registered: 2008-02-09
Posts: 56

timestamps in dmesg

Hi all

since a recent update ( I think it's related to syslog-ng or systemd) my dmesg logs are filled with kernel timestamps even though I've had them disabled with print.time=N on my kernel line in grub for a very long time.


I've looked though syslog-ng.conf but I can't see anything related to time stamps.

I used a custom kernel and the kernel debug message PRINTK_TIME=n is set so I can't see what's turning on the timing messages. If a userspace tool is doing this, it shouldn't as I've disabled it at the kernel level.

What next to check?
Thanks
GregW

Offline

#2 2012-10-14 12:28:41

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: timestamps in dmesg

Why wouldn't you suspect dmesg? use -t, --notime to get rid of the timestamps.

Offline

#3 2012-10-14 13:08:28

GregW
Member
From: 53°24'N 2°35'W
Registered: 2008-02-09
Posts: 56

Re: timestamps in dmesg

falconindy wrote:

Why wouldn't you suspect dmesg? use -t, --notime to get rid of the timestamps.

probably because I've disabled at kernel level the time stamps! why would a userspace tool default to turning them on? cat /var/log/boot shows them as having been logged.

cat /var/log/boot
Fri Jul 20 19:21:28 2012: :: Adjusting system time and setting kernel timezone    [BUSY]    [DONE] 
Fri Jul 20 19:21:28 2012: :: Starting UDev Daemon    [BUSY]    [DONE] 
Fri Jul 20 19:21:28 2012: :: Triggering UDev uevents    [BUSY]    [DONE] 

as do other logs.

I shouldn't have to use a switch that I've never had to use in the past.  Time for a bug report.

Offline

#4 2012-10-14 13:42:21

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,095
Website

Re: timestamps in dmesg

Welcome to the ever changing world of open source. Linux 3.5 introduced structured logging, which dmesg now reads as of util-linux 2.22. By default, this includes timestamps which most people will find to be hugely beneficial in their logs for the purposes of troubleshooting.

Offline

#5 2012-10-14 13:57:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: timestamps in dmesg

I'm not using any switch with 'dmesg', but /var/log/boot indeed shows timestamps:

$ dmesg | tail
[    9.662139] EXT4-fs (sda3): re-mounted. Opts: (null)
[    9.776824] EXT4-fs (sda1): mounting ext2 file system using the ext4 subsystem
[    9.781108] EXT4-fs (sda1): mounted filesystem without journal. Opts: (null)
[    9.825871] EXT4-fs (sda4): mounting ext3 file system using the ext4 subsystem
[    9.951467] EXT4-fs (sda4): mounted filesystem with ordered data mode. Opts: (null)
[    9.987777] Adding 265068k swap on /dev/sda2.  Priority:-1 extents:1 across:265068k 
[   12.965433] Adding 255996k swap on /dev/zram0.  Priority:60 extents:1 across:255996k SS
[   13.077880] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   13.080198] e100 0000:02:08.0: eth0: NIC Link is Up 100 Mbps Full Duplex
[   13.080751] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
$ tail /var/log/boot
Sun Oct 14 12:56:26 2012: INIT: Entering runlevel: 3
Sun Oct 14 12:56:26 2012: :: Starting Syslog-NG    [BUSY]    [DONE] 
Sun Oct 14 12:56:27 2012: :: Starting D-BUS system messagebus    [BUSY]    [DONE] 
Sun Oct 14 12:56:28 2012: :: Starting acpid    [BKGD] 
Sun Oct 14 12:56:28 2012: :: Starting network    [BKGD] 
Sun Oct 14 12:56:28 2012: :: Starting crond    [BKGD] 
Sun Oct 14 12:56:28 2012: :: Starting alsa    [BKGD] 
Sun Oct 14 12:56:28 2012: :: Starting vnstat    [BKGD] 
Sun Oct 14 12:56:28 2012: Setting up swapspace version 1, size = 255996 KiB
Sun Oct 14 12:56:28 2012: no label, UUID=467ff282-5acf-4367-9e8e-76e4ed35361a

BTW, is there a way to localize the timestamps the way I can do with 'date':

$ LC_TIME=C date
Sun Oct 14 15:50:34 CEST 2012
$ date
nie, 14 paź 2012, 15:50:35 CEST

I'd love to find a way to display the timestamps the way that makes sense to me.

Offline

Board footer

Powered by FluxBB