You are not logged in.

#1 2012-10-14 12:19:01

From: Poland
Registered: 2011-05-11
Posts: 28

Toshiba L500-1eq Wi-Fi doesn't show up in lspci, RF-Kill

I've got a Toshiba L500-1EQ laptop, which doesn't have a physical Wi-Fi switch. I just installed ArchLinux on it and after using NetworkManager and ehernet input I've decided to use it's build in Wi-Fi. Since It works on Windows and WAS working on Linux about a year ago (when I've had Arch on it for a short period of time due to later sound problems) I wasn't expecting any problems. But there was one...

NetworkManager tells me, that it can't look up wireless connections, because wi-fi is turned off using a hardware switch. I've tried to get it running using

# ip link set dev wlan0 up

but was told, that it's impossible due to a RF-kill. Running:

# rfkill list
0: phy0: Wireless LAN
     Soft blocked: no
    Hard blocked: yes

I see, that Wi-Fi is hard blocked. I'ts weird, because the Wi-Fi LED is turned on, and everything works on Windows. Using the Fn+F8 (it's Wi-Fi keys) I only swap between it's "Soft blocked" status(Yes/No)

And the weirdest part... Although it shows up using ip link it doesn't when using lspci. I can only see the Ethernet controller.

What should I do?

Last edited by turekpolski (2012-10-14 12:19:24)

Registered Linux User #511180


#2 2012-10-14 13:16:43

Registered: 2009-08-25
Posts: 3,575

Re: Toshiba L500-1eq Wi-Fi doesn't show up in lspci, RF-Kill

Maybe it's an usb device, check with lsusb. And post the output of lsmod.

Also, have you tried using something other than NetworkManager, like netcfg? Does "iwlist wlan0 scan" produce any results? Could be rfkill says the wifi is hardblocked even though it isn't, so the trick is ignoring what rfkill says.


Board footer

Powered by FluxBB