You are not logged in.

#1 2012-10-15 17:55:46

Registered: 2011-12-22
Posts: 24

[Solved] gcc-multilib 4.7.2 problem

Hi, I am trying to compile a program that worked/compiled on thursday 4 days ago on the same machine and now I get a strange error...
(the program is school assignment)

make: *** No rule to make target `/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.1/include/stddef.h', needed by `SimpleViewer.o'.  Stop.

After I tried to make the link: 4.7.1 -> 4.7.2 as shown here

I get:

make: *** No rule to make target `/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.1/../../../../include/c++/4.7.1/cmath', needed by `SimpleViewer.o'.  Stop.

Which I can't seem to figure out... why does make 'think' that 7.4.1 is the current version ?

Also I noticed that netbeans warns me about "unresolved includes" inside <string>,<stdexcept>, <boost/lexical_cast.hpp>, <glm/glm.hpp>... the list keeps going..

Seems like something got broken right after the update of gcc ??
Anybody able to help ?

I figured out a temporary fix... So if anybody else has the same problem, downgrading the packages seems like the only option atm:

sudo pacman-color -Udd /var/cache/pacman/pkg/lib32-gcc-libs-4.7.1-6-x86_64.pkg.tar.xz /var/cache/pacman/pkg/gcc-libs-multilib-4.7.1-6-x86_64.pkg.tar.xz /var/cache/pacman/pkg/gcc-multilib-4.7.1-6-x86_64.pkg.tar.xz 

However that is a temporary solution...

Last edited by sidra (2012-10-26 20:46:10)


#2 2012-10-26 20:45:54

Registered: 2011-12-22
Posts: 24

Re: [Solved] gcc-multilib 4.7.2 problem

Never mind... I forgot to clean the folder of old *.o *.dep files in it...

Here is what happened in more detail:

I was using a Makefile that was pre-made for the assignment/s and had compiled the program before...
Then I tried to re-compile after update, but didn't notice that the makefile actually saves a make.dep file...
And the make.dep file had the old libraries in it o_O.

Lesson learned: Allways check the make dir & makefile...



Board footer

Powered by FluxBB