You are not logged in.

#1 2012-10-16 19:51:11

lobachevsky
Member
Registered: 2012-08-19
Posts: 6

Resume after suspend suspends again

Hi,

for the last two weeks I've been experiencing some weird ACPI behaviour. When I resume after suspending with pm-suspend my system immediately suspends again. Shortly before suspending again the screen blanks and shows a line like this

[   98.602112] ACPI: Unable to dock!

After it suspended again, the system can be resumed normally.

The system is a X230 with a full disk encryption. The suspend is done by calling pm-suspend with acpid. For further power management I use laptop-mode-tools, but the problem persists even after disabling it. Furthermore the problem can be reproduced on battery as well as AC.
I tried looking around, but have only found people having similar problems on hibernate and never any satisfying solutions. Has anyone ever experienced this problem and found a solution?

The relevant dmesg output is

[   98.139750] ACPI: Low-level resume complete
[   98.139785] PM: Restoring platform NVS memory
[   98.140189] Extended CMOS year: 2000
[   98.140208] Enabling non-boot CPUs ...
[   98.146952] Booting Node 0 Processor 1 APIC 0x1
[   98.226464] CPU1 is up
[   98.229850] Booting Node 0 Processor 2 APIC 0x2
[   98.309586] CPU2 is up
[   98.309636] Booting Node 0 Processor 3 APIC 0x3
[   98.389393] CPU3 is up
[   98.392736] ACPI: Waking up from system sleep state S3
[   98.578985] ACPI: \_SB_.PCI0.LPC_.EC__.BAT1 - docking
[   98.602112] ACPI: Unable to dock!
[   98.695344] xhci_hcd 0000:00:14.0: >wake-up capability disabled by ACPI
[   98.695354] xhci_hcd 0000:00:14.0: >power state changed by ACPI to D0
[   98.695357] xhci_hcd 0000:00:14.0: >power state changed by ACPI to D0
[   98.695504] ehci_hcd 0000:00:1a.0: >wake-up capability disabled by ACPI
[   98.695511] ehci_hcd 0000:00:1a.0: >power state changed by ACPI to D0
[   98.695514] ehci_hcd 0000:00:1a.0: >power state changed by ACPI to D0
[   98.695835] ehci_hcd 0000:00:1d.0: >wake-up capability disabled by ACPI
[   98.695842] ehci_hcd 0000:00:1d.0: >power state changed by ACPI to D0
[   98.695845] ehci_hcd 0000:00:1d.0: >power state changed by ACPI to D0
[   98.696233] sdhci-pci 0000:02:00.0: >MMC controller base frequency changed to 50Mhz.
[   98.696841] PM: noirq resume of devices complete after 1.637 msecs
[   98.696952] PM: early resume of devices complete after 0.084 msecs
[   98.697001] xhci_hcd 0000:00:14.0: >power state changed by ACPI to D0
[   98.697162] ehci_hcd 0000:00:1a.0: >power state changed by ACPI to D0
[   98.697164] e1000e 0000:00:19.0: >irq 44 for MSI/MSI-X
[   98.697168] ehci_hcd 0000:00:1d.0: >power state changed by ACPI to D0
[   98.697177] xhci_hcd 0000:00:14.0: >power state changed by ACPI to D0
[   98.697187] xhci_hcd 0000:00:14.0: >setting latency timer to 64
[   98.697227] snd_hda_intel 0000:00:1b.0: >irq 47 for MSI/MSI-X
[   98.697242] ahci 0000:00:1f.2: >setting latency timer to 64
[   98.697433] ehci_hcd 0000:00:1a.0: >power state changed by ACPI to D0
[   98.697442] ehci_hcd 0000:00:1a.0: >setting latency timer to 64
[   98.697461] ehci_hcd 0000:00:1d.0: >power state changed by ACPI to D0
[   98.697470] ehci_hcd 0000:00:1d.0: >setting latency timer to 64
[   98.697511] i915 0000:00:02.0: >power state changed by ACPI to D0
[   98.697514] i915 0000:00:02.0: >power state changed by ACPI to D0
[   98.697520] i915 0000:00:02.0: >setting latency timer to 64
[   98.724116] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
[   98.934829] usb 3-1.6: >reset high-speed USB device number 4 using ehci_hcd
[   99.034359] ata2: SATA link down (SStatus 0 SControl 300)
[   99.034447] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[   99.035035] ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
[   99.035039] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[   99.035774] ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
[   99.035777] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[   99.036070] ata1.00: configured for UDMA/133
[   99.041012] ata5: SATA link down (SStatus 0 SControl 300)
[   99.061091] sd 0:0:0:0: >[sda] Starting disk
[   99.231087] PM: resume of devices complete after 535.501 msecs
[   99.231683] PM: Finishing wakeup.

Offline

#2 2012-10-16 19:55:01

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 812

Re: Resume after suspend suspends again

Are you using systemd? If yes, please read here: https://wiki.archlinux.org/index.php/Sy … th_systemd . This is the cause of your troubles.

Offline

#3 2012-10-16 20:31:39

lobachevsky
Member
Registered: 2012-08-19
Posts: 6

Re: Resume after suspend suspends again

Thank you very much, that solved to problem. Damn I didn't think of that myself. Should've read the changelogs on the last few systemd updates, since I had those options commented out/never uncommented them and falsely assumed to standard behaviour for systemd would be to ignore ACPI signals if the handlers are commented out in logind.conf, since the problem only came up recently. Well, thanks again.

Offline

#4 2013-01-22 00:44:59

wlmeng11
Member
Registered: 2012-11-17
Posts: 6

Re: Resume after suspend suspends again

Thanks! I was wondering why the power management options in XFCE weren't working properly. Now I know.

Offline

#5 2013-01-26 22:29:12

abruptadieu
Member
Registered: 2011-03-14
Posts: 10

Re: Resume after suspend suspends again

Thank you thank you!!! I've been having the same problem with XFCE.

The link has changed:
https://wiki.archlinux.org/index.php/Sy … management

Also, for the sake of better keyword indexing, these are the Google search terms I tried before I successfully reached this:
double suspend
suspend after resume
xfce
arch linux

Offline

#6 2013-02-21 12:26:00

josephk
Member
Registered: 2011-01-09
Posts: 97
Website

Re: Resume after suspend suspends again

HandleLidSwitch=ignore solved my problem on kde.
this is a kde bug, since it supports logind.

Offline

#7 2013-07-28 14:19:04

yru
Member
Registered: 2013-07-28
Posts: 1

Re: Resume after suspend suspends again

Everyone is talking about systemd, but on RHEL 6 there is no systemd installed and also it is not supported. But I am still seeing the exact problem as described in the original question. This is on x230 lenovo.

Linux OS ver
Linux  xxxxxxxxxxxxxxxxx 2.6.32-358.11.1.el6.x86_64 #1 SMP Wed May 15 10:48:38 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux

But currently the os is using pm_utils to do shutdown, suspend and hibernate etc.,

I couldn't suspend, hibernate nor shutdown. system wakes up in all three modes.

Any help would be much appreciated.

Last edited by yru (2013-07-28 14:20:01)

Offline

Board footer

Powered by FluxBB